forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-libs/opensubdiv: Add CUDA 9 compatibility patch
Closes: https://bugs.gentoo.org/641242 Closes: gentoo#6624
- Loading branch information
1 parent
56f6570
commit 02baca5
Showing
2 changed files
with
29 additions
and
3 deletions.
There are no files selected for viewing
25 changes: 25 additions & 0 deletions
25
media-libs/opensubdiv/files/opensubdiv-3.3.0-add-CUDA9-compatibility.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,25 @@ | ||
From 7b9157bca7138480c387ef3d5b69b6cf1eb498e5 Mon Sep 17 00:00:00 2001 | ||
From: "Daniel M. Weeks" <[email protected]> | ||
Date: Fri, 15 Dec 2017 22:45:55 -0500 | ||
Subject: [PATCH] CUDA 9 compatible gpu-architecture default | ||
|
||
--- | ||
CMakeLists.txt | 4 +++- | ||
1 file changed, 3 insertions(+), 1 deletion(-) | ||
|
||
diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
index 4f3cd9d4..fa438b46 100644 | ||
--- a/CMakeLists.txt | ||
+++ b/CMakeLists.txt | ||
@@ -513,8 +513,10 @@ if(CUDA_FOUND) | ||
if (NOT DEFINED OSD_CUDA_NVCC_FLAGS) | ||
if (CUDA_VERSION_MAJOR LESS 6) | ||
set( OSD_CUDA_NVCC_FLAGS --gpu-architecture compute_11 ) | ||
- else() | ||
+ elseif (CUDA_VERSION_MAJOR LESS 9) | ||
set( OSD_CUDA_NVCC_FLAGS --gpu-architecture compute_20 ) | ||
+ else() | ||
+ set( OSD_CUDA_NVCC_FLAGS --gpu-architecture compute_30 ) | ||
endif() | ||
endif() | ||
endif() |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters