Skip to content

Commit

Permalink
media-libs/opensubdiv: Add CUDA 9 compatibility patch
Browse files Browse the repository at this point in the history
  • Loading branch information
dracwyrm authored and SoapGentoo committed Dec 24, 2017
1 parent 56f6570 commit 02baca5
Show file tree
Hide file tree
Showing 2 changed files with 29 additions and 3 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,25 @@
From 7b9157bca7138480c387ef3d5b69b6cf1eb498e5 Mon Sep 17 00:00:00 2001
From: "Daniel M. Weeks" <[email protected]>
Date: Fri, 15 Dec 2017 22:45:55 -0500
Subject: [PATCH] CUDA 9 compatible gpu-architecture default

---
CMakeLists.txt | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4f3cd9d4..fa438b46 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -513,8 +513,10 @@ if(CUDA_FOUND)
if (NOT DEFINED OSD_CUDA_NVCC_FLAGS)
if (CUDA_VERSION_MAJOR LESS 6)
set( OSD_CUDA_NVCC_FLAGS --gpu-architecture compute_11 )
- else()
+ elseif (CUDA_VERSION_MAJOR LESS 9)
set( OSD_CUDA_NVCC_FLAGS --gpu-architecture compute_20 )
+ else()
+ set( OSD_CUDA_NVCC_FLAGS --gpu-architecture compute_30 )
endif()
endif()
endif()
7 changes: 4 additions & 3 deletions media-libs/opensubdiv/opensubdiv-3.3.0.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -12,7 +12,7 @@ SRC_URI="https://github.com/PixarAnimationStudios/OpenSubdiv/archive/v${MY_PV}.t
LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="cuda doc opencl openmp ptex tbb"
IUSE="cuda doc examples opencl openmp ptex tbb tutorials"

RDEPEND="media-libs/glew:=
media-libs/glfw:=
Expand All @@ -32,6 +32,7 @@ S="${WORKDIR}/OpenSubdiv-${MY_PV}"
PATCHES=(
"${FILESDIR}/${P}-fix-quotes.patch"
"${FILESDIR}/${P}-use-gnuinstalldirs.patch"
"${FILESDIR}/${P}-add-CUDA9-compatibility.patch"
)

pkg_pretend() {
Expand All @@ -53,8 +54,8 @@ src_configure() {
-DNO_OPENCL=$(usex !opencl)
-DNO_CUDA=$(usex !cuda)
-DNO_REGRESSION=1 # They don't work with certain settings
-DNO_EXAMPLES=1 # Not needed.
-DNO_TUTORIALS=1 # They install illegally. Need to find a better solution.
-DNO_EXAMPLES=$(usex !examples)
-DNO_TUTORIALS=$(usex !tutorials)
-DGLEW_LOCATION="${EPREFIX}/usr/$(get_libdir)"
-DGLFW_LOCATION="${EPREFIX}/usr/$(get_libdir)"
-DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
Expand Down

0 comments on commit 02baca5

Please sign in to comment.