Skip to content

Commit

Permalink
dev-python/traitlets: Version bump to 4.3.2
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.3
Closes: gentoo#4061
  • Loading branch information
marbre authored and SoapGentoo committed Feb 25, 2017
1 parent 5971b1c commit 0327fa0
Show file tree
Hide file tree
Showing 2 changed files with 56 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/traitlets/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST traitlets-4.0.0.tar.gz 63701 SHA256 0b140b4a94a4f1951887d9bce4650da211f7960
DIST traitlets-4.1.0.tar.gz 76828 SHA256 440e38dfa5d2a26c086d4b427cfb7aed17d0a2dca78bce90c33354da2592af5b SHA512 4000ca3014b3916a16735b0c96b4290ca25a750bc97ae1d65ed7932e84db1d414ae6d0955192a806e878fb4e6769763296474cadf153673fcae7b41f5887a235 WHIRLPOOL b20ff505681cd570d88bb380289f93fe1a880eb873645090b14acc946fa6a5f4595e086390021970fcca31518eb2363ef91779e781ee81d63fd87560478e7d2b
DIST traitlets-4.2.2.tar.gz 79332 SHA256 7d7e3070484b2fe490fa55e0acf7023afc5ed9ddabec57405f25c355158e152a SHA512 1deff1dea59d4f0616510f2f80bc990db3626b83c32784658f3f273ed093221760ca9832bbdbaa15a85cb8cd5c89a795f941b439b244bfd5d390da826f7a69a5 WHIRLPOOL ada46ed15c8b8e822dc6480472c97e559532e0ec1cfb5bea83c6c83f1b2974f475512daf0026c57dd78978dcc6c416411dac2d1af3d51bd06d23358b1c0d3fa2
DIST traitlets-4.3.1.tar.gz 88108 SHA256 ba8c94323ccbe8fd792e45d8efe8c95d3e0744cc8c085295b607552ab573724c SHA512 f68f381c3233a7703d8888a2eda15ccae6ca70a8d0e93d03eb6d646205fe24d03a116c8f1f8ee6d4470eb6267880e8e91c9e2354f1b551b798b6e1b2d80deed5 WHIRLPOOL 39998d12836822bdda2b36f3d92c893e256a47e1c329001b4dd22b438cc91aa7be0b00f0f924a9ab63a019e5be552f104c1b449943a02d044220a5e7a6d45a74
DIST traitlets-4.3.2.tar.gz 88173 SHA256 9c4bd2d267b7153df9152698efb1050a5d84982d3384a37b2c1f7723ba3e7835 SHA512 4f3239bc31af224814c8181dd1ac0fe5287160aee48b2b0f54afae841c8a9d7eaed010082044b6d16f91cd970bf0aa1eeba57d4503dd919fc8c4613ac5150ca9 WHIRLPOOL f61682a9b5a49417d385cb4e3dfac8c51d844883ef8fb5665f9a3988dcf4297da03ee0326bac6c24bb9812f7397d181a37d6c2334f2dd5521592e5b99beab1e3
55 changes: 55 additions & 0 deletions dev-python/traitlets/traitlets-4.3.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,55 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PYTHON_COMPAT=( python2_7 python3_{4,5} )

inherit distutils-r1

DESCRIPTION="A configuration system for Python applications"
HOMEPAGE="https://github.com/ipython/traitlets"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="doc test"

RDEPEND="
dev-python/decorator[${PYTHON_USEDEP}]
$(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*')
dev-python/ipython_genutils[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
"
DEPEND="
doc? (
dev-python/ipython_genutils[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
)
test? (
$(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2*')
dev-python/pytest-cov[${PYTHON_USEDEP}]
)
"

python_prepare_all() {
# Prevent un-needed download during build
if use doc; then
sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
fi

distutils-r1_python_prepare_all
}

python_compile_all() {
if use doc; then
emake -C docs html
HTML_DOCS=( docs/build/html/. )
fi
}

python_test() {
py.test --cov traitlets -v traitlets || die
}

0 comments on commit 0327fa0

Please sign in to comment.