Skip to content

Commit

Permalink
app-crypt/codecrypt: update EAPI 6 -> 8
Browse files Browse the repository at this point in the history
Signed-off-by: David Seifert <[email protected]>
  • Loading branch information
SoapGentoo committed May 18, 2023
1 parent 8d8ee54 commit 03396ea
Show file tree
Hide file tree
Showing 2 changed files with 24 additions and 9 deletions.
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EAPI=8

inherit autotools

Expand All @@ -14,18 +14,20 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="+cryptopp"

DEPEND="dev-libs/gmp:=
cryptopp? ( >=dev-libs/crypto++-7:= )
sci-libs/fftw:3.0="
DEPEND="
dev-libs/gmp:=
sci-libs/fftw:3.0=
cryptopp? ( >=dev-libs/crypto++-7:= )"
RDEPEND="${DEPEND}"
BDEPEND="virtual/pkgconfig"

PATCHES=( "${FILESDIR}"/${P}-libcryptopp.pc-rename.patch )

src_prepare() {
default
# workaround -- the library renamed the pkg-config file
sed -i -e 's/PKG_CHECK_MODULES(\[CRYPTOPP\],.*/PKG_CHECK_MODULES([CRYPTOPP], [libcryptopp])/' configure.ac || die
eautoreconf
}

src_configure() {
econf \
$(use_with cryptopp)
econf $(use_with cryptopp)
}
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
workaround -- the library renamed the pkg-config file

--- a/configure.ac
+++ b/configure.ac
@@ -37,7 +37,7 @@

PKG_PROG_PKG_CONFIG([0.25])

- PKG_CHECK_MODULES([CRYPTOPP],[libcrypto++])
+ PKG_CHECK_MODULES([CRYPTOPP],[libcryptopp])

#crypto++ headers are either in include/crypto++ or include/cryptopp,
#the information is otherwise unavailable from standard configuration

0 comments on commit 03396ea

Please sign in to comment.