Skip to content

Commit

Permalink
games-emulation/mupen64plus-input-sdl: Bump to 2.5.9
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Sep 15, 2019
1 parent 7c81377 commit 034d92a
Show file tree
Hide file tree
Showing 2 changed files with 77 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-emulation/mupen64plus-input-sdl/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST mupen64plus-input-sdl-src-2.5.9.tar.gz 56403 BLAKE2B 56d6c390783aa4a7f25f72a5295eb11f1ca2a69f2ffe4f0232d4a0c329e9c0eba0a2cbf46e66adfdf0462d2ec5337f7c6c4587ae29de346cd4cfe1d240f4d5fd SHA512 b613396ee05e82aaaf15e955f83b5cb4e854df1fdb34d5e1c96cf0fddf0af79aa5af2ceb19cc9cfeaef707c2ecafd25e0814e3d7715a20b740482d0ece273f2f
DIST mupen64plus-input-sdl-src-2.5.tar.gz 50580 BLAKE2B ab75c6e200c2979c75d35082a426266e7f835e0731058f8013d8788802ab9d65363b8820326fbfedc0b384facfaeccf6e04da66e01f79aee3d420f3ebe385461 SHA512 014a5e21feb88b14bcee44a74556a257393b799745308421a611eb3b6c11a390a589fdd393f07e69a128ca60426d4dcf8847bcbabed77b0d570be282550148d6
Original file line number Diff line number Diff line change
@@ -0,0 +1,76 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

MY_P=${PN}-src-${PV}
inherit toolchain-funcs

DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, SDL input plugin"
HOMEPAGE="https://www.mupen64plus.org/"
SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

RDEPEND=">=games-emulation/mupen64plus-core-${PV}:0=
media-libs/libsdl2:0=[joystick]"
DEPEND="${RDEPEND}
virtual/pkgconfig"

S=${WORKDIR}/${MY_P}

src_prepare() {
default

# avoid implicitly appending CPU flags
sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
}

src_compile() {
MAKEARGS=(
# Note: please keep this in sync in all of mupen64plus-* packages

-C projects/unix

# this basically means: GNU userspace
UNAME=Linux

# verbose output
V=1

CROSS_COMPILE="${CHOST}-"
CC="$(tc-getCC)"
CXX="$(tc-getCXX)"
PKG_CONFIG="$(tc-getPKG_CONFIG)"
# usual CFLAGS, CXXFLAGS and LDFLAGS are respected
# so we can leave OPTFLAGS empty
OPTFLAGS=

# paths, some of them are used at compile time
PREFIX=/usr
LIBDIR=/usr/$(get_libdir)

# disable unwanted magic
LDCONFIG=:
INSTALL_STRIP_FLAG=

# Package-specific stuff

# CROSS_COMPILE causes it to look for ${CHOST}-sdl2-config...
SDL_CFLAGS="$($(tc-getPKG_CONFIG) --cflags sdl2)"
SDL_LDLIBS="$($(tc-getPKG_CONFIG) --libs sdl2)"
)

use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
use x86 && MAKEARGS+=( HOST_CPU=i386 )

emake "${MAKEARGS[@]}" all
}

src_install() {
emake "${MAKEARGS[@]}" DESTDIR="${D}" install
dodoc AUTHORS README.md RELEASE
}

0 comments on commit 034d92a

Please sign in to comment.