forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-scheme/guile-colorized: new package; add version 0.1_p20191205 an…
…d live Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <[email protected]>
- Loading branch information
Showing
4 changed files
with
92 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
DIST guile-colorized-0.1_p20191205.tar.bz2 15496 BLAKE2B a85fc44c3b6b8433362197a4f1da216ea99793673ee4592e6ea32178d2952d0f43f5a4e79304185d0c67b6dee668bf52d53970df97954a37650cd8b7770e7abd SHA512 4cd9833c70debf0086ba69252e1fb8b9fc33707ec1f3bb6dfb144d5a35db6f38e3af585cbc889936c8ebb38dea0f8808f483bd51ed1722c9b9df857d31a7cec7 |
39 changes: 39 additions & 0 deletions
39
dev-scheme/guile-colorized/guile-colorized-0.1_p20191205.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,39 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
DESCRIPTION="Colorized REPL for GNU Guile" | ||
HOMEPAGE="https://gitlab.com/NalaGinrut/guile-colorized/" | ||
|
||
if [[ "${PV}" == *9999* ]]; then | ||
inherit git-r3 | ||
EGIT_REPO_URI="https://gitlab.com/NalaGinrut/${PN}.git" | ||
else | ||
# Latest release (before this commit from 2019) was in 2015 | ||
COMMIT_SHA="1625a79f0e31849ebd537e2a58793fb45678c58f" | ||
SRC_URI="https://gitlab.com/NalaGinrut/${PN}/-/archive/${COMMIT_SHA}.tar.bz2 -> ${P}.tar.bz2" | ||
KEYWORDS="~amd64" | ||
S="${WORKDIR}/${PN}-${COMMIT_SHA}" | ||
fi | ||
|
||
LICENSE="GPL-3" | ||
SLOT="0" | ||
|
||
RDEPEND=">=dev-scheme/guile-2.0.9:=" | ||
DEPEND="${DEPEND}" | ||
|
||
src_prepare() { | ||
default | ||
|
||
# http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112 | ||
find "${S}" -name "*.scm" -exec touch {} + || die | ||
} | ||
|
||
src_install() { | ||
einstalldocs | ||
|
||
local loadpath=$(guile -c '(display (string-append (car %load-path) "/ice-9"))') | ||
mkdir -p "${D}${loadpath}" | ||
emake TARGET="${D}${loadpath}" install | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,39 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
DESCRIPTION="Colorized REPL for GNU Guile" | ||
HOMEPAGE="https://gitlab.com/NalaGinrut/guile-colorized/" | ||
|
||
if [[ "${PV}" == *9999* ]]; then | ||
inherit git-r3 | ||
EGIT_REPO_URI="https://gitlab.com/NalaGinrut/${PN}.git" | ||
else | ||
# Latest release (before this commit from 2019) was in 2015 | ||
COMMIT_SHA="1625a79f0e31849ebd537e2a58793fb45678c58f" | ||
SRC_URI="https://gitlab.com/NalaGinrut/${PN}/-/archive/${COMMIT_SHA}.tar.bz2 -> ${P}.tar.bz2" | ||
KEYWORDS="~amd64" | ||
S="${WORKDIR}/${PN}-${COMMIT_SHA}" | ||
fi | ||
|
||
LICENSE="GPL-3" | ||
SLOT="0" | ||
|
||
RDEPEND=">=dev-scheme/guile-2.0.9:=" | ||
DEPEND="${DEPEND}" | ||
|
||
src_prepare() { | ||
default | ||
|
||
# http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112 | ||
find "${S}" -name "*.scm" -exec touch {} + || die | ||
} | ||
|
||
src_install() { | ||
einstalldocs | ||
|
||
local loadpath=$(guile -c '(display (string-append (car %load-path) "/ice-9"))') | ||
mkdir -p "${D}${loadpath}" | ||
emake TARGET="${D}${loadpath}" install | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,13 @@ | ||
<?xml version="1.0" encoding="UTF-8"?> | ||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd"> | ||
|
||
<pkgmetadata> | ||
<maintainer type="project"> | ||
<email>[email protected]</email> | ||
<name>Gentoo Scheme Project</name> | ||
</maintainer> | ||
<upstream> | ||
<bugs-to>https://gitlab.com/NalaGinrut/guile-colorized/-/issues</bugs-to> | ||
<remote-id type="gitlab">NalaGinrut/guile-colorized</remote-id> | ||
</upstream> | ||
</pkgmetadata> |