Skip to content

Commit

Permalink
dev-cpp/libcmis: Add USE tools
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.64, Repoman-2.3.12
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Apr 21, 2019
1 parent 3b1e04f commit 0369fd9
Show file tree
Hide file tree
Showing 3 changed files with 78 additions and 19 deletions.
66 changes: 66 additions & 0 deletions dev-cpp/libcmis/libcmis-0.5.2-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,66 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

if [[ ${PV} = 9999 ]]; then
EGIT_REPO_URI="https://github.com/tdf/libcmis.git"
inherit git-r3
else
SRC_URI="https://github.com/tdf/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
fi
inherit autotools flag-o-matic

DESCRIPTION="C++ client library for the CMIS interface"
HOMEPAGE="https://github.com/tdf/libcmis"

LICENSE="|| ( GPL-2 LGPL-2 MPL-1.1 )"
SLOT="0.5"

IUSE="man static-libs test tools"

BDEPEND="
virtual/pkgconfig
man? (
app-text/docbook2X
dev-libs/libxslt
)
test? (
dev-util/cppcheck
dev-util/cppunit
)
"
DEPEND="
dev-libs/boost:=
dev-libs/libxml2
net-misc/curl
"
RDEPEND="${DEPEND}"

RESTRICT="test"

src_prepare() {
default
eautoreconf
}

src_configure() {
# bug 618778
append-cxxflags -std=c++14

local myeconfargs=(
--program-suffix=-$(ver_cut 1-2)
--disable-werror
$(use_with man)
$(use_enable static-libs static)
$(use_enable test tests)
$(use_enable tools client)
)
econf "${myeconfargs[@]}"
}

src_install() {
default
find "${D}" -name '*.la' -delete || die
}
28 changes: 10 additions & 18 deletions dev-cpp/libcmis/libcmis-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,16 +1,14 @@
# Copyright 1999-2018 Gentoo Authors
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

if [[ ${PV} = 9999 ]]; then
EGIT_REPO_URI="https://github.com/tdf/libcmis.git"
inherit git-r3
elif [[ ${PV} = *_pre* ]]; then
COMMIT=738528d790b2b1d52d9b72d673842969a852815d
SRC_URI="https://github.com/tdf/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
else
SRC_URI="https://github.com/tdf/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
fi
inherit autotools flag-o-matic

Expand All @@ -20,18 +18,8 @@ HOMEPAGE="https://github.com/tdf/libcmis"
LICENSE="|| ( GPL-2 LGPL-2 MPL-1.1 )"
SLOT="0.5"

# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
[[ ${PV} == 9999 ]] || \
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
IUSE="man static-libs test tools"

IUSE="man static-libs test"

RDEPEND="
dev-libs/boost:=
dev-libs/libxml2
net-misc/curl
"
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
man? (
Expand All @@ -43,11 +31,15 @@ BDEPEND="
dev-util/cppunit
)
"
DEPEND="
dev-libs/boost:=
dev-libs/libxml2
net-misc/curl
"
RDEPEND="${DEPEND}"

RESTRICT="test"

[[ ${PV} = *_pre* ]] && S="${WORKDIR}/${PN}-${COMMIT}"

src_prepare() {
default
eautoreconf
Expand All @@ -63,7 +55,7 @@ src_configure() {
$(use_with man)
$(use_enable static-libs static)
$(use_enable test tests)
--enable-client
$(use_enable tools client)
)
econf "${myeconfargs[@]}"
}
Expand Down
3 changes: 2 additions & 1 deletion dev-cpp/libcmis/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,8 @@
<name>Gentoo Office project</name>
</maintainer>
<use>
<flag name="man">Build and install man pages.</flag>
<flag name="man">Build and install man pages</flag>
<flag name="tools">Build client tool for testing and viewing features</flag>
</use>
<upstream>
<remote-id type="github">tdf/libcmis</remote-id>
Expand Down

0 comments on commit 0369fd9

Please sign in to comment.