Skip to content

Commit

Permalink
app-laptop/tp_smapi: migrate to linux-mod-r1.eclass (new revision).
Browse files Browse the repository at this point in the history
In addition:

  * Dropped the flag-o-matic eclass and the -msse,-mssse3 flag
    stripping. I think the underlying GCC behavior has changed
    since bug 492964 was filed.

  * No more sys-apps/dmidecode dependency. I don't see it in the
    source code anywhere.

Closes: https://bugs.gentoo.org/908728
Signed-off-by: Michael Orlitzky <[email protected]>
  • Loading branch information
orlitzky committed Jun 18, 2023
1 parent 10c66d4 commit 03936c1
Showing 1 changed file with 46 additions and 0 deletions.
46 changes: 46 additions & 0 deletions app-laptop/tp_smapi/tp_smapi-0.43-r3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit linux-mod-r1

DESCRIPTION="IBM ThinkPad SMAPI BIOS driver"
HOMEPAGE="https://github.com/evgeni/tp_smapi"
SRC_URI="https://github.com/evgeni/tp_smapi/releases/download/tp-smapi/${PV}/${P}.tgz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"

IUSE="hdaps"

pkg_setup() {
if use hdaps; then
local CONFIG_CHECK="~INPUT_UINPUT"
local WARNING_INPUT_UINPUT="Your kernel needs uinput for the hdaps module to perform better"
local CONFIG_CHECK="~!SENSORS_HDAPS"
local ERROR_SENSORS_HDAPS="${P} with USE=hdaps conflicts with in-kernel HDAPS (CONFIG_SENSORS_HDAPS)"
fi

linux-mod-r1_pkg_setup
}

src_compile() {
local modlist=( thinkpad_ec tp_smapi )
local modargs=( KSRC=${KV_DIR} KBUILD=${KV_OUT_DIR} )

if use hdaps; then
modlist+=( hdaps )
modargs+=( HDAPS=1 )
fi

linux-mod-r1_src_compile
}

src_install() {
linux-mod-r1_src_install

newinitd "${FILESDIR}/${PN}-0.40-initd" smapi
newconfd "${FILESDIR}/${PN}-0.40-confd" smapi
}

0 comments on commit 03936c1

Please sign in to comment.