forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
mate-base/mate-control-center: Bump to 1.22.1, fix deps and USE flags
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Göktürk Yüksek <[email protected]>
- Loading branch information
1 parent
32fc9a3
commit 03e87b6
Showing
3 changed files
with
73 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST mate-control-center-1.22.0.tar.xz 1524084 BLAKE2B e0d7beb9fb358d6e60d6847fb6ee9e295793f856d25b0acf865efc360eefd446fa3f5a22d51121cd0fe675e01509b2612602587d4583b8835ec8e7157b795923 SHA512 3b2b88458848862a4c819d54104e9394817b29feb3d05117fe69441023ec5e6c922012395f24b5f70c9f9dbf6f8044f769840ec9996b1495441c4cb690f68371 | ||
DIST mate-control-center-1.22.1.tar.xz 1445012 BLAKE2B 2dc129280510432c25d158d6acdb50e58dfffd2e027fade545459669a6e6dbeafc4efe2cc81e19483427ec563daee903e2422e61ee398c88fec566cd80842639 SHA512 92390bf5eea459effbd94f0488cdaf3d7b6ff4f548f1aafead928d75e064e85ec1ac7796289f96af2ca8f6cbf3ef57bd2ae37058192af0ec976f4770ec8abeca |
71 changes: 71 additions & 0 deletions
71
mate-base/mate-control-center/mate-control-center-1.22.1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,71 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
MATE_LA_PUNT="yes" | ||
|
||
inherit mate | ||
|
||
if [[ ${PV} != 9999 ]]; then | ||
KEYWORDS="~amd64 ~arm ~arm64 ~x86" | ||
fi | ||
|
||
DESCRIPTION="The MATE Desktop configuration tool" | ||
LICENSE="GPL-2" | ||
SLOT="0" | ||
|
||
IUSE="accountsservice appindicator debug" | ||
|
||
RDEPEND=" | ||
dev-libs/atk | ||
>=dev-libs/dbus-glib-0.73 | ||
>=dev-libs/glib-2.50:2 | ||
dev-libs/libxml2:2 | ||
>=gnome-base/dconf-0.13.4 | ||
>=gnome-base/librsvg-2.0:2 | ||
>=mate-base/libmatekbd-1.17.0 | ||
>=mate-base/mate-desktop-1.21.2 | ||
>=mate-base/caja-1.20.0 | ||
>=mate-base/mate-menus-1.21.0 | ||
>=mate-base/mate-settings-daemon-1.21.2 | ||
>=media-libs/fontconfig-1:1.0 | ||
media-libs/freetype:2 | ||
media-libs/libcanberra:0[gtk3] | ||
>=sys-apps/dbus-1 | ||
x11-apps/xmodmap | ||
x11-libs/cairo | ||
x11-libs/gdk-pixbuf:2 | ||
>=x11-libs/gtk+-3.22:3 | ||
x11-libs/libX11 | ||
x11-libs/libXScrnSaver | ||
x11-libs/libXcursor | ||
x11-libs/libXext | ||
>=x11-libs/libXi-1.5 | ||
x11-libs/libXrandr | ||
x11-libs/libXrender | ||
x11-libs/libXxf86misc | ||
>=x11-libs/libxklavier-4 | ||
x11-libs/pango | ||
>=x11-wm/marco-1.17.0 | ||
virtual/libintl | ||
accountsservice? ( sys-apps/accountsservice ) | ||
appindicator? ( dev-libs/libappindicator:3 )" | ||
|
||
DEPEND="${RDEPEND} | ||
app-text/rarian | ||
>=app-text/scrollkeeper-dtd-1:1.0 | ||
app-text/yelp-tools | ||
dev-util/desktop-file-utils | ||
dev-util/glib-utils | ||
>=dev-util/intltool-0.50.1 | ||
sys-devel/gettext | ||
x11-base/xorg-proto | ||
virtual/pkgconfig" | ||
|
||
src_configure() { | ||
mate_src_configure \ | ||
--disable-update-mimedb \ | ||
$(use_enable appindicator) \ | ||
$(use_enable debug) | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters