Skip to content

Commit

Permalink
games-emulation/fceux: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.31, Repoman-2.3.9
  • Loading branch information
pacho2 committed Apr 29, 2018
1 parent 366058c commit 0403ace
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-emulation/fceux/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST fceux-2.2.2.src.tar.gz 9249858 BLAKE2B 9b6f788e2fc99f5ba728ac31c65da4a459f94e630b8a4b89d6dcfa62299d8170a147232731142fadd4a977f173464c94cb98ef4d1e0d1a2de28e8cf68bc74e55 SHA512 3d3b11c21232656492d962c21a93097f66e33fbd5adbbce6b771dc004393f30502c369eae83c23d988c7e447b4784740a10dfcb0811252854d4364c4b1face98
DIST fceux-2.2.3.src.tar.gz 9292792 BLAKE2B 44412934a50f2cab581cb194932a079071e8c7c1cb4cb4d173e9d7cf4898806fe1b0948d6e86fd70d1265eb596c47f77f751e3a113f03aba9b95e1f5def9c2a8 SHA512 6deb83e9e773694f4040f5f325b0b5b4f45d58bb3481db67b4659c940d90c4c87e3ffeac712b72ddb3f5d089cd9fc7b55b497db61f708c23a7c43c17eda55c7b
51 changes: 51 additions & 0 deletions games-emulation/fceux/fceux-2.2.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5
inherit desktop epatch scons-utils

DESCRIPTION="A portable Famicom/NES emulator, an evolution of the original FCE Ultra"
HOMEPAGE="http://fceux.com/"
SRC_URI="mirror://sourceforge/fceultra/${P}.src.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="gtk logo +lua +opengl"

RDEPEND="
lua? ( dev-lang/lua:0 )
media-libs/libsdl[opengl?,video]
logo? ( media-libs/gd[png] )
opengl? ( virtual/opengl )
gtk? ( x11-libs/gtk+:3 )
sys-libs/zlib[minizip]
"
DEPEND="${RDEPEND}"

src_prepare() {
epatch "${FILESDIR}"/${PN}-2.2.2-warnings.patch
}

src_compile() {
escons \
GTK=0 \
CREATE_AVI=1 \
SYSTEM_LUA=1 \
SYSTEM_MINIZIP=1 \
$(use_scons gtk GTK3) \
$(use_scons logo LOGO) \
$(use_scons opengl OPENGL) \
$(use_scons lua LUA)
}

src_install() {
dobin bin/fceux

doman documentation/fceux.6
docompress -x /usr/share/doc/${PF}/documentation /usr/share/doc/${PF}/fceux.chm
dodoc -r Authors changelog.txt TODO-SDL bin/fceux.chm documentation
rm -f "${D}/usr/share/doc/${PF}/documentation/fceux.6"
make_desktop_entry fceux FCEUX
doicon fceux.png
}

0 comments on commit 0403ace

Please sign in to comment.