forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
net-analyzer/greenbone-security-assistant: Security update, fix #571726
Package-Manager: portage-2.2.26
- Loading branch information
Showing
2 changed files
with
65 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST greenbone-security-assistant-6.0.6.tar.gz 1469343 SHA256 3df98355dc599b2efe24f1d3d1ca4f04b1380eb8996e3814f60b9a56fcc153fb SHA512 68eac5a41206d8c1bb43e84129987c7dd8ab922743c8f40f261ddcf49a1ac6245b17cac859af0d1cdc6061e3156170c88ec5b258ea8ed8a3828513ed8ef64af3 WHIRLPOOL 0d219cd83ecbf00907facbd4153d768d2aacbcd305831e01aaf66740ecae4bf5e798b651f782fa1ef39396fe0faac78976095992d302afcd77b3e676d920bf9f | ||
DIST greenbone-security-assistant-6.0.8.tar.gz 1475498 SHA256 1dc23cc24dcd7adc84aaed218e0d9651e032b930ab897c571bf16eb0b155b1ff SHA512 4126e05fc9c7c3272200a070d849fb21c680f49390d5305dc433aa16bf4365525a2c6047575fc11ca53668f87ce5d2a1aef5e63e782cea9d403129ab86aafa8d WHIRLPOOL 91f38c495d99a1c54132e276c321f536abe2ca9a08d9caba716457d2ffb7b63025bb687ff1e6640912d41aed7b39875f1e5a4d2acba4ab7d48248cdf373414fc |
64 changes: 64 additions & 0 deletions
64
net-analyzer/greenbone-security-assistant/greenbone-security-assistant-6.0.8.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,64 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
inherit cmake-utils systemd | ||
|
||
MY_PN=gsad | ||
|
||
DL_ID=2283 | ||
|
||
DESCRIPTION="Greenbone Security Assistant for openvas" | ||
HOMEPAGE="http://www.openvas.org/" | ||
SRC_URI="http://wald.intevation.org/frs/download.php/${DL_ID}/${P}.tar.gz" | ||
|
||
SLOT="0" | ||
LICENSE="GPL-2+ BSD MIT" | ||
KEYWORDS=" ~amd64 ~arm ~ppc ~x86" | ||
IUSE="" | ||
|
||
RDEPEND=" | ||
dev-libs/libgcrypt:0 | ||
dev-libs/libxslt | ||
>=net-analyzer/openvas-libraries-8.0.3 | ||
net-libs/libmicrohttpd[messages]" | ||
DEPEND="${RDEPEND} | ||
virtual/pkgconfig" | ||
|
||
PATCHES=( | ||
"${FILESDIR}"/${PN}-5.0.3-run.patch | ||
) | ||
|
||
S="${WORKDIR}"/${P} | ||
|
||
src_prepare() { | ||
sed \ | ||
-e '/^install.*OPENVAS_CACHE_DIR.*/d' \ | ||
-i CMakeLists.txt || die | ||
cmake-utils_src_prepare | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DLOCALSTATEDIR="${EPREFIX}/var" | ||
-DSYSCONFDIR="${EPREFIX}/etc" | ||
) | ||
cmake-utils_src_configure | ||
} | ||
|
||
src_install() { | ||
cmake-utils_src_install | ||
newinitd "${FILESDIR}"/${MY_PN}.init ${MY_PN} | ||
|
||
insinto /etc/openvas | ||
doins "${FILESDIR}"/${MY_PN}-daemon.conf | ||
dosym ../openvas/${MY_PN}-daemon.conf /etc/conf.d/${MY_PN} | ||
|
||
insinto /etc/logrotate.d | ||
doins "${FILESDIR}"/${MY_PN}.logrotate | ||
|
||
systemd_newtmpfilesd "${FILESDIR}"/${MY_PN}.tmpfiles.d ${MY_PN}.conf | ||
systemd_dounit "${FILESDIR}"/${MY_PN}.service | ||
} |