Skip to content

Commit

Permalink
app-metrics/fusioninventory-agent: add startup files
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: Alexey Shvetsov <[email protected]>
  • Loading branch information
alexxy committed May 26, 2020
1 parent 0ec0a76 commit 042f96e
Show file tree
Hide file tree
Showing 4 changed files with 53 additions and 4 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
--- a/Makefile.PL 2020-05-27 02:16:42.106531746 +0300
+++ b/Makefile.PL 2020-05-27 02:17:30.568531767 +0300
@@ -170,18 +170,15 @@
INSTALLSCRIPT => '$(PREFIX)/bin',
INSTALLSITESCRIPT => '$(PREFIX)/bin',
INSTALLVENDORSCRIPT => '$(PREFIX)/bin',
- INSTALLLIB => '$(DATADIR)/lib',
- INSTALLSITELIB => '$(DATADIR)/lib',
- INSTALLVENDORLIB => '$(DATADIR)/lib',
INSTALLMAN1DIR => '$(PREFIX)/share/man/man1',
INSTALLSITEMAN1DIR => '$(PREFIX)/share/man/man1',
INSTALLVENDORMAN1DIR => '$(PREFIX)/share/man/man1',
INSTALLMAN3DIR => '$(PREFIX)/share/man/man3',
INSTALLSITEMAN3DIR => '$(PREFIX)/share/man/man3',
INSTALLVENDORMAN3DIR => '$(PREFIX)/share/man/man3',
- SYSCONFDIR => '$(PREFIX)/etc/fusioninventory',
+ SYSCONFDIR => '/etc/fusioninventory',
DATADIR => '$(PREFIX)/share/fusioninventory',
- LOCALSTATEDIR => '$(PREFIX)/var/fusioninventory',
+ LOCALSTATEDIR => '/var/lib/fusioninventory',
);

# allow variables defined on command line to override defaults
Original file line number Diff line number Diff line change
@@ -0,0 +1,2 @@
# additional args for fusioninventory-agent
FUSIONINVENTORY_OPTIONS=""
Original file line number Diff line number Diff line change
@@ -0,0 +1,21 @@
#!/sbin/openrc-run
# Copyright 2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

pidfile=${RC_PREFIX%/}/run/${SVCNAME}.pid

name="fusioninventory-agent daemon"
description="FusionInventroy agent"
command=/usr/bin/fusioninventory-agent
command_args="--daemon --pidfile ${pidfile} ${FUSIONINVENTORY_OPTIONS}"
extra_started_commands="reload"

depend() {
need net
}

reload() {
ebegin "Reloading ${SVCNAME}"
start-stop-daemon --signal HUP --pidfile "${pidfile}"
eend $?
}
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@

EAPI=7

inherit perl-module
inherit perl-module systemd

DESCRIPTION="The FusionInventory agent is a generic management agent"
HOMEPAGE="http://fusioninventory.org/"
Expand Down Expand Up @@ -31,9 +31,12 @@ RDEPEND="${DEPEND}"
BDEPEND="
dev-perl/Module-Install
"
PATCHES=( "${FILESDIR}/${P}-dirs.patch" )

src_prepare() {
sed -e 's:\$(PREFIX)/etc:/etc:g' \
-i Makefile.PL || die "sed failed"
src_install() {
default
systemd_dounit contrib/unix/fusioninventory-agent.service
doinitd "${FILESDIR}/${PN}.initd"
doconfd "${FILESDIR}/${PN}.confd"
keepdir /var/lib/fusioninventory
}

0 comments on commit 042f96e

Please sign in to comment.