Skip to content

Commit

Permalink
games-util/pyfa: version bump to 2.20.2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Andreas Zuber <[email protected]>
Closes: gentoo#15381
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
ZeroPointEnergy authored and juippis committed Apr 17, 2020
1 parent 2ac163b commit 045e577
Show file tree
Hide file tree
Showing 2 changed files with 102 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-util/pyfa/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST pyfa-2.17.0.tar.gz 12348275 BLAKE2B fd670a6d34760285561ed07e82c3c54eb9a74cad732b24b89fab103fe8013608c18f27461bfac28a854df3ce7273fac1011752a8da2447b69432ad36709c08dd SHA512 d4af2c6a30deb8b205e5db55c25e1fa48dc74b964c9d85da69acca9bbd19764b77abc96ff42a2e99733d132253081a3e2c3de6ef787c162e392a9627ab62c529
DIST pyfa-2.19.0.tar.gz 11822419 BLAKE2B 7aaa9d8fc7de7ab9fb246bdf1dd61aa4aac6035d37cc6ecf9e32b03e67baada7d3dc765d02a7d9ed75f5933ccd76f92c4ae79c822c0562f8658dd1b52dfdba4d SHA512 5083f125cfd7f5d32e76029a836089cb79c5c6c93397712d37054518ed9bd77092d0c610cecdb1d0afce40753276431cdec72699ffc04088162158b55c04bac8
DIST pyfa-2.20.1.tar.gz 11834967 BLAKE2B 6caf4abb5ff543aa0dc4747a853775a03e20fe8fce5f174d791429ad021ecf955895e108127182f1872f23ccad862892a1afa2e22af27aafd198100604993d62 SHA512 6e6e04f9cd6e3dd127d51c666cf88eb700cc783b02d0b31220196925bc64bb1d88ea2c6a36bc45d71ba62cc53074bd509b46edd175f02e7b1fc736af13ce41ef
DIST pyfa-2.20.2.tar.gz 11835308 BLAKE2B 3482ba068720ca735a5f794ede38dffda61ff571552c57a268263820b5b9085c6059be64c739d4ce67a9c95a1c4ba44136cb6aaa2ee7454514924e8c2de7e128 SHA512 14066b81ae77e600367255fa9ba079192f79a8d01d0194b894ba616d7a225e58141b9c2b980e99bfdf17403e665d1968e62a805f845c5065f8ed47de7950e44c
101 changes: 101 additions & 0 deletions games-util/pyfa/pyfa-2.20.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,101 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

PYTHON_COMPAT=( python3_6 )
PYTHON_REQ_USE="sqlite,threads"

inherit desktop eutils python-single-r1 xdg-utils

DESCRIPTION="Python Fitting Assistant - a ship fitting application for EVE Online"
HOMEPAGE="https://github.com/pyfa-org/Pyfa"

LICENSE="GPL-3+ all-rights-reserved"
SLOT="0"
if [[ ${PV} = 9999 ]]; then
EGIT_REPO_URI="https://github.com/pyfa-org/Pyfa.git"
inherit git-r3
else
SRC_URI="https://github.com/pyfa-org/Pyfa/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/Pyfa-${PV}"
fi

REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="mirror bindist"

DEPEND="
$(python_gen_cond_dep '
>=dev-python/cryptography-2.3[${PYTHON_MULTI_USEDEP}]
>=dev-python/logbook-1.0.0[${PYTHON_MULTI_USEDEP}]
>=dev-python/pyyaml-5.1[${PYTHON_MULTI_USEDEP}]
>=dev-python/sqlalchemy-1.3.0[${PYTHON_MULTI_USEDEP}]
>=dev-python/wxpython-4.0.4[webkit,${PYTHON_MULTI_USEDEP}]
')
${PYTHON_DEPS}"
RDEPEND="${DEPEND}
$(python_gen_cond_dep '
>=dev-python/beautifulsoup-4.6.0[${PYTHON_MULTI_USEDEP}]
>=dev-python/markdown2-2.3.0[${PYTHON_MULTI_USEDEP}]
>=dev-python/packaging-16.8[${PYTHON_MULTI_USEDEP}]
dev-python/python-dateutil[${PYTHON_MULTI_USEDEP}]
>=dev-python/requests-2.0.0[${PYTHON_MULTI_USEDEP}]
>=dev-python/roman-2.0.0[${PYTHON_MULTI_USEDEP}]
>=dev-python/matplotlib-3.1.2[wxwidgets,${PYTHON_MULTI_USEDEP}]
dev-python/numpy[${PYTHON_MULTI_USEDEP}]
')"
BDEPEND="app-arch/zip"

PATCHES=(
# fix import path in the main script for systemwide installation
"${FILESDIR}/${PN}-2.9.3-import-pyfa.patch"
)

src_prepare() {
# get rid of CRLF line endings introduced in 1.1.10 so patches work
edos2unix config.py pyfa.py gui/bitmap_loader.py service/settings.py

default

# make python recognize pyfa as a package
touch __init__.py || die

sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
-e "s:%%EPREFIX%%:${EPREFIX}:" \
"${FILESDIR}/configforced-1.15.1.py" > configforced.py || die
sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
pyfa.py > pyfa || die
}

src_install() {
python_moduleinto ${PN}
python_domodule eos gui service utils graphs
python_domodule config*.py __init__.py version.yml configforced.py db_update.py
python_doscript pyfa

insinto /usr/share/${PN}

einfo "Creating database ..."
python ./db_update.py || die
doins eve.db

einfo "Compressing images ..."
pushd imgs > /dev/null || die
zip -r imgs.zip * || die "zip failed"
doins imgs.zip
popd > /dev/null || die

dodoc README.md
doicon -s 32 imgs/gui/pyfa.png
newicon -s 64 imgs/gui/pyfa64.png pyfa.png
domenu "${FILESDIR}/${PN}.desktop"
}

pkg_postinst() {
xdg_icon_cache_update
}

pkg_postrm() {
xdg_icon_cache_update
}

0 comments on commit 045e577

Please sign in to comment.