forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-admin/setools: fix cross-compiling
- Loading branch information
Showing
3 changed files
with
47 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,15 @@ | ||
there's no real need to run AC_CHECK_FILE to see if a file exists. if the | ||
static link fails later on, then the static lib didn't exist. this also | ||
breaks cross-compiling. | ||
|
||
--- a/configure.ac | ||
+++ b/configure.ac | ||
@@ -448,8 +448,6 @@ | ||
sepol_srcdir="") | ||
if test "x${sepol_srcdir}" = "x"; then | ||
sepol_srcdir=${sepol_devel_libdir} | ||
- AC_CHECK_FILE([${sepol_srcdir}/libsepol.a],, | ||
- AC_MSG_ERROR([make sure libsepol-static is installed])) | ||
else | ||
AC_MSG_CHECKING([for compatible sepol source tree]) | ||
sepol_version=${sepol_srcdir}/VERSION |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,29 @@ | ||
trying to run compiled code fails when cross-compiling. | ||
probe the value using the preprocessor instead. | ||
|
||
--- a/configure.ac | ||
+++ b/configure.ac | ||
@@ -621,21 +621,8 @@ | ||
sepol_new_errcodes="yes", | ||
sepol_new_errcodes="no") | ||
|
||
-AC_RUN_IFELSE( | ||
- [AC_LANG_SOURCE([ | ||
-#include <sepol/policydb/policydb.h> | ||
-#include <stdio.h> | ||
-#include <stdlib.h> | ||
-int main(void) { | ||
- FILE *f = fopen("conftest.data", "w"); | ||
- if (f != NULL && fprintf(f, "%d", POLICYDB_VERSION_MAX) > 0) { | ||
- fclose(f); | ||
- exit(EXIT_SUCCESS); | ||
- } | ||
- exit(EXIT_FAILURE); | ||
-}])], | ||
- sepol_policy_version_max=`cat conftest.data`, | ||
- AC_MSG_FAILURE([could not determine maximum libsepol policy version])) | ||
+printf "#include <sepol/policydb/policydb.h>\nPOLICYDB_VERSION_MAX\n" > conftest.c | ||
+sepol_policy_version_max=`${CPP} -E -P ${CPPFLAGS} conftest.c | tail -1` | ||
AC_DEFINE_UNQUOTED(SEPOL_POLICY_VERSION_MAX, ${sepol_policy_version_max}, [maximum policy version supported by libsepol]) | ||
CFLAGS="${sepol_save_CFLAGS}" | ||
CPPFLAGS="${sepol_save_CPPFLAGS}" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters