Skip to content

Commit

Permalink
app-vim/command-t: version bump to 5.0.1
Browse files Browse the repository at this point in the history
  • Loading branch information
radhermit committed Aug 23, 2017
1 parent 03ce889 commit 04992cd
Show file tree
Hide file tree
Showing 2 changed files with 49 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-vim/command-t/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST command-t-4.0.tar.gz 79052 SHA256 1a733b660c461b675fc0e95627036c9328a5f7a33cb641f8c8ec98e639314abf SHA512 31f58210b2e9954d830dac3f18d87d08059f396c6637c6ff0be1e8b660fc307796ef8c0d572b105690072c013f0fc4ff6cfaa2f0f8ebde00b5f76fdfc3e29c34 WHIRLPOOL 8119c2d7c61922d84402882f1499fd8a9fd955951f9b6952f24335ef8f14d7bca93c023adf61985d571631bbd7db6ed7c60c96151570228120d2025e9c7b4c5a
DIST command-t-5.0.1.tar.gz 81781 SHA256 7ac1e4c2bd9bf87c788be22fc24cfc2a4993c30365031a2b15ddff79d8b00e3d SHA512 54262f4628bbef8a11878a8593510af566dabf35dd70005dc90e4abb4c4e9aebde5dc7d08d808c944980017f8f35d7e9723b0032ccde5ab6d2d2fae38e1c632d WHIRLPOOL 240cf7a171c848d8201929c8e02d0db3e74ce64b5117aff4f12c8e7b320c08f2cb944ee1bd44a2f3681706d533698e792bfd5f0487933d04b88699aa25c6a398
48 changes: 48 additions & 0 deletions app-vim/command-t/command-t-5.0.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
USE_RUBY="ruby22 ruby23 ruby24"

inherit vim-plugin ruby-ng

DESCRIPTION="vim plugin: fast file navigation for vim"
HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3025 https://github.com/wincent/command-t"
SRC_URI="https://github.com/wincent/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD-2"
KEYWORDS="~amd64 ~x86"

VIM_PLUGIN_HELPFILES="${PN}.txt"

RDEPEND="|| ( app-editors/vim[ruby] app-editors/gvim[ruby] )"

all_ruby_prepare() {
find "${S}" -name .gitignore -delete || die
}

each_ruby_configure() {
cd ruby/${PN}/ext/${PN} || die
${RUBY} extconf.rb || die "extconf.rb failed"
}

each_ruby_compile() {
cd ruby/${PN}/ext/${PN} || die
emake V=1
rm *.o *.c *.h *.log extconf.rb depend Makefile || die
}

each_ruby_install() {
local sitelibdir=$(ruby_rbconfig_value "sitelibdir")
insinto "${sitelibdir}"
doins -r ruby/${PN}/{ext,lib}/*
}

all_ruby_install() {
rm Gemfile* Rakefile LICENSE README.md || die
rm -r appstream bin fixtures data ruby/${PN}/{ext,lib,*.gemspec} spec vendor || die

vim-plugin_src_install

# make sure scripts are executable
chmod +x "${ED}"/usr/share/vim/vimfiles/ruby/${PN}/bin/* || die
}

0 comments on commit 04992cd

Please sign in to comment.