Skip to content

Commit

Permalink
app-admin/mongo-tools: version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Alexys Jacob <[email protected]>
  • Loading branch information
ultrabug committed Jun 7, 2019
1 parent 67b1627 commit 04be46e
Show file tree
Hide file tree
Showing 3 changed files with 73 additions and 1 deletion.
1 change: 1 addition & 0 deletions app-admin/mongo-tools/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,5 +2,6 @@ DIST mongo-tools-3.4.16.tar.gz 4697191 BLAKE2B 2e9a0e7dc8016d3e7d7c7f8d0cf80a97d
DIST mongo-tools-3.6.11.tar.gz 4731680 BLAKE2B 88558a26d2552848121d984e4b963acafe9e56b37a3d393bacdcd8c0f71a29e2082845ad6d648c3c4800bd47514d339d1f1e984e339a48572ecb5f6f31d9166d SHA512 2291cb963965a59a89bac35a760ce49b4b835d1447065d558c4b254aae5fe38f7ebe4c9d7a67aa475e06be95c45f8529922c6fb0b78d41bc07d1a83f3a564192
DIST mongo-tools-3.6.12.tar.gz 4990846 BLAKE2B a2b649df03ba17175d95b0fb7be94e446a0cda8dd45111a41f6f74ee5498b853d9fd361f683d4db558197a1951fc79056b516cff6fcd32cc32877744456b67e3 SHA512 948e49719c958e8b7cd1c27b9d413df6d032189801180540ee86b927d5dd53ab4b8906e5cc7880163ecc6abf11daebfc2fb96fcf8fcfd3e0b1f8c8fedaf54558
DIST mongo-tools-3.6.8.tar.gz 4723878 BLAKE2B a1693024d60f69d25c268eaaa30a478b1e4c0042c5fb7a3fd6252ed00aef2fee3fba94516fe825165a1a57887ed38e4fbce488c48ddd4f45349f0b7a1b244020 SHA512 359e8ce2d847d005d48ff12bc2e8af73213d81cd1521d2b5b5ac94792468218248bebbe808e1bd8fd49234eab8480608f294c1b63f317aed58f456b84ef17dcf
DIST mongo-tools-4.0.10.tar.gz 11134721 BLAKE2B f25e834622db8a2cea1658d9396b747666dee6a0e6471f5fcf351431f716735227b19f854c228ebb9ace8a7c27b8cdf83f8a5009107191aa6dd27c1a4c037505 SHA512 12764b2e2016ae3ab3f0ed1f5b9be9ce10e466c53b408ad2c01b26bdf39ca41a358acd07aea5847db2b40e3e89293f77efcd2b310e4e2bf3071873abf1b20f49
DIST mongo-tools-4.0.6.tar.gz 10879606 BLAKE2B 9a7656ba1486df4b36ceb527735ad46864d7a04f2d0451fb4e04bbbdc09c3bb0ec922aa5daa584b93e123e1c3764c0ebef96a3566dd0d6b646a627d769645619 SHA512 d6185d7442a593d29db78889c55aba53e070bedd522d78d8c0bf52bb27f26c5fee6d010457f65774ea36a2e6d5280f38c95433ff76ed53ed9d74b1c811198cb7
DIST mongo-tools-4.0.9.tar.gz 11134365 BLAKE2B ad27ad868b33a3c0802a0c79b5570a85c20106c71f38229e25a09a4ab8f0e6edbfe4338ce9862b2ba6b7836e4aa71fe5a3704a81a028a95d74168ac5107364d7 SHA512 55720766da5fdb9ee5a93d90be5ebe61ec4a5f5428097e9d6cb022472a2964c39b184531e1f59fb7780e834c3b03986e9edcc66e3f3933b3457b86260a6bbd8f
2 changes: 1 addition & 1 deletion app-admin/mongo-tools/mongo-tools-3.4.16.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
Expand Down
71 changes: 71 additions & 0 deletions app-admin/mongo-tools/mongo-tools-4.0.10.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,71 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

MY_PV=${PV/_rc/-rc}
MY_P=${PN}-r${MY_PV}

DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
HOMEPAGE="https://www.mongodb.com"
SRC_URI="https://github.com/mongodb/mongo-tools/archive/r${MY_PV}.tar.gz -> mongo-tools-${MY_PV}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
IUSE="sasl ssl"

DEPEND="dev-lang/go:=
net-libs/libpcap
sasl? ( dev-libs/cyrus-sasl )
ssl? ( dev-libs/openssl:0= )"

# Do not complain about CFLAGS etc since go projects do not use them.
QA_FLAGS_IGNORED='.*'

EGO_PN="github.com/mongodb/mongo-tools"
S="${WORKDIR}/src/${EGO_PN}"

src_unpack() {
mkdir -p "${S%/*}" || die
default
mv ${MY_P} "${S}" || die
}

src_prepare() {
default

# allow building with go 1.12 #678924
sed -i 's/_Ctype_struct_/C.struct_/' vendor/github.com/google/gopacket/pcap/pcap.go || die
}

src_compile() {
local myconf=()

if use sasl; then
myconf+=(sasl)
fi

if use ssl; then
myconf+=(ssl)
fi

# build pie to avoid text relocations wrt #582854
local buildmode="pie"

# skip on ppc64 wrt #610984
if use ppc64; then
buildmode="default"
fi

mkdir -p bin || die
for i in bsondump mongostat mongofiles mongoexport mongoimport mongorestore mongodump mongotop mongoreplay; do
echo "Building $i"
GOROOT="$(go env GOROOT)" GOPATH="${WORKDIR}" go build -buildmode="${buildmode}" -o "bin/$i" \
-ldflags "-X ${EGO_PN}/common/options.VersionStr=${PV}" --tags "${myconf[*]}" "$i/main/$i.go" || die
done
}

src_install() {
dobin bin/*
}

0 comments on commit 04be46e

Please sign in to comment.