Skip to content

Commit

Permalink
app-admin/filebeat: version bump to 5.0.2
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.1
  • Loading branch information
hydrapolic authored and gktrk committed Dec 3, 2016
1 parent 70af2da commit 04d38c9
Show file tree
Hide file tree
Showing 2 changed files with 66 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/filebeat/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST filebeat-1.3.1.tar.gz 10225540 SHA256 1d8e41b42a0b2dd59403795ff07cbfd8a9a76477731c38122aa9242b47b054e0 SHA512 60f6d4ae93bb01e74311d7ccc3d367707f888f58898b89a0ea7512c96b6e1369edf7dc2afe3615df97e8c311629d9fc1e9fc2f1abe8edcbb5bc5bcf47c82107c WHIRLPOOL 608b825fa4dc99d792deb9d23672eea0e66318461adb944dc484d42edc3d3acb1cf1f65cd4024cf0437dd5e5ed088ff5b5aeec967f7efad03b82f259793410f0
DIST filebeat-5.0.0.tar.gz 15736495 SHA256 3e6b7cf2ee5f52e78ae87ef04ab9dd49977c89f86a09416586896aeaea844e34 SHA512 0838fb5e04d2266b15a6f21ebf1109626b60591a9154f4bb11cde73ae127a7695defb1e238a115ab59e0a7441bd9fa5642d4eb924663f00467b715224a3fa076 WHIRLPOOL a2b39bccfb45a32a25de9ae32ad881cd79e7a854280d6eb17614f4c274e9f92d956f8b811e6ff6371d16e7d723a98c59e82906d90029a25d079b33089142df5f
DIST filebeat-5.0.2.tar.gz 15774694 SHA256 feef1e53b978c12b3b3c552534fd666839df5d7d3b974e16636360ca6c4ab7c0 SHA512 2481ed584efda67051e59a27b45ba52039d960d6dc335d9225e2370bc71e5167f5e4e9e7cc0cb7e689c9a73d5edf27655c4764b0acb6f1422f18bfc10fc44fe9 WHIRLPOOL 82d79d09d4c138b40841227e7b4b137b262fb251ec83b736914bb4cda00837d8eedf7af01618d2a04c368cc50650121148cd507da38acce481a3f4dd93281ae8
65 changes: 65 additions & 0 deletions app-admin/filebeat/filebeat-5.0.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

DESCRIPTION="Lightweight log shipper for Logstash and Elasticsearch"
HOMEPAGE="https://www.elastic.co/products/beats"
SRC_URI="https://github.com/elastic/beats/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"

DEPEND="dev-lang/go"
RDEPEND="!app-admin/filebeat-bin"

ELASTIC="${WORKDIR}/src/github.com/elastic"
BEATS="${ELASTIC}/beats"
S="${BEATS}"

src_unpack() {
mkdir -p "${ELASTIC}" || die
unpack ${P}.tar.gz
mv beats-${PV} "${BEATS}" || die
}

src_compile() {
cd ${BEATS}/filebeat || die
GOPATH="${WORKDIR}" emake
}

src_install() {
keepdir /var/{lib,log}/${PN}

fperms 0750 /var/{lib,log}/${PN}

newconfd "${FILESDIR}/${PN}.confd-r1" ${PN}
newinitd "${FILESDIR}/${PN}.initd-r1" ${PN}

insinto "/usr/share/doc/${PF}/examples"
doins ${PN}/{filebeat.yml,filebeat.full.yml}

insinto "/etc/${PN}"
doins ${PN}/{filebeat.template.json,filebeat.template-es2x.json}

exeinto "/usr/share/${PN}"
doexe libbeat/scripts/migrate_beat_config_1_x_to_5_0.py

dobin filebeat/filebeat
}

pkg_postinst() {
if [[ -n "${REPLACING_VERSIONS}" ]]; then
elog "Please read the migration guide at:"
elog "https://www.elastic.co/guide/en/beats/libbeat/5.0/upgrading.html"
elog ""
elog "The migration script:"
elog "${EROOT%/}/usr/share/filebeat/migrate_beat_config_1_x_to_5_0.py"
elog ""
fi

elog "Example configurations:"
elog "${EROOT%/}/usr/share/doc/${PF}/examples"
}

0 comments on commit 04d38c9

Please sign in to comment.