Skip to content

Commit

Permalink
app-arch/cabextract: bump to v1.9
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/669280
Package-Manager: Portage-2.3.51, Repoman-2.3.12
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Nov 6, 2018
1 parent 222dd14 commit 0524057
Show file tree
Hide file tree
Showing 2 changed files with 67 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-arch/cabextract/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST cabextract-1.6.tar.gz 241731 BLAKE2B 49a94b1b0d8a6c9f61cd51280a035e3fedb8d7a2d097b132bc56114c6003a558647a7f8c47b8d08fcac1999e68bea5303adb2b03c8e6dd010995e8b0c6dcd442 SHA512 d1c71c0292e3d73d8edbff5f5230b3127c63028f5aba1d0cad968bc945202fb9c0773327affce3d28466068377f029c80735adbabe0929d29b2204dea73738f8
DIST cabextract-1.7.tar.gz 293760 BLAKE2B d5ab4783c944d5d8b1d9ed8a2fbbfd60aeeab9f12b836032f982efc5721055b2caa521147246b3b5274d9456b1dbd2d513455cfd57750cf6d7fdc18f109f96c9 SHA512 63789e485d57299f2a0a60dc6d9a94e83639eb59b73789eff52977d3d3bd37a1c00713c86a4c6289e35541d0b7240ea0545ba84013713c070b4324ae1f2865ce
DIST cabextract-1.8.tar.gz 289256 BLAKE2B ba9fea0cd12859b0de97b13362eaf276066650eb7151e0115af7ed2586cfa7497f72be2f9287d3ccb5ce5256ec26ca69e729df5bb0a327bb9f32ded25391460c SHA512 f8d676d6b738b0b13ac1cac7716c2fb46db423ef30b05ee64f00fcb19596131fbd34341c8b417af3de04896e9b6a8abf0d5976ee4bf87d016806a71317246d7a
DIST cabextract-1.9.tar.gz 466334 BLAKE2B 1a82bddca826ee35ed13e1c0b50deca3ae1b7e31d7f427f54b5d6cf9651a727b7cbf8049c1a4326237725e007baecb4356721489611bb5e015bd7460e2530758 SHA512 d144c1df9ed8e8c339bcadb3d1be2eb2576bb066e3f75a3480df0d5e81407a633554e4674b3bb43716c0cf33a0f2327e6f798cd6d7825bceefa0ad839fcc3f64
66 changes: 66 additions & 0 deletions app-arch/cabextract/cabextract-1.9.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,66 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

inherit autotools toolchain-funcs

if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/kyz/libmspack.git"
inherit git-r3
MY_P="${PN}-9999"

LIBMSPACK_DEPEND="~dev-libs/libmspack-9999:="
else
KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
MY_PV="${PV/_alpha/alpha}"
MY_P="${PN}-${MY_PV}"
SRC_URI="https://www.cabextract.org.uk/${P}.tar.gz"

LIBMSPACK_DEPEND=">=dev-libs/libmspack-0.8_alpha:="
fi

DESCRIPTION="Extracts files from Microsoft cabinet archive files"
HOMEPAGE="https://www.cabextract.org.uk/"

LICENSE="GPL-3"
SLOT="0"
IUSE="extras"

DEPEND="${LIBMSPACK_DEPEND}
virtual/pkgconfig"
RDEPEND="extras? ( dev-lang/perl )"

src_prepare() {
if [[ ${PV} == "9999" ]] ; then
# Re-create file layout from release tarball
pushd "${WORKDIR}" &>/dev/null || die
cp -aL "${S}"/${PN} "${WORKDIR}"/${PN}-source || die
rm -r "${S}" || die
mv "${WORKDIR}"/${PN}-source "${S}" || die
popd &>/dev/null || die
fi

default

eautoreconf
}

src_configure() {
econf \
--with-external-libmspack=yes
}

src_compile() {
emake AR="$(tc-getAR)"
}

src_install() {
local DOCS=( AUTHORS ChangeLog NEWS README TODO doc/magic )
default
docinto html
dodoc doc/wince_cab_format.html
if use extras; then
dobin src/{wince_info,wince_rename,cabinfo,cabsplit}
fi
}

0 comments on commit 0524057

Please sign in to comment.