Skip to content

Commit

Permalink
app-emulation/crun: bump to 0.15
Browse files Browse the repository at this point in the history
Signed-off-by: Robert Günzler <[email protected]>
Closes: gentoo#17702
Signed-off-by: Georgy Yakovlev <[email protected]>
  • Loading branch information
robertgzr authored and gyakovlev committed Oct 6, 2020
1 parent e133cce commit 0558886
Show file tree
Hide file tree
Showing 3 changed files with 70 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/crun/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST crun-0.14.1.tar.gz 1341891 BLAKE2B c20d5001161e298050ddca859fa78487fe3f8577ef0b06eb5515056f19ba4f981debeb684148de49111a0370b9bafb7f6454d65f7ecf087862c697a162c9b377 SHA512 420f1713653cbd17df83b2a63d163aaa41baf78115b093877a2241305e10b2ceeaf08ea6700658eca894729ff8a20cbc66f868d18d27fba3fbedf1a9993b122e
DIST crun-0.15.tar.gz 1364861 BLAKE2B 7078e71229bae4bc663398891b21344abc3189c78a11e4feeae3236e1df4a2c5160cf26f2cc243d4c0898a642a779603d473d2c22ca2b67123c6ac4654fce4d7 SHA512 f9a9e94b6a9c5cff01fe93b1c3d5876a0794e6288b802cf579556e11411ca5d6e63cae3859aaa4df4bb600e2d27aa131872a93a92784b9b48f7885411d86f325
DIST libcrun.lds 257 BLAKE2B 00e7cdf3162ea0b7231dbb9037b192bcf5ffa83316e1aa60268560bc9fe8302be351c405861f9dfc06620ea64561a9226f58b7133039c0af1299dc4088b98272 SHA512 0e9b836c79ee4ad7ff33c592eca8ff41f38aed588f2f5a2416bed82efa819cd4c61ad65a2dfd11a37838a19d950688b1d5adb3b75841963dbb589536e8a867f7
68 changes: 68 additions & 0 deletions app-emulation/crun/crun-0.15.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{6,7} )

inherit autotools python-any-r1

DESCRIPTION="A fast and low-memory footprint OCI Container Runtime fully written in C"
HOMEPAGE="https://github.com/containers/crun"
SRC_URI="https://github.com/containers/${PN}/releases/download/${PV}/${P}.tar.gz"

LICENSE="GPL-2+ LGPL-2.1+"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
IUSE="+bpf +caps criu man +seccomp systemd static-libs"

DEPEND="
sys-kernel/linux-headers
>=dev-libs/yajl-2.0.0
caps? ( sys-libs/libcap )
criu? ( >=sys-process/criu-3.13 )
seccomp? ( sys-libs/libseccomp )
systemd? ( sys-apps/systemd:= )
"
RDEPEND="${DEPEND}"
BDEPEND="
${PYTHON_DEPS}
man? ( dev-go/go-md2man )
"

# the crun test suite is comprehensive to the extent that tests will fail
# within a sandbox environment, due to the nature of the privileges
# required to create linux "containers".
RESTRICT="test"

DOCS=( README.md )

src_configure() {
local myeconfargs=(
$(use_enable bpf) \
$(use_enable caps) \
$(use_enable criu) \
$(use_enable seccomp) \
$(use_enable systemd) \
$(usex static-libs '--enabled-shared --enabled-static' '--enable-shared --disable-static' '' '')
)

econf "${myeconfargs[@]}"
}

src_compile() {
emake -C libocispec
emake crun
if use man ; then
emake generate-man
fi
}

src_install() {
emake "DESTDIR=${D}" install-exec
if use man ; then
emake "DESTDIR=${D}" install-man
fi

einstalldocs
}
1 change: 1 addition & 0 deletions app-emulation/crun/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -27,5 +27,6 @@
support for managing device controllers.
</flag>
<flag name="man">Build and install man pages</flag>
<flag name="criu">Enable CRIU based checkpoint/restore support</flag>
</use>
</pkgmetadata>

0 comments on commit 0558886

Please sign in to comment.