Skip to content

Commit

Permalink
app-emulation/kompose: Version bump to 0.3.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.4, Repoman-2.3.2
  • Loading branch information
mrueg committed Mar 13, 2017
1 parent 036ffca commit 0561750
Show file tree
Hide file tree
Showing 2 changed files with 31 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/kompose/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST kompose-0.2.0_p20170214.tar.gz 4928182 SHA256 437303c2f7b3c24182561e76cfa85102814f731fc7f5951933fe6c153c6b2e1b SHA512 dab013f861f4a185c0fdea3f4b79d33ff280f3c7ad77e150ce381770182ad77a37d8ccbadfe1f7bd13d50dc36a7087847d1636b6b411a21e0de43113be5b0183 WHIRLPOOL 581a6059bdb6286ca859e5a2f1e750a9ceaa3724ed9fee4092ac9283b2216629118437ccd0354ffebde95ac37b1591048f5972658a093b4aefc09bc8a02402f8
DIST kompose-0.3.0.tar.gz 4928611 SHA256 047e5367856f07338515eea43fb213e08fdde79333250e4cc85251e80251c928 SHA512 094d0093d6cf480d8c757f5f2d82719eaaf0c6c1b33140d45fcb2ff7b129e9cada0660a3faf26b13e877b05897920e00ddf8b451dfc91042f7f6bb72a4a24618 WHIRLPOOL dba40efcfdd6d22a9112c078be47f159fde4de9ac43bf04f72c5006add523a67c13487c0da9168feab0c8c9f84abe3865914239008d87172df86b3654b21935d
30 changes: 30 additions & 0 deletions app-emulation/kompose/kompose-0.3.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit golang-build golang-vcs-snapshot

EGO_PN="github.com/kubernetes-incubator/kompose/..."
EGIT_COMMIT="v0.3.0"
COMPOSE_COMMIT="135165b"
ARCHIVE_URI="https://${EGO_PN%/*}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"

DESCRIPTION="Tool to move from docker-compose to Kubernetes"
HOMEPAGE="https://github.com/kubernetes-incubator/kompose"
SRC_URI="${ARCHIVE_URI}"
LICENSE="Apache-2.0"
SLOT="0/${PVR}"
IUSE="hardened"

RESTRICT="test"

src_compile() {
export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')"
GOPATH="${S}" go build -ldflags="-X github.com/kubernetes-incubator/kompose/cmd.GITCOMMIT=${COMPOSE_COMMIT}" -o bin/kompose src/${EGO_PN%/*}/main.go || die
}

src_install() {
dobin bin/*
dodoc -r src/${EGO_PN%/*}/{docs,{README,RELEASE,ROADMAP,CHANGELOG,CONTRIBUTING}.md}
}

0 comments on commit 0561750

Please sign in to comment.