Skip to content

Commit

Permalink
app-misc/vifm: Bumps version to 0.9.1_beta
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
Chema Alonso Josa committed Jan 27, 2018
1 parent 765c28e commit 056e5b5
Show file tree
Hide file tree
Showing 2 changed files with 103 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-misc/vifm/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST vifm-0.7.2.tar.bz2 468086 BLAKE2B a83b1f43eb3f6e47afd5a7c810741468857c602b80cad5c91d2033eea9e1f1efb09e19ca7b02f39e93f8f7186b4cb6fb0627f98a30c054a0d7d71d1b454698d8 SHA512 24a5ad44cecd01f489b95008f0b98ad6cd63656bc7fe4a888101f369f9b258cb87b8025efac30237fbaebc7aff14d173d02118839312017276f3f6b62ea4a3b9
DIST vifm-0.9.1-beta.tar.bz2 1002371 BLAKE2B 435b50294a623e1e0bc1f98b2f4687bb9e85934178c540fda89a8e0d8ff32e9ea1a944cc7fb39190ca741d57e4c5abbd5a46e776d0115cf3892452bff565bb15 SHA512 c8516acf069fb88f8cfc0db663623ab37caf34277b7fd4d07759deb026c11ac70a7d438e419fc8f5d545e2e25b8e9cc40f8220c3b415c97a8e7e8b9d132bdb0c
DIST vifm-0.9.tar.bz2 971539 BLAKE2B 5d6dd8c399e38886ab3e2d548b93492bf31b464e5661c6f6d54504701bf1eab8338155a9ddc9b220c4cb2a67417d5622094e9ffb717ddf594984fe475214af60 SHA512 5ae2b03e672bd9a7f95a5c59141dabac8bc7946a4e307d6a3df70bdb52e1f7665b960a3d20709c811cbfbcf76f7836d23b5edb191968e5277fb705a291ab3a9a
102 changes: 102 additions & 0 deletions app-misc/vifm/vifm-0.9.1_beta.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,102 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit autotools vim-doc versionator xdg-utils

MY_P=$(replace_version_separator 4 '-' ${PF})

DESCRIPTION="Console file manager with vi(m)-like keybindings"
HOMEPAGE="http://vifm.info/"
SRC_URI="mirror://sourceforge/vifm/${MY_P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="X developer +extended-keys gtk +magic vim vim-syntax"

DEPEND="
>=sys-libs/ncurses-5.9-r3:0
magic? ( sys-apps/file )
gtk? ( x11-libs/gtk+:2 )
X? ( x11-libs/libX11 )
"
RDEPEND="
${DEPEND}
vim? ( || ( app-editors/vim app-editors/gvim ) )
vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
"

DOCS="AUTHORS FAQ NEWS README TODO"

S="${WORKDIR}/${MY_P}"

src_prepare() {
sed -i -e '/stat.h/a#include <sys/sysmacros.h>' "${S}/src/modes/file_info.c" \
|| die
eapply_user
eautoreconf
}

src_configure() {
econf \
$(use_enable developer) \
$(use_enable extended-keys) \
$(use_with magic libmagic) \
$(use_with gtk) \
$(use_with X X11)
}

src_compile() {
default
}

src_install() {
emake DESTDIR="${D}" install
dodoc ${DOCS}

if use vim; then
local t
for t in app plugin; do
insinto /usr/share/vim/vimfiles/"${t}"
doins "${S}"/data/vim/doc/"${t}"/"${PN}"*
done
fi

if use vim-syntax; then
local t
for t in ftdetect ftplugin syntax; do
insinto /usr/share/vim/vimfiles/"${t}"
doins "${S}"/data/vim/"${t}"/"${PN}".vim
done
fi
}

src_test() {
emake check
}

pkg_postinst() {
xdg_desktop_database_update
if use vim; then
update_vim_helptags

if [[ -n ${REPLACING_VERSIONS} ]]; then
elog
elog "You don't need to copy or link any files for"
elog " the vim plugin and documentation to work anymore."
elog "If you copied any vifm files to ~/.vim/ manually"
elog " in earlier vifm versions, please delete them."
fi
elog
elog "To use vim in vifm to view the documentation"
elog " edit ~/.vifm/vifmrc and set vimhelp instead of novimhelp"
elog
fi
}

pkg_postrm() {
xdg_desktop_database_update
use vim && update_vim_helptags
}

0 comments on commit 056e5b5

Please sign in to comment.