Skip to content

Commit

Permalink
app-office/libreoffice: Fix testODFEncryptedGPG, fix test deps
Browse files Browse the repository at this point in the history
Thanks-to: Thomas Deutschmann <[email protected]>
Closes: https://bugs.gentoo.org/656676
Package-Manager: Portage-2.3.40, Repoman-2.3.9
  • Loading branch information
a17r committed May 27, 2018
1 parent 9d82dbe commit 0578a15
Show file tree
Hide file tree
Showing 6 changed files with 95 additions and 1 deletion.
Original file line number Diff line number Diff line change
@@ -0,0 +1,89 @@
From 74d438f716d9cef165c78f950d4c53a46c37503c Mon Sep 17 00:00:00 2001
From: Rene Engelhard <[email protected]>
Date: Sun, 18 Mar 2018 22:25:36 +0100
Subject: gpg4libre: fix failing gpg test due to over-long filenames
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

This squashes the following commits:

From f68929ac611fdda19c1ee413effc59d33aa5ef97 Mon Sep 17 00:00:00 2001
From: Thorsten Behrens <[email protected]>
Date: Fri, 9 Mar 2018 01:38:26 +0100
Subject: gpg4libre: fix failing gpg test due to over-long filenames

With long workdir path, gpg sometimes fails with 'gpg: can't connect
to the agent: File name too long' error.
WK recommends to create preferred socket dir under /run/user, needs
prepping though via gpgconf.

See https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=84720

From d7ecf4a4e37a9eeffa2b40f9fe5a2e6a8f90c876 Mon Sep 17 00:00:00 2001
From: Rene Engelhard <[email protected]>
Date: Sun, 18 Mar 2018 11:25:41 +0100
Subject: properly check for gpgconf (and --create-socketdir) working

From d6ed1d415d36809d784af780231258ea0ee1024f Mon Sep 17 00:00:00 2001
From: Rene Engelhard <[email protected]>
Date: Sun, 18 Mar 2018 19:06:58 +0100
Subject: actually add GPGCONF to config_host.mk.in

From 7a95ee8d0badb2cbbd137a6e18af1bada35ae933 Mon Sep 17 00:00:00 2001
From: Rene Engelhard <[email protected]>
Date: Sun, 18 Mar 2018 19:26:45 +0100
Subject: actually add HAVE_GPGCONF_SOCKETDIR to config_host.mk.in...

From 5204a5145d8232ea0650144fb4756c38303ef06e Mon Sep 17 00:00:00 2001
From: Rene Engelhard <[email protected]>
Date: Sun, 18 Mar 2018 19:28:55 +0100
Subject: revert accidentially comitted local changes :(

From bc358d39ac985914160e8aaa23b29469470c032b Mon Sep 17 00:00:00 2001
From: Rene Engelhard <[email protected]>
Date: Sun, 18 Mar 2018 20:36:45 +0100
Subject: this is sh, not make...

Change-Id: I7880fd7eee57cedc19b72348b45f0c1389409fe6
Reviewed-on: https://gerrit.libreoffice.org/51521
Tested-by: Jenkins <[email protected]>
Reviewed-by: Caolán McNamara <[email protected]>
Tested-by: Caolán McNamara <[email protected]>
---
xmlsecurity/CppunitTest_xmlsecurity_signing.mk | 14 +++++++++++++-
1 file changed, 13 insertions(+), 1 deletion(-)

(limited to 'xmlsecurity/CppunitTest_xmlsecurity_signing.mk')

diff --git a/xmlsecurity/CppunitTest_xmlsecurity_signing.mk b/xmlsecurity/CppunitTest_xmlsecurity_signing.mk
index c382e3b..2f3ed41 100644
--- a/xmlsecurity/CppunitTest_xmlsecurity_signing.mk
+++ b/xmlsecurity/CppunitTest_xmlsecurity_signing.mk
@@ -52,11 +52,23 @@ ifeq ($(ENABLE_PDFIMPORT),TRUE)
$(eval $(call gb_CppunitTest_use_executable,xmlsecurity_signing,xpdfimport))
endif

-# reset the LD_LIBRARY_PATH for spawned GPG processes
+# various hacks to make unit test work on Linux more often
ifeq ($(OS),LINUX)
+# reset the LD_LIBRARY_PATH for spawned GPG processes
$(call gb_CppunitTest_get_target,xmlsecurity_signing): \
EXTRA_ENV_VARS := \
LIBO_LD_PATH=$$LD_LIBRARY_PATH
+
+ifneq (,$(HAVE_GPGCONF_SOCKETDIR))
+# create socket dir below /run/user/ instead of in workdir
+.PHONY : gb_CppunitTest_run_gpgconf
+gb_CppunitTest_run_gpgconf:
+ GNUPGHOME=$(WORKDIR)/CppunitTest/xmlsecurity_signing.test.user \
+ $(GPGCONF) --create-socketdir
+
+$(call gb_CppunitTest_get_target,xmlsecurity_signing): \
+ gb_CppunitTest_run_gpgconf
+endif
endif

# vim: set noet sw=4 ts=4:
--
cgit v1.1
Original file line number Diff line number Diff line change
Expand Up @@ -10,4 +10,4 @@ index 457aedce0acb..4f02cf2b4040 100644
+ CPPUNIT_ASSERT_EQUAL(1, getPages());

//Check if Headers/Footers contain what they should in this document
uno::Reference<text::XText> xHeaderTextRight = getProperty<uno::Reference<text::XText>>(
uno::Reference<text::XText> xHeaderTextRight = getProperty<uno::Reference<text::XText>>(
2 changes: 2 additions & 0 deletions app-office/libreoffice/libreoffice-6.0.3.2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -226,6 +226,7 @@ DEPEND="${COMMON_DEPEND}
)
odk? ( >=app-doc/doxygen-1.8.4 )
test? (
app-crypt/gnupg
dev-util/cppunit
media-fonts/dejavu
)
Expand All @@ -246,6 +247,7 @@ PATCHES=(
"${FILESDIR}/${PN}-5.3.4.2-kioclient5.patch"
# 6.0 branch
"${FILESDIR}/${P}-poppler-0.64.patch"
"${FILESDIR}/${PN}-6.0.3.2-testODFEncryptedGPG.patch" #bug 656676

# TODO: upstream
"${FILESDIR}/${PN}-5.2.5.1-glibc-2.24.patch"
Expand Down
1 change: 1 addition & 0 deletions app-office/libreoffice/libreoffice-6.0.4.2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -236,6 +236,7 @@ DEPEND="${COMMON_DEPEND}
)
odk? ( >=app-doc/doxygen-1.8.4 )
test? (
app-crypt/gnupg
dev-util/cppunit
media-fonts/dejavu
)
Expand Down
1 change: 1 addition & 0 deletions app-office/libreoffice/libreoffice-6.0.9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -236,6 +236,7 @@ DEPEND="${COMMON_DEPEND}
)
odk? ( >=app-doc/doxygen-1.8.4 )
test? (
app-crypt/gnupg
dev-util/cppunit
media-fonts/dejavu
)
Expand Down
1 change: 1 addition & 0 deletions app-office/libreoffice/libreoffice-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -235,6 +235,7 @@ DEPEND="${COMMON_DEPEND}
)
odk? ( >=app-doc/doxygen-1.8.4 )
test? (
app-crypt/gnupg
dev-util/cppunit
media-fonts/dejavu
)
Expand Down

0 comments on commit 0578a15

Please sign in to comment.