Skip to content

Commit

Permalink
dev-python/xarray: Bump to 2023.5.0
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed May 20, 2023
1 parent 00c118e commit 058f6df
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/xarray/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST xarray-2023.3.0.tar.gz 3686167 BLAKE2B b9c2e04d0278e383aef17280e74863244d458324c01ac59a453e72196d65cad8fbca9f8f99a33b6db66637f742e04e5615fa8fc6eed307f0511954a856f8f3d2 SHA512 c08269e6fc8cdd3123dd7c39e0b85959bafdc53a5da75187fc615281fb71212bf2e45059f8d18fa05339567a4827e7bb68de3e605416929a6a1defdb4ed393e3
DIST xarray-2023.4.2.tar.gz 3692437 BLAKE2B d4fb5b184386bb7e9574ea3bdf484c3df82b9dca1fcd2380ac65b6a58da9f89da057d70efa9bd045b5cf6900c38f6aa4176fd2990cfe1369f987c452711307d6 SHA512 581b06a677b80c0f7e494a80ae52d75bd62bf613b13b7b7215458ceef727fb55a898c8da8cc6f8a6875ef6898007897eea8be55fb138f1dacad42965bbf1d956
DIST xarray-2023.5.0.tar.gz 3707468 BLAKE2B 55ee416c41aff8edcb609adcac1c0a2e1d4ae896c25ae3d771d755930725f69f854feac42c42558db598acc5d0a852370198908d85d5af9664c485052948f4ca SHA512 ab6538b280f05acc296d8d73003e07f494d330a2a6a486d2f3dac121aee9682e2fa46c05be868b23a31584c908e0f6454757bdac7ec032d3a6f79a4500c0629f
56 changes: 56 additions & 0 deletions dev-python/xarray/xarray-2023.5.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..11} )

inherit distutils-r1 multiprocessing pypi

DESCRIPTION="N-D labeled arrays and datasets in Python"
HOMEPAGE="
https://xarray.pydata.org/
https://github.com/pydata/xarray/
https://pypi.org/project/xarray/
"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"

RDEPEND="
>=dev-python/numpy-1.22[${PYTHON_USEDEP}]
>=dev-python/pandas-1.4[${PYTHON_USEDEP}]
>=dev-python/packaging-21.3[${PYTHON_USEDEP}]
"
# note: most of the test dependencies are optional
BDEPEND="
dev-python/setuptools-scm[${PYTHON_USEDEP}]
test? (
dev-python/bottleneck[${PYTHON_USEDEP}]
dev-python/hypothesis[${PYTHON_USEDEP}]
dev-python/matplotlib[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
dev-python/toolz[${PYTHON_USEDEP}]
!hppa? ( >=dev-python/scipy-1.4[${PYTHON_USEDEP}] )
)
"

distutils_enable_tests pytest

EPYTEST_DESELECT=(
# warning-targeted tests are fragile and not important to end users
xarray/tests/test_backends.py::test_no_warning_from_dask_effective_get
# TODO: segv in netcdf4-python
'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-5-5]'
'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-5-None]'
'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-None-5]'
'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-None-None]'
xarray/tests/test_backends.py::TestDask::test_save_mfdataset_compute_false_roundtrip
)

python_test() {
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest -p xdist.plugin -n "$(makeopts_jobs)"
}

0 comments on commit 058f6df

Please sign in to comment.