Skip to content

Commit

Permalink
kde-apps/cantor: 21.11.90 version bump
Browse files Browse the repository at this point in the history
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Nov 29, 2021
1 parent 92daa33 commit 059a4fe
Show file tree
Hide file tree
Showing 2 changed files with 113 additions and 0 deletions.
1 change: 1 addition & 0 deletions kde-apps/cantor/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST cantor-21.08.3.tar.xz 9190432 BLAKE2B fb701abadad15ca4579f54bb6d5504dd5d791c2090181c957493b001e61cd1ec6737c314db3929e7b2b6b4503e368235ce24b57a93bd5ceae572f9c555088545 SHA512 9ecfd88016138dc6e15afcf034f53907e706fb5eb972174198c22f061d3feb0b4ffa9698c5f6b4caafe3ef102e7554ae2ed125ac46850f509e35000f8ee02a0b
DIST cantor-21.11.90.tar.xz 9184608 BLAKE2B 92de38f5273e15dc391004f355212b01fe192bd8897ca27fbef0bbd8a5aebea09c9d0494a655dbfad1e95c802deb760be2726917df17a984d90dfd4aa3f36957 SHA512 bba01f8826d6df15115c8bd90204b99ca402cd7865a0d5d7a1050e5715c90b6900ea9e644a4bafce07aa4ac6df6ee5df0cda506ab2aa2ea7a7ca3315b054a04e
112 changes: 112 additions & 0 deletions kde-apps/cantor/cantor-21.11.90.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,112 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

CMAKE_MAKEFILE_GENERATOR="emake"
ECM_HANDBOOK="forceoptional"
ECM_TEST="forceoptional"
LUA_COMPAT=( luajit )
PYTHON_COMPAT=( python3_{8..10} )
PVCUT=$(ver_cut 1-3)
KFMIN=5.88.0
QTMIN=5.15.2
inherit ecm kde.org lua-single optfeature python-single-r1

DESCRIPTION="Interface for doing mathematics and scientific computing"
HOMEPAGE="https://apps.kde.org/cantor/ https://edu.kde.org/cantor/"

LICENSE="GPL-2" # TODO: CHECK
SLOT="5"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="+analitza julia lua postscript python qalculate R"

REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} ) python? ( ${PYTHON_REQUIRED_USE} )"
RESTRICT="test"

# TODO Add Sage Mathematics Software backend (https://www.sagemath.org)
DEPEND="
app-text/poppler[qt5]
>=dev-qt/qtgui-${QTMIN}:5
>=dev-qt/qthelp-${QTMIN}:5
>=dev-qt/qtprintsupport-${QTMIN}:5
>=dev-qt/qtsvg-${QTMIN}:5
>=dev-qt/qtwebengine-${QTMIN}:5[widgets]
>=dev-qt/qtwidgets-${QTMIN}:5
>=dev-qt/qtxml-${QTMIN}:5
>=dev-qt/qtxmlpatterns-${QTMIN}:5
>=kde-frameworks/karchive-${KFMIN}:5
>=kde-frameworks/kcompletion-${KFMIN}:5
>=kde-frameworks/kconfig-${KFMIN}:5
>=kde-frameworks/kconfigwidgets-${KFMIN}:5
>=kde-frameworks/kcoreaddons-${KFMIN}:5
>=kde-frameworks/kcrash-${KFMIN}:5
>=kde-frameworks/ki18n-${KFMIN}:5
>=kde-frameworks/kiconthemes-${KFMIN}:5
>=kde-frameworks/kio-${KFMIN}:5
>=kde-frameworks/knewstuff-${KFMIN}:5
>=kde-frameworks/kparts-${KFMIN}:5
>=kde-frameworks/kpty-${KFMIN}:5
>=kde-frameworks/ktexteditor-${KFMIN}:5
>=kde-frameworks/ktextwidgets-${KFMIN}:5
>=kde-frameworks/kwidgetsaddons-${KFMIN}:5
>=kde-frameworks/kxmlgui-${KFMIN}:5
>=kde-frameworks/syntax-highlighting-${KFMIN}:5
analitza? ( >=kde-apps/analitza-${PVCUT}:5 )
julia? ( dev-lang/julia )
lua? ( ${LUA_DEPS} )
qalculate? (
sci-libs/cln
sci-libs/libqalculate:=
)
postscript? ( app-text/libspectre )
python? (
${PYTHON_DEPS}
>=dev-qt/qtdbus-${QTMIN}:5
)
R? ( dev-lang/R )
"
RDEPEND="${DEPEND}
!analitza? ( !julia? ( !lua? ( !python? ( !qalculate? ( !R? (
|| (
sci-mathematics/maxima
sci-mathematics/octave
)
) ) ) ) ) )
"
BDEPEND="x11-misc/shared-mime-info"

pkg_setup() {
use lua && lua-single_pkg_setup
use python && python-single-r1_pkg_setup
ecm_pkg_setup
}

src_configure() {
use julia && addpredict /proc/self/mem # bug 602894

local mycmakeargs=(
$(cmake_use_find_package analitza Analitza5)
$(cmake_use_find_package julia Julia)
$(cmake_use_find_package lua LuaJIT)
-DUSE_LIBSPECTRE=$(usex postscript)
$(cmake_use_find_package python Python3)
$(cmake_use_find_package qalculate Qalculate)
$(cmake_use_find_package R R)
)
use lua && mycmakeargs+=(
-DLUAJIT_INCLUDEDIR="${EPREFIX}/$(lua_get_include_dir)"
-DLUAJIT_LIBDIR="${EPREFIX}/$(lua_get_cmod_dir)"
)
use python && mycmakeargs+=( -DPython3_EXECUTABLE="${PYTHON}" )
ecm_src_configure
}

pkg_postinst() {
if [[ -z "${REPLACING_VERSIONS}" ]]; then
optfeature "Maxima backend" sci-mathematics/maxima
optfeature "Octave backend" sci-mathematics/octave
optfeature "LaTeX support" virtual/latex-base
fi
ecm_pkg_postinst
}

0 comments on commit 059a4fe

Please sign in to comment.