Skip to content

Commit

Permalink
dev-libs/intel-common: version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
  • Loading branch information
SoapGentoo committed Feb 17, 2016
1 parent a3911cf commit 05bb4b8
Show file tree
Hide file tree
Showing 2 changed files with 60 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/intel-common/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -21,3 +21,4 @@ DIST parallel_studio_xe_2015.tgz 3819862086 SHA256 31abe447b1db457b38547dfbf0fd7
DIST parallel_studio_xe_2015_update1.tgz 4044230603 SHA256 84fdf48d1de20e1d580ba5d419a5bc1c55d217a4f5dc1807190ecffe0229a62b SHA512 894c911dce9d261fbe67d65c91c3b6c7117b183102fe7673a5e106d14994a082fdf03fdb573bbb1a9f0a01cf1539082b72ec75c39db7590bb2f63222f9a5b832 WHIRLPOOL f43b219ba82aa3f94c6818c54b971302f3693cb1c0266924f7ee79c67d6008699388afedaf4b2f72e969a73c8fd7d276309d80ff4dc8dfb1ba766cbe19b33872
DIST parallel_studio_xe_2015_update2.tgz 4145283363 SHA256 8cbde4d4fb3bbfcc5096d5d924953121ca84e9a9bee7b00dfd07c029c1a89943 SHA512 1166eaa41c881059673dbf51194cf800fbc94a1080fc9eebbacc20cd762c3b2e92f83191cb1cdacc50da0c8522524b7132d269fc2a91615ba4fbda5c63cb7a47 WHIRLPOOL 95e93fc964f0ddbd81e87d3c8083adea3f8ab82fc0668dc00b10154ba8911bd50d07be9d2130a1b27c7ea66e5208e172055df4fee69f336ae777d629ca7874d4
DIST parallel_studio_xe_2015_update3.tgz 4156836825 SHA256 ab7169989c87bbb0fe66221cb7eb3a26b17c8b9ceff38f1926e5607834306896 SHA512 eccc2bfe85ccd039a2ec9e334d370e49d43baa0522d095c087a5982aa08bddb4c97bfc3125bd09f5cd57d3ed252c598012e1f2670b8373a1b3bb455825d18f96 WHIRLPOOL d1fd8d1e46ce35150357a9452f04529d8a1f7e915e50a5d714895184aa37fb61186a5455e89b4750f444f0f6da94563e493d0821c661378551c3739f8d27d7b9
DIST parallel_studio_xe_2015_update6.tgz 4190044333 SHA256 e604ed2bb45d227b151dd2898f3edd93526d58d1db1cb9d6b6f614907864f392 SHA512 a9896289db8e820f02c330702ff1e954af11af5f9bbc0e5623a001b3a8c33a2bcb8660ac8b0e569994a3682bfd263bf119dbe6a43fb343139adbeaaaa13f8a81 WHIRLPOOL 997c96d0d9d6c603f8659a5ece91aa55b9a7bf5b428065ac55a0fa3d5577dab7fcc61157a983eb355832dc7c201fde4e5fcc9ff7bcb4d8b656847c2c1092b1dd
59 changes: 59 additions & 0 deletions dev-libs/intel-common/intel-common-15.0.6.233.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

INTEL_DPN=parallel_studio_xe
INTEL_DID=8470
INTEL_DPV=2015_update6
INTEL_SUBDIR=composerxe
INTEL_SINGLE_ARCH=false

inherit intel-sdp

DESCRIPTION="Common libraries and utilities needed for Intel compilers and libraries"
HOMEPAGE="http://software.intel.com/en-us/articles/intel-compilers/"

IUSE="+compiler"
KEYWORDS="-* ~amd64 ~x86 ~amd64-linux ~x86-linux"

CHECKREQS_DISK_BUILD=375M

pkg_setup() {
einfo ${INTEL_SDP_EDIR}
INTEL_BIN_RPMS="openmp openmp-devel"
INTEL_DAT_RPMS="compilerpro-common compilerpro-common-pset"
if use compiler; then
INTEL_BIN_RPMS+=" compilerpro-devel sourcechecker-devel"
INTEL_DAT_RPMS+=" compilerpro-vars sourcechecker-common ccompxe compxe fcompxe"
fi
intel-sdp_pkg_setup
}

src_install() {
intel-sdp_src_install
local path rootpath ldpath arch fenv=35intelsdp
cat > ${fenv} <<-EOF
NLSPATH=${INTEL_SDP_EDIR}/lib/locale/en_US/%N
INTEL_LICENSE_FILE="${INTEL_SDP_EDIR}"/licenses:"${EPREFIX}/opt/intel/license"
EOF
for arch in ${INTEL_ARCH}; do
path=${path}:${INTEL_SDP_EDIR}/bin/${arch}:${INTEL_SDP_EDIR}/mpirt/bin/${arch}
rootpath=${rootpath}:${INTEL_SDP_EDIR}/bin/${arch}:${INTEL_SDP_EDIR}/mpirt/bin/${arch}
ldpath=${ldpath}:${INTEL_SDP_EDIR}/compiler/lib/${arch}:${INTEL_SDP_EDIR}/mpirt/lib/${arch}
done
cat >> ${fenv} <<-EOF
PATH=${path#:}
ROOTPATH=${rootpath#:}
LDPATH=${ldpath#:}
EOF

doenvd ${fenv}

cat >> "${T}"/40-${PN} <<- EOF
SEARCH_DIRS_MASK="${INTEL_SDP_EDIR}"
EOF
insinto /etc/revdep-rebuild/
doins "${T}"/40-${PN}
}

0 comments on commit 05bb4b8

Please sign in to comment.