Skip to content

Commit

Permalink
gnustep-libs/sope: 4.3.2 bump
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/725630
Package-Manager: Portage-3.0.1, Repoman-2.3.23
Signed-off-by: Bernard Cafarelli <[email protected]>
  • Loading branch information
voyageur committed Jul 29, 2020
1 parent 8cea020 commit 05d0847
Show file tree
Hide file tree
Showing 2 changed files with 63 additions and 0 deletions.
1 change: 1 addition & 0 deletions gnustep-libs/sope/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST sope-4.1.1.tar.gz 2202428 BLAKE2B 551306a5d722442d60f68d132a21023bd7acf2fb2dcefdfcb0e1a053c03bf3c5af3afc954ec4b76e4db56799ff8cdd931ca8038fb7b3c41e5dff915858e49013 SHA512 fe672ba3b6b42bcc67f98efcb49bbe7f61f3e2fa9a0b2c571b60978425714916fe35f43283f27efaf8d568e53e6e0b6b1f80a7a63cf5b3df001e1d591cb386df
DIST sope-4.3.2.tar.gz 2203224 BLAKE2B a51f87ac5b6e2cbb432fa1a63f6240d9c3309d600d82040096f65140933d6ac2cc875dc3c0db88e1cd3ff944b3c85fd0155fde03ee27c894e3416c8aec9abedd SHA512 bbdd78d08af26f435f3faaaa89833b7f910443a971ccde34236af30bed54a6ff50b3bee52990902a74a40abf2050db53a198e208e10a515fd6353b0c9e6eb447
62 changes: 62 additions & 0 deletions gnustep-libs/sope/sope-4.3.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,62 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit gnustep-2 vcs-snapshot

DESCRIPTION="A set of frameworks forming a complete Web application server environment"
HOMEPAGE="http://www.sogo.nu/"
SRC_URI="https://github.com/inverse-inc/sope/archive/SOPE-${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="gnutls ldap libressl mysql postgres +ssl +xml"

RDEPEND="
sys-libs/zlib
ldap? ( net-nds/openldap )
gnutls? ( net-libs/gnutls:= )
!gnutls? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
)
mysql? ( dev-db/mysql-connector-c:= )
postgres? ( dev-db/postgresql:= )
xml? ( dev-libs/libxml2:2 )
"
DEPEND="${RDEPEND}"

pkg_pretend() {
if use ssl && use gnutls && use libressl ; then
ewarn "You have enabled both gnutls and libressl, but only"
ewarn "one provider can be active. Using gnutls!"
fi
}

src_configure() {
local ssl_provider
if use ssl ; then
if use gnutls ; then
ssl_provider=gnutls
else
ssl_provider=ssl
fi
else
ssl_provider=none
fi

egnustep_env

# Non-standard configure script
./configure \
--disable-strip \
$(use_enable debug) \
$(use_enable ldap openldap) \
$(use_enable mysql) \
$(use_enable postgres postgresql) \
$(use_enable xml) \
--with-ssl="${ssl_provider}" \
--with-gnustep || die "configure failed"
}

0 comments on commit 05d0847

Please sign in to comment.