Skip to content

Commit

Permalink
dev-libs/re2: bump to 2016-05-01
Browse files Browse the repository at this point in the history
Closes: gentoo#1213
Package-Manager: portage-2.2.28_p97
  • Loading branch information
floppym committed May 8, 2016
1 parent 8948a98 commit 0621475
Show file tree
Hide file tree
Showing 3 changed files with 95 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/re2/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST re2-20130115.tgz 1020951 SHA256 a95d83ed8203817587f7cc368b6f7199d8a4b1558372c306b07201058b92e1fe SHA512 ef1378d89397bf594ece7817ef91171e467a3408046f769eca08beba900a0e70f652e7c4e3b667b3a9d5cef044b08ed74ef7d564ffb965ab75bb9a3964c9ab5a WHIRLPOOL 2cbf47b1816e35e5c7f359a310b4421ad635d1513167ffabf98db84397be800f8b98d4808705754f0e2db14bbeb0d62e47ac3abb385e299c503126a9f874daf5
DIST re2-20130712.tgz 1028311 SHA256 c30e43524280ebc2b9afa8c40ad477d0b2665bc81b663e9ae1b8b48e053af54b SHA512 910e7c7f5b3268746355c2e14dc6a4e32105207abcf8cb56b76fc554be41768e4e4a6b526c9335e95be0bb111025876b61ede1cfebcbec4a4062d53bb1448e08 WHIRLPOOL e5cf26a6c8586503c1639dd3f528cace8a4d7ca4c4ff97e08b12f45753ff67ad78656513658eabd678ac8ab88f1de5279960428fffe1b9e0535afdba44e7e8a3
DIST re2-20140304.tgz 1050493 SHA256 0bffd1a57de2f4b218ca0f77d8850bfd59c82944a98256c6edba25260e0196a7 SHA512 a426e8d69d2c7614087990180539c5b1aa2c544dee14b144098f810b76b6062d7de9efaf1e90e83c61c8e4382a066201862d09965f1a6a9f86e2912011ad9d40 WHIRLPOOL d998a6dd9edac52fe0c4ed7e895940380d9b67220711d68aed02294c8f65a644a59f77bddce116ccf79860c633046fa2b5060ef45d5cb5ea5bc0c1965cdce052
DIST re2-2016-05-01.tar.gz 399509 SHA256 d9d13f0ea4e1c6628b1cb85eeee284d4fdd4948da94b1f205096254927092e3d SHA512 6d37ab1eae51a73f60d3c8280ea1162c420638363f0eb1313d7c2d5cee65a5abd4c2927da1a53572afbcb7d07fac2993a7e54c6cbc85e24aaae93c46dab19b14 WHIRLPOOL b601349800341d213b01219cf2171873be551488c71c2c06fbab1da27c20719fca12e0cfac30ac4e8ed0eb062a445b4c008491fd0e379f629434e0c9b4649a7e
47 changes: 47 additions & 0 deletions dev-libs/re2/files/0.2016.05.01-pkgconfig.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
From 7dc941862819398db2ac4ae4239c8ed05431f928 Mon Sep 17 00:00:00 2001
From: Mike Gilbert <[email protected]>
Date: Sun, 8 May 2016 11:54:00 -0400
Subject: [PATCH] Substitute includedir and libdir in re2.pc

---
Makefile | 5 ++++-
re2.pc => re2.pc.in | 5 ++---
2 files changed, 6 insertions(+), 4 deletions(-)
rename re2.pc => re2.pc.in (71%)

diff --git a/Makefile b/Makefile
index d0e2090..4a8d8a6 100644
--- a/Makefile
+++ b/Makefile
@@ -273,7 +273,10 @@ install: obj/libre2.a obj/so/libre2.$(SOEXT)
$(INSTALL) obj/so/libre2.$(SOEXT) $(DESTDIR)$(libdir)/libre2.$(SOEXTVER00)
ln -sf libre2.$(SOEXTVER00) $(DESTDIR)$(libdir)/libre2.$(SOEXTVER)
ln -sf libre2.$(SOEXTVER00) $(DESTDIR)$(libdir)/libre2.$(SOEXT)
- sed -e "s#@prefix@#${prefix}#" re2.pc >$(DESTDIR)$(libdir)/pkgconfig/re2.pc
+ sed -e "s#@prefix@#$(prefix)#" \
+ -e "s#@includedir@#$(includedir)#" \
+ -e "s#@libdir@#$(libdir)#" \
+ re2.pc.in >$(DESTDIR)$(libdir)/pkgconfig/re2.pc

testinstall: static-testinstall shared-testinstall
@echo
diff --git a/re2.pc b/re2.pc.in
similarity index 71%
rename from re2.pc
rename to re2.pc.in
index 91ba181..a04a70a 100644
--- a/re2.pc
+++ b/re2.pc.in
@@ -1,7 +1,6 @@
prefix=@prefix@
-exec_prefix=${prefix}
-includedir=${prefix}/include
-libdir=${exec_prefix}/lib
+includedir=@includedir@
+libdir=@libdir@

Name: re2
Description: RE2 is a fast, safe, thread-friendly regular expression engine.
--
2.8.2

47 changes: 47 additions & 0 deletions dev-libs/re2/re2-0.2016.05.01.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit multilib-minimal toolchain-funcs

# Different date format used upstream.
RE2_VER=${PV#0.}
RE2_VER=${RE2_VER//./-}

DESCRIPTION="An efficent, principled regular expression library"
HOMEPAGE="https://www.github.com/google/re2/"
SRC_URI="https://www.github.com/google/re2/archive/${RE2_VER}.tar.gz -> ${PN}-${RE2_VER}.tar.gz"

LICENSE="BSD"
# NOTE: Always run libre2 through abi-compliance-checker!
SLOT="0/0.2016.05.01"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="icu"

RDEPEND="icu? ( dev-libs/icu:0= )"
DEPEND="${RDEPEND}
icu? ( virtual/pkgconfig )"

S="${WORKDIR}/${PN}-${RE2_VER}"

PATCHES=( "${FILESDIR}/${PV}-pkgconfig.patch" )
DOCS=( "AUTHORS" "CONTRIBUTORS" "README" "doc/syntax.txt" )
HTML_DOCS=( "doc/syntax.html" )

src_prepare() {
default
if use icu; then
sed -i -e 's:^# \(\(CC\|LD\)ICU=.*\):\1:' Makefile || die
fi
multilib_copy_sources
}

src_configure() {
tc-export AR CXX NM
}

multilib_src_install() {
emake DESTDIR="${D}" prefix="${EPREFIX}/usr" libdir="\$(exec_prefix)/$(get_libdir)" install
}

0 comments on commit 0621475

Please sign in to comment.