Skip to content

Commit

Permalink
app-admin/integrit: Bump to version 4.2_rc1.
Browse files Browse the repository at this point in the history
Fixed build with >=sys-devel/autoconf-2.70

Closes: https://bugs.gentoo.org/775746
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Mar 16, 2021
1 parent 6fc7e23 commit 068c5c1
Show file tree
Hide file tree
Showing 2 changed files with 71 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/integrit/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST integrit-4.1.tar.gz 271626 BLAKE2B 538a34c8e5c00e1be66ba35095be4d61402372ea7fd9ba9bfff9149c9a82c43d625ffb345fe84b7561100b31f2a2a1ba319e8b9a7d2b78e44a81d1ed6ae64f3a SHA512 599ae66a193fd87971994f59422e148e1ae01a5ff0fea93a0f2555c972f5254f0213116950766e72c87a57b1bd490f04afd3e0557d25a366c41dbbacc80b6842
DIST integrit-4.2_rc1.tar.gz 223627 BLAKE2B ff0dead8a8903dba0f43c7746672ca2d57aced352df2fef7b195fc90e9b38e77bb21affb40c424c5d23df7dcecf3192c1bff5c7c04d3fcbc5dad0dae60565f93 SHA512 2a86a37c684ca0b78bbf7901c8e72511f1169e8af7e9b4efdeadbade52e8fc7302167f6d82bd02b5af9688a05d13fc56d4f5474e3e04d1aef3dd9f72d782d739
70 changes: 70 additions & 0 deletions app-admin/integrit/integrit-4.2_rc1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,70 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit autotools

MY_PV="${PV/_/-}"

DESCRIPTION="file integrity verification program"
HOMEPAGE="http://integrit.sourceforge.net/"
SRC_URI="https://github.com/integrit/integrit/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""

# Tests don't work in 4.2_rc1. Please re-check on version bump!
RESTRICT="test"

S="${WORKDIR}/${PN}-${MY_PV}"

PATCHES=( "${FILESDIR}"/${PN}-4.1-fix-build-system.patch )

src_prepare() {
default
mv configure.{in,ac} || die
mv hashtbl/configure.{in,ac} || die

eautoreconf
touch ar-lib || die #775746
}

src_compile() {
emake
emake utils

emake -C doc
emake -C hashtbl hashtest
}

src_install() {
dosbin integrit
dolib.a libintegrit.a
dodoc Changes HACKING README todo.txt

# utils
dosbin utils/i-viewdb
dobin utils/i-ls

# hashtbl
dolib.a hashtbl/libhashtbl.a
doheader hashtbl/hashtbl.h
dobin hashtbl/hashtest
newdoc hashtbl/README README.hashtbl

# doc
doman doc/{i-ls.1,i-viewdb.1,integrit.1}
doinfo doc/integrit.info

# examples
dodoc -r examples
}

pkg_postinst() {
elog "It is recommended that the integrit binary is copied to a secure"
elog "location and re-copied at runtime or run from a secure medium."
elog "You should also create a configuration file (see examples)."
}

0 comments on commit 068c5c1

Please sign in to comment.