Skip to content

Commit

Permalink
dev-haskell/extra: fix test, bump up to 1.5.1, bug #624030
Browse files Browse the repository at this point in the history
Reported-by: Toralf Förster
Bug: https://bugs.gentoo.org/624030
Package-Manager: Portage-2.3.6, Repoman-2.3.2
  • Loading branch information
Sergei Trofimovich committed Jul 6, 2017
1 parent 3e74bd0 commit 06bc93e
Show file tree
Hide file tree
Showing 4 changed files with 53 additions and 1 deletion.
1 change: 1 addition & 0 deletions dev-haskell/extra/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST extra-1.3.1.tar.gz 30439 SHA256 94c8cc02b530e589171d2e0520afac066994a1cb48cd4c847496387489230dfa SHA512 d6e736a021ee39139855516647b91a328e8ff075b94bdcc84c1296586d9f58a20819fcf78a45bd0fc9b3e9516780c68fb27ec0dc406964b6d9d5c93e26bfc9c5 WHIRLPOOL f8d02f3cd149f3d1dd5e30a5411f3359a2e4590061856f8f0350e63b4baafa961ade1ca142696dd1b1db97dc7ec35dc5481e836a4eaaf62803f55cf66b40caac
DIST extra-1.4.10.tar.gz 34981 SHA256 b40b3f74c02e40697f4ba5242a764c2846921e8aafdd92e79a30a7afd9e56759 SHA512 16b7bbe3944d7013a54dfe629f997bb46a24c9b933a6be9570cd86f6b1bace9c001acb0b5b8d92ddf50aa21ca67d5694d3705029116644012345d20f1e3386fd WHIRLPOOL d7dd9403179259f1778e92c3fdab86474f4aba7584f23f829db32d8fd49f6c59ab672534c2bbb14c175c09a265a606a2cade7dd094b30daf2957f0e59ba0f377
DIST extra-1.4.2.tar.gz 31311 SHA256 0ea699d56bb08ad6e70ee6aaa2069326c2bc76ac347c0f04e94ce38cf3ec30c1 SHA512 5d0c5ee70d51fa4d132b5e7813908a65badbf339cfcae4182932933b70cb7b8faf659d22c624086757c38973aeff769b5175bf533bbb51c3ec419ba09bb28409 WHIRLPOOL f8090b12f6412d9a15b115cad88b760053844549e5132a2def334f2ced98c51d3e87d45786bdaa55c862bcafea054211c4d2f3bea81f134b0c8e60a3f81c89c6
DIST extra-1.5.1.tar.gz 35989 SHA256 8f3397c7a176045f1bb3b2a181e36b54192cb6fb5e99a9d28552975130ec49fc SHA512 c3a0d7abc589e4a175c5c090b4a850751b0f231a3934db3bb87f4a11044acfcb161aa366789b3c6b5415778578ca126c3469f648fa326fa5ebec0889c59005e8 WHIRLPOOL 9a133604957c373b02c6d712ab9f1a08258f414e551c50f97d9244e31845534b40239dec9f02518ac5d2f79709462dcafb1f5d5e3c4f8390413dbaaedc41bbad
4 changes: 3 additions & 1 deletion dev-haskell/extra/extra-1.4.10.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
Expand All @@ -23,3 +23,5 @@ DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.10
test? ( dev-haskell/quickcheck )
"

PATCHES=("${FILESDIR}"/${P}-QC-2.9.patch)
26 changes: 26 additions & 0 deletions dev-haskell/extra/extra-1.5.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

# ebuild generated by hackport 0.5.1.9999

CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal

DESCRIPTION="Extra functions I use"
HOMEPAGE="https://github.com/ndmitchell/extra#readme"
SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"

LICENSE="BSD"
SLOT="2/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE=""

RDEPEND=">=dev-haskell/clock-0.7:=[profile?]
>=dev-lang/ghc-7.4.1:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.18
test? ( >=dev-haskell/quickcheck-2.9 )
"
23 changes: 23 additions & 0 deletions dev-haskell/extra/files/extra-1.4.10-QC-2.9.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
diff --git a/test/TestUtil.hs b/test/TestUtil.hs
index 87f3417..cda262f 100644
--- a/test/TestUtil.hs
+++ b/test/TestUtil.hs
@@ -72,3 +72,5 @@ instance Testable () where
property = property . (`seq` True)
+#if ! MIN_VERSION_QuickCheck(2,9,0)
exhaustive _ = True
+#endif

@@ -76,3 +78,6 @@ instance Testable a => Testable (IO a) where
property = property . unsafePerformIO
+#if ! MIN_VERSION_QuickCheck(2,9,0)
exhaustive = exhaustive . unsafePerformIO
+#endif
+

@@ -107,3 +112,5 @@ instance Arbitrary DiffTime where

+#if ! MIN_VERSION_QuickCheck(2,9,2)
instance Arbitrary Version where
arbitrary = makeVersion . map abs <$> listOf1 arbitrary
+#endif

0 comments on commit 06bc93e

Please sign in to comment.