Skip to content

Commit

Permalink
games-strategy/wesnoth: Version 1.14.4.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.43, Repoman-2.3.10
  • Loading branch information
Jeroen Roovers committed Jul 23, 2018
1 parent cf9dde4 commit 06c3f5a
Show file tree
Hide file tree
Showing 2 changed files with 115 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-strategy/wesnoth/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST wesnoth-1.14.2.tar.gz 489041516 BLAKE2B f38f3596edd97096e39ee1e87e13a3d0402d0f9f0f67f25ce1e4a28123abc62ca7b2410c8420a4091d505bf64219cdf92c1cfed562ae2f3705c37685d7c2c20e SHA512 010dcdeaf03d3855192d2480facbfce134459b71acb06515196968dd66b5e1fc40bd75eeeb8b7dd7fc30c9b43af004784d9907893c4b1d61e57436457afc30bb
DIST wesnoth-1.14.3.tar.gz 489258637 BLAKE2B bc6c49a768d07387f8f4a285801964acd4476819075cedfd9dd2a0bbe36706e93badd78d4bd4468b687d3d34073c59e4a67dde7a578dabfd26f224233eb87413 SHA512 57c6766edce3b7984da9e6bc795913e1a582e4afac8c287b603ad2173f49d26095af903b3f10938a3b04d4f2921c3a2a5f2239c6c3a4d88222fabd9601a833aa
DIST wesnoth-1.14.4.tar.gz 489503950 BLAKE2B 2802098a83169d1dd3d0d38052145b7da006992843d748fdc263fe04ed0f485c2a46a93569e2728e152d76361d3651f0f207d2cfdd7b6bb59ae7cdec43680cd7 SHA512 d867d68278075536c61eb87c32dd43bcd832de0dd20f9c941e2c5a2f413b95ba1897b5401721a0e895934afe79bb568ea155d8fe648dac58c519289fc7d12885
114 changes: 114 additions & 0 deletions games-strategy/wesnoth/wesnoth-1.14.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,114 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit cmake-utils user

DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
HOMEPAGE="http://www.wesnoth.org
https://github.com/wesnoth/wesnoth"
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~x86-fbsd"
IUSE="dbus dedicated doc fribidi libressl nls openmp server"

RDEPEND="
>=dev-libs/boost-1.50:=[nls,threads,icu]
>=media-libs/libsdl2-2.0.4:0[joystick,video,X]
!dedicated? (
dev-libs/glib:2
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
>=media-libs/fontconfig-2.4.1
>=media-libs/sdl2-image-2.0.0[jpeg,png]
>=media-libs/sdl2-mixer-2.0.0[vorbis]
>=media-libs/sdl2-ttf-2.0.12
media-libs/libvorbis
>=x11-libs/pango-1.22.0
>=x11-libs/cairo-1.10.0
sys-libs/readline:0
dbus? ( sys-apps/dbus )
fribidi? ( dev-libs/fribidi )
)"
DEPEND="${RDEPEND}
sys-devel/gettext
virtual/pkgconfig
x11-libs/libX11
"

pkg_setup() {
if use openmp; then
tc-has-openmp || die "Please switch to an openmp compatible compiler"
fi

enewgroup ${PN}
enewuser ${PN} -1 /bin/bash -1 ${PN}
}

src_prepare() {
cmake-utils_src_prepare

if ! use doc ; then
sed -i \
-e '/manual/d' \
doc/CMakeLists.txt || die
fi

# respect LINGUAS (bug #483316)
if [[ ${LINGUAS+set} ]] ; then
local langs
for lang in $(cat po/LINGUAS)
do
has $lang $LINGUAS && langs+="$lang "
done
echo "$langs" > po/LINGUAS || die
fi
}

src_configure() {
filter-flags -ftracer -fomit-frame-pointer
if [[ $(gcc-major-version) -eq 3 ]] ; then
filter-flags -fstack-protector
append-flags -fno-stack-protector
fi

# Work around eclass
append-flags -UNDEBUG

if use dedicated || use server ; then
mycmakeargs=(
-DENABLE_CAMPAIGN_SERVER="ON"
-DENABLE_SERVER="ON"
-DSERVER_UID="${PN}"
-DSERVER_GID="${PN}"
-DFIFO_DIR="/run/wesnothd"
)
else
mycmakeargs=(
-DENABLE_CAMPAIGN_SERVER="OFF"
-DENABLE_SERVER="OFF"
)
fi
mycmakeargs+=(
-Wno-dev
-DENABLE_GAME="$(usex !dedicated)"
-DENABLE_DESKTOP_ENTRY="$(usex !dedicated)"
-DENABLE_NLS="$(usex nls)"
-DENABLE_NOTIFICATIONS="$(usex dbus)"
-DENABLE_FRIBIDI="$(usex fribidi)"
-DENABLE_OMP="$(usex openmp)"
-DENABLE_STRICT_COMPILATION="OFF"
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
)
cmake-utils_src_configure
}

src_install() {
DOCS="README.md changelog.md players_changelog.md" cmake-utils_src_install
if use dedicated || use server; then
rmdir "${ED%/}/run/wesnothd" || die
newinitd "${FILESDIR}"/wesnothd.rc-r1 wesnothd
fi
}

0 comments on commit 06c3f5a

Please sign in to comment.