forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
mate-base/mate-settings-daemon: Version bump to 1.18.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
- Loading branch information
Showing
2 changed files
with
73 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST mate-settings-daemon-1.12.1.tar.xz 781388 SHA256 a0d9ea55ba5828500e873eff6c771dae645fa3218c1ba9d701c408f0eb71e988 SHA512 36c0d2cacef22db1d27e694602ee390fd0a24e3478837fd7fbfe069f55278c7a7ff3f7d280e0bf9cd4e827beeb9b3d40f505e5772686036e47e3d0b7d1e4b47e WHIRLPOOL 771efca75fa7c0d337648b81e52f81d085fc62287e34ccdb132c3844fedbb7e3df2a49e327d7a34048515c661ac417cffa5d5c4f74a7589f136af2e628bc2a32 | ||
DIST mate-settings-daemon-1.14.1.tar.xz 760936 SHA256 81bc955ecebd054939cb5f90338ed86616f5aebedd8ecc581600120f5db374ad SHA512 e237c1c7df4a42183e3c3079c88dfc94422b604ed9b197363a5ea9bfdf7a16782681f6d82ee3b5b7c5edac6b90b0f2875072a108f5fe9b954bbbf1c8cc27e6d5 WHIRLPOOL 1ac365064a8980557867f8bab22f8cdf17020536c439778fc2419065c8e19469ea3bcadfbddef5b57bfdac9a7b39c949989eca300d81bf0bb240c62806c0aa57 | ||
DIST mate-settings-daemon-1.16.0.tar.xz 767136 SHA256 7876b7377adb89a11812c1b3fd44e1e78f371f8418f4f05bf5be25ea8efce4d0 SHA512 39ab6cd52008bfb92949f225b003186ed27f9ad215a59015a3ccaa1f02e618b786fe9db94d993bc89660b03c50700b364de1ac4a9b7cf23a83ca545fc93bbee3 WHIRLPOOL 618fe5ac34387111f4ea80bb93964b86d4888f1f8a8a106bdbc4269c2b3f6333e5f4d68734b8d7becd796e0827560435c1d7c6e77e76961a7c726abf17d5234d | ||
DIST mate-settings-daemon-1.18.1.tar.xz 778776 SHA256 a64597c7bb9ac56b9b3f71671a20a3e68a83da4893b5f97293f6808dfb94621d SHA512 35ea953a508c1a8a2359a13f36789f2b171873e2b153f3c7e5e779a900672cf19a4f36892136d4886e61349f536706f0ab0e781cbde3e246c490c66af3e621d6 WHIRLPOOL 249a70d96be48aa378a20c78aa651129c2de1a21ed3911deccd3ccb167796d4e88bde7620c3acb76bdebf1ad428e2847812a47ffb1be6b25e0b281fb2beb3906 |
72 changes: 72 additions & 0 deletions
72
mate-base/mate-settings-daemon/mate-settings-daemon-1.18.1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,72 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
MATE_LA_PUNT="yes" | ||
|
||
inherit mate | ||
|
||
if [[ ${PV} != 9999 ]]; then | ||
KEYWORDS="~amd64 ~arm ~x86" | ||
fi | ||
|
||
DESCRIPTION="MATE Settings Daemon" | ||
LICENSE="GPL-2 LGPL-2.1" | ||
SLOT="0" | ||
|
||
IUSE="X debug libnotify policykit pulseaudio smartcard +sound" | ||
|
||
REQUIRED_USE="pulseaudio? ( sound )" | ||
|
||
COMMON_DEPEND=">=dev-libs/dbus-glib-0.74:0 | ||
>=dev-libs/glib-2.17.3:2 | ||
>=gnome-base/dconf-0.13.4:0 | ||
>=mate-base/libmatekbd-1.17.0 | ||
>=mate-base/mate-desktop-1.17.0 | ||
media-libs/fontconfig:1.0 | ||
x11-libs/cairo:0 | ||
x11-libs/gdk-pixbuf:2 | ||
>=x11-libs/gtk+-3.14:3 | ||
x11-libs/libX11:0 | ||
x11-libs/libXi:0 | ||
x11-libs/libXext:0 | ||
x11-libs/libXxf86misc:0 | ||
>=x11-libs/libxklavier-5.2:0 | ||
virtual/libintl:0 | ||
libnotify? ( >=x11-libs/libnotify-0.7:0 ) | ||
policykit? ( | ||
>=dev-libs/dbus-glib-0.71:0 | ||
>=sys-apps/dbus-1.1.2:0 | ||
>=sys-auth/polkit-0.97:0 | ||
) | ||
pulseaudio? ( | ||
>=media-libs/libmatemixer-1.10:0[pulseaudio] | ||
>=media-sound/pulseaudio-0.9.15:0 | ||
) | ||
smartcard? ( >=dev-libs/nss-3.11.2:0 ) | ||
sound? ( | ||
>=media-libs/libmatemixer-1.10:0 | ||
media-libs/libcanberra:0[gtk3] | ||
)" | ||
|
||
RDEPEND="${COMMON_DEPEND}" | ||
|
||
DEPEND="${COMMON_DEPEND} | ||
>=dev-util/intltool-0.50.1:0 | ||
sys-devel/gettext:0 | ||
virtual/pkgconfig:0 | ||
x11-proto/inputproto:0 | ||
x11-proto/xproto:0" | ||
|
||
src_configure() { | ||
mate_src_configure \ | ||
$(use_with X x) \ | ||
$(use_with libnotify) \ | ||
$(use_with sound libcanberra) \ | ||
$(use_with sound libmatemixer) \ | ||
$(use_enable debug) \ | ||
$(use_enable policykit polkit) \ | ||
$(use_enable pulseaudio pulse) \ | ||
$(use_enable smartcard smartcard-support) | ||
} |