forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
kde-apps/kdeartwork-wallpapers: Add missing DEPEND, KDE_DEBUG=false
KDEInstallDirs calls query_qmake which requires qtcore. Package-Manager: portage-2.2.27
- Loading branch information
1 parent
4522d29
commit 06dc05f
Showing
1 changed file
with
34 additions
and
0 deletions.
There are no files selected for viewing
34 changes: 34 additions & 0 deletions
34
kde-apps/kdeartwork-wallpapers/kdeartwork-wallpapers-15.08.3-r2.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,34 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
RESTRICT="binchecks strip" | ||
|
||
KMNAME="kdeartwork" | ||
KDE_AUTODEPS="false" | ||
KDE_DEBUG="false" | ||
inherit kde5 | ||
|
||
DESCRIPTION="Wallpapers from KDE" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
DEPEND=" | ||
$(add_frameworks_dep extra-cmake-modules) | ||
$(add_qt_dep qtcore) | ||
" | ||
RDEPEND="!kde-apps/kdeartwork-wallpapers:4" | ||
|
||
PATCHES=( "${FILESDIR}/${P}-kf5-port.patch" ) | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DDISABLE_ALL_OPTIONAL_SUBDIRECTORIES=TRUE | ||
-DBUILD_wallpapers=TRUE | ||
-DBUILD_HighResolutionWallpapers=TRUE | ||
) | ||
|
||
kde5_src_configure | ||
} |