Skip to content

Commit

Permalink
media-libs/jasper: Version bump to 2.0.12
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
SoapGentoo committed Mar 29, 2017
1 parent 46dba86 commit 07191dc
Show file tree
Hide file tree
Showing 2 changed files with 66 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/jasper/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST jasper-1.900.6.tar.gz 787271 SHA256 5d0b4d684d19104b4564ef7142f4059eda91902620af36a3a6205d3dae66e027 SHA512 096e77609bf977eb0bbc9b1fc804bce7be1c7c81d066db7e367b61c4f6fa772a7a7ef21f7613485de46c3ca22cce57dce1e80c3736f54eb77eb44153218983b6 WHIRLPOOL 23edd5abc05248b43085f5a77a0210dcaf52089c57e31686478bd9b01284f294459ac1cad71eae4a594ef2632ba4323190b25d1a37dd36af0c0d7cd69579e568
DIST jasper-2.0.10.tar.gz 1310613 SHA256 d48193de3b82e7f5792fe933fba2ef6714228de4d904ce98f3d69217ed7a85ec SHA512 8f96f72b73197088ff28364c7b4db79745a3188aa9be888ad3b211541bb4d1e45f23604b36d0b6c4176a432c2da888d1e31f119279aaab73e09430699e036859 WHIRLPOOL 37f98278af2baf2978b21a894c618166b4086c744c21ce953bad1b7aec9191550eda7d161aa93533c6a8f36399160633de5ea912e5d1e7ac37d5b3eece48062b
DIST jasper-2.0.12.tar.gz 1311323 SHA256 f0bcc1c4de5fab199f2e792acf269eb34d54689777c305d80e2498788f9f204b SHA512 a308983511119d85e6580772f5164c188e2e170500fa4b98c8831aa63aa87cb661b88952b278e390497571f9ebf9286855a8aa946037692309ba5f41cffe265a WHIRLPOOL 375eebf63f99081171d04414bae4ef0ce5514955818ddf5c985e9dc7bb93e539bf4b90adecdd497c43bcf0658d68c9261cc7e53f164d3fe5436e02da778f6ee3
65 changes: 65 additions & 0 deletions media-libs/jasper/jasper-2.0.12.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit cmake-multilib

DESCRIPTION="Implementation of the codec specified in the JPEG-2000 Part-1 standard"
HOMEPAGE="http://www.ece.uvic.ca/~mdadams/jasper/"

if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/mdadams/jasper.git"
else
inherit vcs-snapshot
SRC_URI="https://github.com/mdadams/${PN}/archive/version-${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 \
~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux \
~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
fi

# We limit memory usage to 128 MiB by default, specified in bytes
: ${JASPER_MEM_LIMIT:=134217728}

LICENSE="JasPer2.0"
SLOT="0/4"
IUSE="doc jpeg opengl"

RDEPEND="
jpeg? ( >=virtual/jpeg-0-r2:0[${MULTILIB_USEDEP}] )
opengl? (
>=virtual/opengl-7.0-r1:0[${MULTILIB_USEDEP}]
>=media-libs/freeglut-2.8.1:0[${MULTILIB_USEDEP}]
virtual/glu[${MULTILIB_USEDEP}]
x11-libs/libXi[${MULTILIB_USEDEP}]
x11-libs/libXmu[${MULTILIB_USEDEP}]
)"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"

multilib_src_configure() {
local mycmakeargs=(
-DALLOW_IN_SOURCE_BUILD=OFF
-DBASH_PROGRAM="${EPREFIX}"/bin/bash
-DJAS_ENABLE_ASAN=OFF
-DJAS_ENABLE_LSAN=OFF
-DJAS_ENABLE_MSAN=OFF
-DJAS_ENABLE_SHARED=ON
-DJAS_ENABLE_STRICT=ON
-DJAS_ENABLE_USAN=OFF
-DCMAKE_INSTALL_DOCDIR=share/doc/${PF}

# JPEG
-DJAS_ENABLE_LIBJPEG=$(usex jpeg)
-DCMAKE_DISABLE_FIND_PACKAGE_JPEG=$(usex !jpeg)

# OpenGL
-DJAS_ENABLE_OPENGL=$(usex opengl)
-DCMAKE_DISABLE_FIND_PACKAGE_OpenGL=$(usex !opengl)

# Doxygen
-DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=$(multilib_native_usex doc OFF ON)
)
cmake-utils_src_configure
}

0 comments on commit 07191dc

Please sign in to comment.