Skip to content

Commit

Permalink
dev-python/imexam: initial import
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.2
  • Loading branch information
sfabbro committed Jul 19, 2017
1 parent a98f903 commit 072da0c
Show file tree
Hide file tree
Showing 4 changed files with 128 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/imexam/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST imexam-0.7.1.tar.gz 20264259 SHA256 99579305e71f22fd06e4ed95e0d38edd0474832e9b87ef3f6abcd243ed8ad46f SHA512 cb09d1764de19333fa6be1bbb9e6efd3d59943fdef4ccac4e8429e436dd615fa5be3a06c9473cc2c3ff1de1a8987d02ef24765de5b36131c31451b013be8d776 WHIRLPOOL 6c45aa0006d1217df6fd7fc4c2b0fa01a6cf4efcb26bd8adf16832823b229407ed20394202b3298f9e5433e3330cbd33469eaf215af863523011d6286afff89b
52 changes: 52 additions & 0 deletions dev-python/imexam/files/imexam-0.7.1-system-xpa.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
From: Ole Streicher <[email protected]>
Date: Fri, 21 Apr 2017 13:40:06 +0200
Subject: Use external xpa

---
setup.py | 15 +++------------
1 file changed, 3 insertions(+), 12 deletions(-)

diff --git a/setup.py b/setup.py
index f0dd5d5..f291201 100644
--- a/setup.py
+++ b/setup.py
@@ -121,24 +121,20 @@ if not sys.platform.startswith('win'):
xpaio.c
""".split()

- XPA_SOURCES = [os.path.join(XPALIB_DIR, c) for c in XPA_FILES]
- XPALIB_DEFINES = [("HAVE_CONFIG_H", "1")]
+ XPA_SOURCES = []
+ XPALIB_DEFINES = []
XPA_SOURCES.append(CYTHON_SOURCE)

xpa_module = Extension("xpa",
sources=XPA_SOURCES,
- include_dirs=[XPALIB_DIR],
define_macros=XPALIB_DEFINES,
- depends=[CONF_H_NAME],
+ libraries = ['xpa'],
)
if use_cython:
ext = cythonize(xpa_module)

class my_clean(clean):
def run(self):
- import subprocess
- subprocess.call(["make", "clean"],
- cwd=XPALIB_DIR)
if os.access(CONF_H_NAME, os.F_OK):
os.remove(CONF_H_NAME)
os.remove("wrappers/xpa.c")
@@ -147,11 +143,6 @@ if not sys.platform.startswith('win'):

class build_ext_with_configure(build_ext):
def build_extensions(self):
- import subprocess
- subprocess.call(["make", "-f", "Makefile", "clean"],
- cwd=XPALIB_DIR)
- subprocess.call(["sh", "./configure"], cwd=XPALIB_DIR)
- subprocess.call(["make", "-f", "Makefile"], cwd=XPALIB_DIR)
build_ext.build_extensions(self)

cmdclass.update({'build_ext': build_ext_with_configure,
54 changes: 54 additions & 0 deletions dev-python/imexam/imexam-0.7.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python{2_7,3_5,3_6} )

inherit distutils-r1 xdg-utils

DESCRIPTION="Simple interactive astronomical image examination and plotting"
HOMEPAGE="https://imexam.readthedocs.io"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE="doc test"

RDEPEND="
dev-python/astropy[${PYTHON_USEDEP}]
dev-python/ginga[${PYTHON_USEDEP}]
dev-python/ipython[${PYTHON_USEDEP}]
dev-python/matplotlib[${PYTHON_USEDEP}]
sci-libs/scipy[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/astropy-helpers[${PYTHON_USEDEP}]
dev-python/cython[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"

PATCHES=( "${FILESDIR}"/${P}-system-xpa.patch )

python_prepare_all() {
# use system astropy-helpers instead of bundled one
sed -i -e '/auto_use/s/True/False/' setup.cfg || die
echo "backend: Agg" > "${T}"/matplotlibrc || die
xdg_environment_reset
distutils-r1_python_prepare_all
}

python_compile_all() {
if use doc; then
python_setup
VARTEXFONTS="${T}"/fonts \
MPLCONFIGDIR="${T}" \
PYTHONPATH="${BUILD_DIR}"/lib \
esetup.py build_docs --no-intersphinx
HTML_DOCS=( docs/_build/html/. )
fi
}

python_test() {
esetup.py test -v
}
21 changes: 21 additions & 0 deletions dev-python/imexam/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,21 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>Gentoo Astronomy Project</name>
</maintainer>
<longdescription lang="en">
Imexam is an affiliated package of AstroPy. It was designed to be a
lightweight library which enables users to explore data using common
methods which are consistent across viewers. It can be used from a
command line interface, through a Jupyter notebook or through a
Jupyter console. It can be used with multiple viewers, such as DS9 or
Ginga, or without a viewer as a simple library to make plots and grab
quick photometry information.
</longdescription>
<upstream>
<remote-id type="pypi">imexam</remote-id>
<remote-id type="github">spacetelescope/imexam</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit 072da0c

Please sign in to comment.