Skip to content

Commit

Permalink
app-admin/puppetdb: 6.3.3 bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.66, Repoman-2.3.15
Signed-off-by: Matthew Thode <[email protected]>
  • Loading branch information
prometheanfire committed Jun 22, 2019
1 parent 0178d3a commit 075aeb3
Show file tree
Hide file tree
Showing 2 changed files with 93 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/puppetdb/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST puppetdb-5.2.7.tar.gz 24353701 BLAKE2B 196b336a92031a25f7f28ca070a831857f3e0dde3ecc02e12e6884f3628c12dcc27b347c39147636addc975841f340fbf89196e86b3c10efc2ad1f16cf6f882a SHA512 989fa232d0fbd90c975fe110caca9b9c92a90167eb7b8d0384282dd8cf85111a56174c6785d7c73800e19185e879e258b8e6cefb210c1c44a229ce994336ef1d
DIST puppetdb-6.3.2.tar.gz 41707817 BLAKE2B 480737af3abc862e90a7075011327ce3821a5d9460c785602c105ec7accc82f2ea712ae488c585226126e88f817cbb1acda7fa09793b7508aa38cc47e1c76ab0 SHA512 e2a3ce73c976cbbfa6acc62612187478cf5ecc9d514ff4866a74e2c6364979f17c3daeba0f03a01e7fc3eeb1ca84a3c886fd5eed07d2a9fbaa5fd9f7c9d577af
DIST puppetdb-6.3.3.tar.gz 41714959 BLAKE2B 0d3e2e33e24dea7bf375bfb104131bf54bcb93ea8318ea73b0027ced3a9a504849c2680657f329c7c4e017b1b41b6381684c82944e739822bc875007c85124d2 SHA512 a40e8e35bdfc6279015280f55a06dabac0e75bc60c37278334cc72af893809ba28b6e0477909797fac354bae2649d14c0337536914eb00123d0d758ea4e972f8
92 changes: 92 additions & 0 deletions app-admin/puppetdb/puppetdb-6.3.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,92 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit multilib systemd user

DESCRIPTION="PuppetDB collects data generated by Puppet."
HOMEPAGE="http://docs.puppetlabs.com/puppetdb/"
SRC_URI="https://downloads.puppetlabs.com/${PN}/${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
IUSE=""
# will need the same keywords as puppet
KEYWORDS="~amd64 ~x86"

RDEPEND+=">=virtual/jdk-1.8.0"
DEPEND+=""

pkg_setup() {
enewgroup puppetdb
enewuser puppetdb -1 -1 /opt/puppetlabs/server/data/puppetdb "puppetdb"
}

src_prepare() {
sed -i 's/sysconfig/conf\.d/g' ext/redhat/puppetdb.service || die
sed -i 's/sysconfig/conf\.d/g' ext/bin/puppetdb || die
sed -i 's/sysconfig/conf\.d/g' install.sh || die
sed -i 's/var\/run/run/g' ext/puppetdb.tmpfiles.conf || die
sed -i 's/var\/run/run/g' install.sh || die
default
}

src_compile() {
einfo "not compiling"
}

src_install() {
dodir /opt/puppetlabs/server/data/puppetdb
insinto /opt/puppetlabs/server/apps/puppetdb
insopts -m0744
doins ext/ezbake-functions.sh
insopts -m0644
doins ext/ezbake.manifest
doins puppetdb.jar
insinto /etc/puppetlabs/puppetdb
doins ext/config/logback.xml
doins ext/config/bootstrap.cfg
doins ext/config/request-logging.xml
insinto /etc/puppetlabs/puppetdb/conf.d
doins ext/config/conf.d/jetty.ini
doins ext/config/conf.d/repl.ini
doins ext/config/conf.d/database.ini
doins ext/config/conf.d/config.ini
insopts -m0755
insinto /opt/puppetlabs/server/apps/puppetdb/scripts
doins install.sh
insinto /opt/puppetlabs/server/apps/puppetdb/cli/apps
doins ext/cli/foreground
doins ext/cli/ssl-setup
doins ext/cli/config-migration
doins ext/cli/foreground
doins ext/cli/anonymize
doins ext/cli/reload
doins ext/cli/start
doins ext/cli/stop
insinto /opt/puppetlabs/server/apps/puppetdb/bin
doins ext/bin/puppetdb
insopts -m0644
dodir /opt/puppetlabs/server/bin
dosym ../apps/puppetdb/bin/puppetdb /opt/puppetlabs/server/bin/puppetdb
dodir /opt/puppetlabs/bin
dosym ../server/apps/puppetdb/bin/puppetdb /opt/puppetlabs/bin/puppetdb
dosym ../../opt/puppetlabs/server/apps/puppetdb/bin/puppetdb /usr/bin/puppetdb
# init type tasks
newconfd ext/default puppetdb
systemd_dounit ext/redhat/puppetdb.service
systemd_newtmpfilesd ext/puppetdb.tmpfiles.conf puppetdb.conf
newinitd "${FILESDIR}/puppetdb.initd-r2" puppetdb
# misc
insinto /etc/logrotate.d
newins ext/puppetdb.logrotate.conf puppetdb
fowners -R puppetdb:puppetdb /opt/puppetlabs/server/data/puppetdb
fperms -R 770 /opt/puppetlabs/server/data/puppetdb
}

pkg_postinst() {
elog "to install please run '/opt/puppetlabs/server/bin/puppetdb ssl-setup'"
elog
elog "to upgrade please run '/opt/puppetlabs/server/bin/puppetdb config-migration'"
}

0 comments on commit 075aeb3

Please sign in to comment.