Skip to content

Commit

Permalink
app-emulation/runc: version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
Signed-off-by: Doug Goldstein <[email protected]>
  • Loading branch information
cardoe committed Apr 19, 2016
1 parent 7239e60 commit 076b7f3
Show file tree
Hide file tree
Showing 3 changed files with 97 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/runc/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST runc-0.0.2.tar.gz 370712 SHA256 3d0aa68ebb1622853d0bbed432ebd4b6c9ef210881ac74f3a695b4e914d246dc SHA512 e0a44d5dd8a1b8eaeaf7d466cebc7dc8beaa26f49bd0e76d3a955cef9c5c266d2afe6652f28fa905a408b5b93966f52e345112fa7aef373216561ad7069181c5 WHIRLPOOL e7ed1ee3d159a81fb0b2b0f5fac9a9a66116035babc88f6f266a6c8455953ce372e93351baf7c621c42ab8c5907961fd899b1d158e7f7b1335f83fcef7252c71
DIST runc-0.0.5.tar.gz 441874 SHA256 e80323412883e4afcfcf8e1b2eaefdcb74632628d02fd7f48618caf78e5e4aa0 SHA512 625d67ec02e23c66a3d1a97113a0c58f3f200404866839556bc3cd5b3e34342230b8091613d17ef4a38d05ca51df586cd7366dc6bddeeddd6b69bb9a2ae7efda WHIRLPOOL 862b08621b67fc57286940ad5e20557d90cfef63aae5be0a90fc6f5b764d032b187ba5ad5dcb1fa99fb5ec59d6217941aa19ca9048637bd02b64e52c8cecdce6
DIST runc-0.1.0.tar.gz 496358 SHA256 681d6d89541ae2e06757f999a242a1f97bbcb1ad6e10f4cdee287ec4a9d2bff9 SHA512 8a9ff02b0161eda0a730194b0fbf7ad76e8f379992e74061ef49302da3492fd0c53f06db9153ded4d934d67bbf6f4291d6154254f1b924ef73c97c44cd14ffcf WHIRLPOOL 81f488a4f1e23e8704a9fa8404965b2f12f74a875ba8e67dc15de93f43b075dc538cd0d89c7a1187cb74ac6320317b5985855945fb8bf8f749d6736df47b844a
48 changes: 48 additions & 0 deletions app-emulation/runc/runc-0.1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit eutils multilib

DESCRIPTION="runc container cli tools"
HOMEPAGE="http://runc.io"

GITHUB_URI="github.com/opencontainers/runc"

if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="git://${GITHUB_URI}.git"
inherit git-r3
else
SRC_URI="https://${GITHUB_URI}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi

LICENSE="Apache-2.0"
SLOT="0"
IUSE="+seccomp"

DEPEND=">=dev-lang/go-1.4:="
RDEPEND="seccomp? ( sys-libs/libseccomp )"

src_compile() {
# Taken from app-emulation/docker-1.7.0-r1
export CGO_CFLAGS="-I${ROOT}/usr/include"
export CGO_LDFLAGS="-L${ROOT}/usr/$(get_libdir)"

# Setup GOPATH so things build
rm -rf .gopath
mkdir -p .gopath/src/"$(dirname "${GITHUB_URI}")"
ln -sf ../../../.. .gopath/src/"${GITHUB_URI}"
export GOPATH="${PWD}/.gopath:${PWD}/vendor"

# build up optional flags
local options=( $(usex seccomp "seccomp") )

emake BUILDTAGS="${options[@]}"
}

src_install() {
dobin runc
}
48 changes: 48 additions & 0 deletions app-emulation/runc/runc-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit eutils multilib

DESCRIPTION="runc container cli tools"
HOMEPAGE="http://runc.io"

GITHUB_URI="github.com/opencontainers/runc"

if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="git://${GITHUB_URI}.git"
inherit git-r3
else
SRC_URI="https://${GITHUB_URI}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi

LICENSE="Apache-2.0"
SLOT="0"
IUSE="+seccomp"

DEPEND=">=dev-lang/go-1.4:="
RDEPEND="seccomp? ( sys-libs/libseccomp )"

src_compile() {
# Taken from app-emulation/docker-1.7.0-r1
export CGO_CFLAGS="-I${ROOT}/usr/include"
export CGO_LDFLAGS="-L${ROOT}/usr/$(get_libdir)"

# Setup GOPATH so things build
rm -rf .gopath
mkdir -p .gopath/src/"$(dirname "${GITHUB_URI}")"
ln -sf ../../../.. .gopath/src/"${GITHUB_URI}"
export GOPATH="${PWD}/.gopath:${PWD}/vendor"

# build up optional flags
local options=( $(usex seccomp "seccomp") )

emake BUILDTAGS="${options[@]}"
}

src_install() {
dobin runc
}

0 comments on commit 076b7f3

Please sign in to comment.