Skip to content

Commit

Permalink
media-gfx/gnome-photos: Version bump to 40.0
Browse files Browse the repository at this point in the history
Signed-off-by: Matt Turner <[email protected]>
  • Loading branch information
mattst88 committed Apr 16, 2021
1 parent 76042de commit 07906c9
Show file tree
Hide file tree
Showing 3 changed files with 99 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-gfx/gnome-photos/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST gnome-photos-3.34.2.tar.xz 639992 BLAKE2B f189e7e1a831f4d19416b689733ef6a55822d57b5f1ea29a4dcb4fc06d5f9a450e45aaf53f65e392ac78e9959f7359f3df17827a326cfd6dbf8cc7d77cc0a367 SHA512 6315fb8e7623de48a42f1b47a2935c80f8f9f6db1ab724d1857697f673c4ca0d5ca1afa5c0d147455c3c0ad0224b85b52a220b1dd39a1409804bb75794d0a04b
DIST gnome-photos-40.0.tar.xz 632440 BLAKE2B 4a3be35e627169afa4b3b9aca2c675f6035f3e46822450fc479550a3e48aebba6f9e335dc528a6593f1bd844fde501b8535ed368be9825f229280a08d5ead7e6 SHA512 70641e7fc6375e15cadc62ad75804d3ffb1d2193dd0bbed21b291b38f1d271ba7d34a4714a1658b9f13345f20e421190958b4713aae64f4f46913628079ba814
97 changes: 97 additions & 0 deletions media-gfx/gnome-photos/gnome-photos-40.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,97 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
PYTHON_COMPAT=( python3_{7..9} )

inherit gnome.org gnome2-utils meson python-any-r1 virtualx xdg

DESCRIPTION="Access, organize and share your photos on GNOME"
HOMEPAGE="https://wiki.gnome.org/Apps/Photos"

LICENSE="GPL-3+ LGPL-2+ CC0-1.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="flickr test upnp-av"
RESTRICT="!test? ( test )"

DEPEND="
media-libs/babl
>=x11-libs/cairo-1.14.0
>=x11-libs/gdk-pixbuf-2.36.8:2
>=media-libs/gegl-0.4.0:0.4[cairo,raw]
sci-geosciences/geocode-glib
>=media-libs/gexiv2-0.10.8
>=dev-libs/glib-2.62.0:2
>=net-libs/gnome-online-accounts-3.8.0:=
>=media-libs/grilo-0.3.5:0.3=
gnome-base/gsettings-desktop-schemas
>=x11-libs/gtk+-3.22.16:3
>=dev-libs/libdazzle-3.26.0
>=dev-libs/libgdata-0.17.13:0=[gnome-online-accounts]
>=net-libs/libgfbgraph-0.2.1:0.2
>=gui-libs/libhandy-1.1.90:1=
virtual/jpeg:0
>=media-libs/libpng-1.6:0=
app-misc/tracker:3=
sys-apps/dbus
"
# gnome-online-miners is also used for google, facebook, DLNA - not only flickr
# but out of all the grilo-plugins, only upnp-av and flickr get used, which have USE flags here,
# so don't pull it always, but only if either USE flag is enabled.
# tracker-miners gschema used at runtime.
RDEPEND="${DEPEND}
net-misc/gnome-online-miners[flickr?]
upnp-av? ( media-plugins/grilo-plugins:0.3[upnp-av] )
flickr? ( media-plugins/grilo-plugins:0.3[flickr] )
app-misc/tracker-miners:3
"
BDEPEND="
dev-libs/appstream-glib
dev-util/desktop-file-utils
dev-util/gdbus-codegen
dev-util/glib-utils
dev-util/itstool
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
test? ( $(python_gen_any_dep 'dev-util/dogtail[${PYTHON_USEDEP}]') )
"

DOCS=() # meson installs docs itself

python_check_deps() {
use test && has_version "dev-util/dogtail[${PYTHON_USEDEP}]"
}

pkg_setup() {
use test && python-any-r1_pkg_setup
}

src_prepare() {
xdg_src_prepare
sed -i -e "/photos_docdir.*=.*join_paths/s/meson.project_name()/'${PF}'/" meson.build
}

src_configure() {
local emesonargs=(
$(meson_use test dogtail)
-Dflatpak=false
-Dinstalled_tests=false
-Dmanuals=true
)
meson_src_configure
}

src_test() {
virtx meson_src_test
}

pkg_postinst() {
xdg_pkg_postinst
gnome2_schemas_update
}

pkg_postrm() {
xdg_pkg_postrm
gnome2_schemas_update
}
1 change: 1 addition & 0 deletions profiles/package.mask
Original file line number Diff line number Diff line change
Expand Up @@ -85,6 +85,7 @@ x11-misc/xstroke
>=sys-process/gnome-usage-3.38
>=media-plugins/grilo-plugins-0.3.13
>=media-sound/gnome-music-40
>=media-gfx/gnome-photos-40

# Michał Górny <[email protected]> (2021-04-10)
# Obsolete backport to Python < 3.4. No reverse dependencies left.
Expand Down

0 comments on commit 07906c9

Please sign in to comment.