Skip to content

Commit

Permalink
dev-db/mysql++: Fix build for Bug 629492 and general build cleanup
Browse files Browse the repository at this point in the history
Installed files are unchanged

Package-Manager: Portage-2.3.8, Repoman-2.3.3
  • Loading branch information
Brian Evans committed Sep 1, 2017
1 parent a900af2 commit 080a631
Show file tree
Hide file tree
Showing 2 changed files with 46 additions and 3 deletions.
31 changes: 31 additions & 0 deletions dev-db/mysql++/files/mysql++-3.2.3-mariadb-10.2.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,31 @@
diff -Naur mysql++-3.2.2-ORIG/lib/dbdriver.cpp mysql++-3.2.2/lib/dbdriver.cpp
--- mysql++-3.2.2-ORIG/lib/dbdriver.cpp 2017-07-14 14:56:06.206629443 +0200
+++ mysql++-3.2.2/lib/dbdriver.cpp 2017-07-14 15:28:34.690826959 +0200
@@ -257,7 +257,11 @@
}

if ((n == 1) &&
+#ifdef CLIENT_LONG_PASSWORD
(o >= CLIENT_LONG_PASSWORD) &&
+#else
+ (o >= CLIENT_MYSQL) &&
+#endif
#if MYSQL_VERSION_ID > 40000 // highest flag value varies by version
(o <= CLIENT_MULTI_RESULTS)
#else
diff -aurN a/lib/common.h b/lib/common.h
--- a/lib/common.h 2016-12-30 18:44:44.000000000 -0500
+++ b/lib/common.h 2017-09-01 09:12:12.270089396 -0400
@@ -130,12 +130,6 @@
#define MYSQLPP_PATH_SEPARATOR '/'
#endif

-#if defined(MYSQLPP_MYSQL_HEADERS_BURIED)
-# include <mysql/mysql_version.h>
-#else
-# include <mysql_version.h>
-#endif
-
namespace mysqlpp {

/// \brief Alias for 'true', to make code requesting exceptions more
18 changes: 15 additions & 3 deletions dev-db/mysql++/mysql++-3.2.3.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@

EAPI=6

inherit eutils
inherit autotools libtool flag-o-matic

DESCRIPTION="C++ API interface to the MySQL database"
HOMEPAGE="http://tangentsoft.net/mysql++/"
Expand All @@ -19,16 +19,28 @@ DEPEND="${RDEPEND}"
DOCS=( CREDITS.txt HACKERS.txt Wishlist doc/ssqls-pretty )

src_prepare() {
# Bug filed upstream about deprecated std::auto_ptr
append-cxxflags $(test-flags-CXX -Wno-deprecated-declarations)
# Bad symlink for libtool in the archive
rm "${S}/ltmain.sh" || die
eapply "${FILESDIR}/${PN}-3.2.1-gold.patch"
eapply "${FILESDIR}/${PN}-3.2.3-mariadb-10.2.patch"
eapply_user
_elibtoolize --auto-ltdl --install --copy --force
elibtoolize
# Current MySQL libraries are always with threads and slowly being removed
sed -i -e "s/mysqlclient_r/mysqlclient/" "${S}/configure" || die
rm "${S}/doc/"README-*-RPM.txt || die
}

src_configure() {
local myconf="--enable-thread-check --with-mysql=${EPREFIX}/usr"
econf ${myconf}
local myconf=(
--enable-thread-check
--with-mysql="${EPREFIX}/usr"
--with-mysql-lib="${EPREFIX}$(mysql_config --variable=pkglibdir)"
--with-mysql-include="${EPREFIX}$(mysql_config --variable=pkgincludedir)"
)
econf "${myconf[@]}"
}

src_install() {
Expand Down

0 comments on commit 080a631

Please sign in to comment.