Skip to content

Commit

Permalink
net-misc/remmina: bump to version 1.2.0_rc15
Browse files Browse the repository at this point in the history
- Change license to GPL-2+
- Remove RDEPEND on xorg-server[kdrive] (optional runtime dependency)
- Remove 'debug' USE flag (unused)
- Remove 'vte' USE flag (now controlled by the 'ssh' USE flag)
- Add 'spice' USE flag (support for the SPICE remote-display protocol)

Gentoo-Bug: 591518
Package-Manager: portage-2.3.0

Closes: gentoo#2096

Signed-off-by: Yixun Lan <[email protected]>
  • Loading branch information
diogocp authored and dlan17 committed Aug 18, 2016
1 parent 892ba97 commit 081a6b9
Show file tree
Hide file tree
Showing 3 changed files with 85 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-misc/remmina/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST remmina-1.2.0_rc14.tar.gz 940432 SHA256 00c854cd08438399f3788606bf5ee6e4fad48016bab25b3c853c93e85e371050 SHA512 02d5db7c061b760d2b101e2e5b906015c8192b5cc30d75ce649c522e4d7f53ade2dff65324c244139bfce491d31a413342a330dfe0b217af5847e1adbb53935f WHIRLPOOL 31ac11f07665d05e4d48712b8364670c8529a9a96a76809c28fa52327b5a75efff561b7ae4e38f70c8579e15356b7b8ab98ed8af30bc967a8a75c8b913bb7e3e
DIST remmina-1.2.0_rc15.tar.gz 968958 SHA256 cb26d7894cfe0da2998b3de1861c36265d02ab1f8dc5375081e69d66b0c7d615 SHA512 58527e7e834fbd770cf841cfc8f23707f96b030d7e9e991bd2901f89d2ea4eb33afddc238bf70c4d80e03076b9276d62ff8e29e61fc3982b8355b5b7a62cbd5e WHIRLPOOL eb2c162bb68a26a59baa7901747cb04aa35ffce1fbfd0da0f716676f8af4b54b757f0c07ad7c19f837a1877f90ee08b97ef2f8249a00a3512ade11a8c2ffcd94
DIST remmina-1.2.0_rc3.tar.gz 791812 SHA256 bfe352cd87b031585d867d519c3a36ee117cca9cc79efb7c11cd11d0f9697208 SHA512 e740cbeda40bfca96c846c77140120ff92803f1bf5fff15c3eb3ba90e7ebe9ccbfa04825ad3fca96c09a5440f496934711141dedc665572965bf0d9c32e053da WHIRLPOOL 1686a4e029a9cd3019b2dc0b59c715cc67b66d6c75337c7032a72ee0228e1df7d7dfd8dc7fb7f51d6298a1c886b29d45b7352bf7a9e025ecb1cd184b08d385ed
1 change: 1 addition & 0 deletions net-misc/remmina/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -21,6 +21,7 @@
<use>
<flag name="freerdp">Add support for the net-misc/freerdp application</flag>
<flag name="libsecret">Enable libsecret support to store login credentials</flag>
<flag name="spice">Support connecting to SPICE-enabled virtual machines</flag>
<flag name="ssh">Enable support for SSH/SFTP protocol; see also 'vte'</flag>
<flag name="telepathy">Enable telepathy support</flag>
<flag name="vte">Enable virtual terminal support (for SSH sessions)</flag>
Expand Down
83 changes: 83 additions & 0 deletions net-misc/remmina/remmina-1.2.0_rc15.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,83 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit cmake-utils gnome2-utils

MY_PV="${PV//_rc/-rcgit.}"

DESCRIPTION="A GTK+ RDP, VNC, XDMCP and SSH client"
HOMEPAGE="http://remmina.org/"
SRC_URI="https://github.com/FreeRDP/Remmina/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="ayatana crypt freerdp gnome-keyring nls spice ssh telepathy webkit zeroconf"

RDEPEND="
>=dev-libs/glib-2.31.18:2
>=net-libs/libvncserver-0.9.8.2
x11-libs/libxkbfile
x11-libs/gdk-pixbuf
x11-libs/gtk+:3
x11-libs/libX11
virtual/freedesktop-icon-theme
ayatana? ( dev-libs/libappindicator:3 )
crypt? ( dev-libs/libgcrypt:0= )
freerdp? ( >=net-misc/freerdp-2 )
gnome-keyring? ( app-crypt/libsecret )
spice? ( net-misc/spice-gtk[gtk3] )
ssh? ( net-libs/libssh[sftp]
x11-libs/vte:2.91 )
telepathy? ( net-libs/telepathy-glib )
webkit? ( net-libs/webkit-gtk:4 )
zeroconf? ( net-dns/avahi[gtk3] )
"
DEPEND="${RDEPEND}
dev-util/intltool
virtual/pkgconfig
nls? ( sys-devel/gettext )
"
RDEPEND+="
!net-misc/remmina-plugins
"

DOCS=( README.md )

S="${WORKDIR}/Remmina-${MY_PV}"

src_configure() {
local mycmakeargs=(
-DWITH_APPINDICATOR=$(usex ayatana)
-DWITH_GCRYPT=$(usex crypt)
-DWITH_FREERDP=$(usex freerdp)
-DWITH_LIBSECRET=$(usex gnome-keyring)
-DWITH_GETTEXT=$(usex nls)
-DWITH_TRANSLATIONS=$(usex nls)
-DWITH_SPICE=$(usex spice)
-DWITH_LIBSSH=$(usex ssh)
-DWITH_VTE=$(usex ssh)
-DWITH_TELEPATHY=$(usex telepathy)
-DWITH_SURVEY=$(usex webkit)
-DWITH_AVAHI=$(usex zeroconf)
-DGTK_VERSION=3
)
cmake-utils_src_configure
}

pkg_preinst() {
gnome2_icon_savelist
}

pkg_postinst() {
gnome2_icon_cache_update

elog "XDMCP support requires x11-base/xorg-server[xephyr]."
}

pkg_postrm() {
gnome2_icon_cache_update
}

0 comments on commit 081a6b9

Please sign in to comment.