forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-ruby/selenium-webdriver: add 3.5.2
Package-Manager: Portage-2.3.6, Repoman-2.3.2
- Loading branch information
Showing
2 changed files
with
34 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
33 changes: 33 additions & 0 deletions
33
dev-ruby/selenium-webdriver/selenium-webdriver-3.5.2.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,33 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
USE_RUBY="ruby22 ruby23 ruby24" | ||
|
||
# NOTE: this package contains precompiled code. It appears that all | ||
# source code can be found at https://code.google.com/p/selenium/ but the | ||
# repository is not organized in a way so that we can easily rebuild the | ||
# suited shared object. We'll just try our luck with the precompiled | ||
# objects for now. | ||
|
||
RUBY_FAKEGEM_TASK_DOC="" | ||
RUBY_FAKEGEM_EXTRADOC="CHANGES README.md" | ||
|
||
RUBY_FAKEGEM_TASK_TEST="" | ||
|
||
RUBY_QA_ALLOWED_LIBS="x_ignore_nofocus.so" | ||
QA_PREBUILT="*/x_ignore_nofocus.so" | ||
|
||
inherit ruby-fakegem | ||
|
||
DESCRIPTION="This gem provides Ruby bindings for WebDriver" | ||
HOMEPAGE="https://github.com/seleniumhq/selenium" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="3" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~x86" | ||
IUSE="" | ||
|
||
ruby_add_rdepend ">=dev-ruby/childprocess-0.5.0 | ||
dev-ruby/rubyzip:1" |