forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-games/irrlicht-mt-headers: add 1.9.0.10
Signed-off-by: Marek Szuba <[email protected]>
- Loading branch information
Marek Szuba
committed
Apr 8, 2023
1 parent
9c46e01
commit 08fefc6
Showing
2 changed files
with
33 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST irrlicht-mt-1.9.0.10.tar.gz 898774 BLAKE2B 2b11aead4556127bff7c7f06d16a57632cf1758ad0ddf12e6d9346d80d13c0cd437ccade268db5bec25f8d62cfa61e9ecda07a98d0a82c18b548a1b520dccee2 SHA512 216221b5073d2b234b2d19658b30517c3abb2677c16e3a9b7fd31c15431bd2ffc047a68851c5bebf94aeb178d6b761a80c2f5744a7498cdac1d7b65fed139cc0 | ||
DIST irrlicht-mt-1.9.0.8.tar.gz 909733 BLAKE2B 6c85377b5e426a9f4ba06ea60fb0414fb9598c3b66d01d80da8461d53b16bc1c74ea5f949d0419d01f2d4dccabff20410840dc9380cac3cf5b656b2e073a4636 SHA512 3a5cbcd8d13730e08f24a72b4ceb2a6d3ba1cfa4292475915da6413ab8084d0b7f0b5dc34edc152d5bf516730faf43d983433619b0a1fb15540adb5cab00ca10 |
32 changes: 32 additions & 0 deletions
32
dev-games/irrlicht-mt-headers/irrlicht-mt-headers-1.9.0.10.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,32 @@ | ||
# Copyright 1999-2023 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
MY_PN="${PN%-mt-headers}" | ||
MY_PV="$(ver_rs 3 'mt')" | ||
MY_P="${MY_PN}-${MY_PV}" | ||
# These two should be kept in sync with dev-games/irrlicht-mt | ||
SRC_PN="${PN%-headers}" | ||
SRC_P="${SRC_PN}-${PV}" | ||
|
||
DESCRIPTION="Header files for Minetest's fork of dev-games/irrlicht" | ||
HOMEPAGE="https://github.com/minetest/irrlicht" | ||
SRC_URI="https://github.com/minetest/${MY_PN}/archive/refs/tags/${MY_PV}.tar.gz -> ${SRC_P}.tar.gz" | ||
|
||
LICENSE="ZLIB" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~riscv" | ||
|
||
RDEPEND="!<dev-games/irrlicht-mt-1.9.0.4-r1" | ||
|
||
S="${WORKDIR}"/${MY_P} | ||
|
||
src_configure() { :; } | ||
|
||
src_compile() { :; } | ||
|
||
src_install() { | ||
insinto /usr/include/${SRC_PN/-/} | ||
doins include/* | ||
} |