Skip to content

Commit

Permalink
kde-apps/dolphin: 21.12.2.1 version bump
Browse files Browse the repository at this point in the history
- Fix KNewStuff3 ProvidersUrl

See also:
https://mail.kde.org/pipermail/distributions/2022-February/001124.html
https://mail.kde.org/pipermail/distributions/2022-February/001128.html

- Fix FTP folder ignores default application to open file
KDE-bug: https://bugs.kde.org/show_bug.cgi?id=443253

Package-Manager: Portage-3.0.30, Repoman-3.0.3
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Feb 6, 2022
1 parent ad38b38 commit 0908473
Show file tree
Hide file tree
Showing 2 changed files with 97 additions and 0 deletions.
1 change: 1 addition & 0 deletions kde-apps/dolphin/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST dolphin-21.08.3.tar.xz 5327496 BLAKE2B 864016bdb3b30c181eeb158ad0b418c27556f8e0d1bcd2da495cc387667a99e655abcd320a352157156443ab91bd2b1820dce7cb10a4b8d226b5b07dcb46b167 SHA512 918be8ff9ac01ce9e9f0f575a31e70687b24edc08f022cc991922a136bda5900f5cc431b056d2aac8349858e3b9592c365b1cfa8e4bbf01f86eb7be8cbca751e
DIST dolphin-21.12.2.1.tar.xz 5338960 BLAKE2B 1b89c191f2824eb88b379ea8f72b34d0f28ab463e87fe6eb54fc553e2d2fe4a0379ad0e9b6d713bb5ec91777e29332a45a77cf1dc516bcfeb603881a3e88d9fc SHA512 e80ee65759b8f48cf5d8ec0ec621610bc332f22dfbe01d934f590b49afcd18f79ee08a25c8b516831f1b65d85243c69bb29a520fa83b729e7b505589e2dc02f8
DIST dolphin-21.12.2.tar.xz 5338952 BLAKE2B 3a6a4b622e11bd1eafba137ac6468f1bd82e87b2b3a8ee4c5d3504623a7fa20026fa77ac85136b3a1bfe3c3c522b2ea615b9b9bd6b448b30daae7858ee4a4b87 SHA512 7037aa7c0aab9974ae6eedfe324d241f85458858ea79a8b0beb0c9f241c4e86df4ea17ed0cfe4e601ecb45cac4eb6c5ea3f134385ec719a91d9fe353b578c46e
96 changes: 96 additions & 0 deletions kde-apps/dolphin/dolphin-21.12.2.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,96 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

ECM_HANDBOOK="optional"
ECM_TEST="true"
PVCUT=$(ver_cut 1-3)
KFMIN=5.88.0
QTMIN=5.15.2
VIRTUALX_REQUIRED="test"
inherit ecm kde.org optfeature

DESCRIPTION="Plasma filemanager focusing on usability"
HOMEPAGE="https://apps.kde.org/dolphin/ https://userbase.kde.org/Dolphin"
SRC_URI="mirror://kde/stable/release-service/21.12.2/src/dolphin-21.12.2.1.tar.xz"

LICENSE="GPL-2" # TODO: CHECK
SLOT="5"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
IUSE="activities semantic-desktop telemetry"

DEPEND="
>=dev-qt/qtconcurrent-${QTMIN}:5
>=dev-qt/qtdbus-${QTMIN}:5
>=dev-qt/qtgui-${QTMIN}:5
>=dev-qt/qtwidgets-${QTMIN}:5
>=dev-qt/qtxml-${QTMIN}:5
>=kde-frameworks/kbookmarks-${KFMIN}:5
>=kde-frameworks/kcmutils-${KFMIN}:5
>=kde-frameworks/kcodecs-${KFMIN}:5
>=kde-frameworks/kcompletion-${KFMIN}:5
>=kde-frameworks/kconfig-${KFMIN}:5
>=kde-frameworks/kconfigwidgets-${KFMIN}:5
>=kde-frameworks/kcoreaddons-${KFMIN}:5
>=kde-frameworks/kcrash-${KFMIN}:5
>=kde-frameworks/kdbusaddons-${KFMIN}:5
>=kde-frameworks/ki18n-${KFMIN}:5
>=kde-frameworks/kiconthemes-${KFMIN}:5
>=kde-frameworks/kio-${KFMIN}:5=
>=kde-frameworks/kitemviews-${KFMIN}:5
>=kde-frameworks/kjobwidgets-${KFMIN}:5
>=kde-frameworks/knewstuff-${KFMIN}:5
>=kde-frameworks/knotifications-${KFMIN}:5
>=kde-frameworks/kparts-${KFMIN}:5
>=kde-frameworks/kservice-${KFMIN}:5
>=kde-frameworks/ktextwidgets-${KFMIN}:5
>=kde-frameworks/kwidgetsaddons-${KFMIN}:5
>=kde-frameworks/kwindowsystem-${KFMIN}:5
>=kde-frameworks/kxmlgui-${KFMIN}:5
>=kde-frameworks/solid-${KFMIN}:5
>=media-libs/phonon-4.11.0
activities? ( >=kde-frameworks/kactivities-${KFMIN}:5 )
semantic-desktop? (
>=kde-apps/baloo-widgets-${PVCUT}:5
>=kde-frameworks/baloo-${KFMIN}:5
>=kde-frameworks/kfilemetadata-${KFMIN}:5
)
telemetry? ( dev-libs/kuserfeedback:5 )
"
RDEPEND="${DEPEND}
>=kde-apps/kio-extras-${PVCUT}:5
"

src_configure() {
local mycmakeargs=(
-DCMAKE_DISABLE_FIND_PACKAGE_PackageKitQt5=ON
$(cmake_use_find_package activities KF5Activities)
$(cmake_use_find_package semantic-desktop KF5Baloo)
$(cmake_use_find_package semantic-desktop KF5BalooWidgets)
$(cmake_use_find_package semantic-desktop KF5FileMetaData)
$(cmake_use_find_package telemetry KUserFeedback)
)
ecm_src_configure
}

src_test() {
local myctestargs=(
# servicemenuinstaller requires ruby, no thanks
# dolphinmainwindowtest, kitemlistcontrollertest, kfileitemlistviewtest, kfileitemmodeltest hang forever
# placesitemmodeltest requires DBus
-E "(servicemenuinstaller|dolphinmainwindowtest|kfileitemlistviewtest|kfileitemmodeltest|kitemlistcontrollertest|placesitemmodeltest)"
)
ecm_src_test
}

pkg_postinst() {
if [[ -z "${REPLACING_VERSIONS}" ]]; then
optfeature "compress/extract and other actions" kde-apps/ark:${SLOT}
optfeature "crypto actions" kde-apps/kleopatra:${SLOT}
optfeature "video file thumbnails" kde-apps/ffmpegthumbs:${SLOT}
optfeature "graphics file thumbnails" kde-apps/thumbnailers:${SLOT}
optfeature "'Share' context menu actions" kde-frameworks/purpose:${SLOT}
fi
ecm_pkg_postinst
}

0 comments on commit 0908473

Please sign in to comment.