Skip to content

Commit

Permalink
app-mobilephone/scrcpy: add 2.3.1
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/920032
Signed-off-by: Bernard Cafarelli <[email protected]>
  • Loading branch information
voyageur committed Dec 17, 2023
1 parent f8287c4 commit 09404e5
Show file tree
Hide file tree
Showing 2 changed files with 43 additions and 0 deletions.
2 changes: 2 additions & 0 deletions app-mobilephone/scrcpy/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,6 @@
DIST scrcpy-2.1.1.tar.gz 386002 BLAKE2B 3d1ec3829cc08d36a6b42f7429749000ea5a4aaf2b8501167fe03b68fb722ec9351da9f287aef752fbceebf04db1484071c4fdf3b84bc5d9eb3805f635502951 SHA512 247d2b4d5523412c667b3104621cdbb5d4a47f1fbc34e4fbde242212d9a4a198232d886eb5d4dc8678fbbe97a63d747827986fd34b08b0951bce02f256e65c47
DIST scrcpy-2.2.tar.gz 396529 BLAKE2B 6f11dbde6900ef818dbd3e5f1edb169d8acc2a4940675a2cadaec362c1a56c409fe8bcdeab7fcd208c5b4c038d2ddb5da5b0092d5743b27f3719d0970d5553e5 SHA512 e1518d4eb649f40facfd61c8b29120dd11183dd1e753c3b3914794956f87c09777410d0b9f47a05be2763c92c352afd1ee0ac6077d7319e6b29835e1b1259f04
DIST scrcpy-2.3.1.tar.gz 401278 BLAKE2B 0cb231aef87965f346613987c45a624ad853ad870000d78ccaeda6fabaa39cfbd1fed5da50f028aece96c7c12395edc521bf629d935fb8e45a806e487681e6b8 SHA512 4ef9398f23740edf8d09bb18ecc9f6e120b7d3991b8d359836f5e3f4a568484307a1f020da2edeb3193a4f4d6820b5948d6b80600e7ceeed869a2ed8136bfefd
DIST scrcpy-server-v2.1.1 56995 BLAKE2B 6a089ca33025873f48d62389b17ba6fb6249c007ef7d7fd21883351e7724c3207dce1cea8b655cb949361d26210f5bb6115a2f5f9895c8a3b129652a77848c3d SHA512 f9b27068a92042e6d05ca4d56e6220174fbb008d21c2c423ad3adf91ac1ba0d30cf63a2d9072608adee56f5b49e5a55f9a193737ddf80fb222b447af196c4a90
DIST scrcpy-server-v2.2 64363 BLAKE2B 65f53a9b931ab076f06de174c1212077d5961a28881237967894ca5f9f59006b4974c4fd6c1e878df9fa7804b848a92b03689f07e27fa32489e66dede5220363 SHA512 7020b3e1b78a9e5896355d22855cffd338d2a455367a82a1aad0659511de42bff8112756ed614b56f9945340aeb56f42f6e093263450c08c02dd8774348dd64a
DIST scrcpy-server-v2.3.1 66007 BLAKE2B f3b006bdec8fb3e34474a694fcd5d54fa1caac6b1757cd4ac74d84ce42c9e163e68dbb33985c1474fdeda4c124c317494837c24bc4c18e42cc7e285666d76374 SHA512 9360ad9321554bc9ab38833720e20fada1e0e3a9d1302fced2bbc035b87ea2bbc6802fa8d52fe73ae8d9272ac0f1759c6042badd0043392b90cb68c5c89fc57c
41 changes: 41 additions & 0 deletions app-mobilephone/scrcpy/scrcpy-2.3.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit meson xdg

DESCRIPTION="Display and control your Android device"
HOMEPAGE="https://github.com/Genymobile/scrcpy"
# Source code and server part on Android device
SRC_URI="https://github.com/Genymobile/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
https://github.com/Genymobile/${PN}/releases/download/v${PV}/${PN}-server-v${PV}"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
IUSE="lto"

DEPEND="media-libs/libsdl2[X]
media-video/ffmpeg
virtual/libusb:1"
# Manual install for ppc64 until bug #723528 is fixed
RDEPEND="${DEPEND}
!ppc64? ( dev-util/android-tools )"

src_configure() {
local emesonargs=(
$(meson_use lto b_lto)
-Dprebuilt_server="${DISTDIR}/${PN}-server-v${PV}"
)
meson_src_configure
}

pkg_postinst() {
xdg_pkg_postrm

einfo "If you use pipewire because of a problem with libsdl2 it is possible that"
einfo "scrcpy will not start, in which case start the program by exporting the"
einfo "environment variable SDL_AUDIODRIVER=pipewire."
einfo "For more information see https://github.com/Genymobile/scrcpy/issues/3864."
}

0 comments on commit 09404e5

Please sign in to comment.