Skip to content

Commit

Permalink
www-client/chromium: always pass -Wl,--undefined-version if supported
Browse files Browse the repository at this point in the history
Needed for e.g. mold and also if the ebuild didn't force lld but it's
being used.

Bug: https://bugs.gentoo.org/918897
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Jan 28, 2024
1 parent 45f40d1 commit 09792f6
Show file tree
Hide file tree
Showing 4 changed files with 14 additions and 10 deletions.
5 changes: 3 additions & 2 deletions www-client/chromium/chromium-120.0.6099.129.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -719,10 +719,11 @@ chromium_configure() {
myconf_gn+=" is_clang=false"
fi

# https://bugs.gentoo.org/918897#c32
append-ldflags $(test-flags-CCLD -Wl,--undefined-version)

# Force lld for lto and pgo builds, otherwise disable, bug 641556
if needs_lld || use lto || use pgo; then
# https://bugs.gentoo.org/918897#c32
append-ldflags -Wl,--undefined-version
myconf_gn+=" use_lld=true"
else
myconf_gn+=" use_lld=false"
Expand Down
5 changes: 3 additions & 2 deletions www-client/chromium/chromium-120.0.6099.224.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -719,10 +719,11 @@ chromium_configure() {
myconf_gn+=" is_clang=false"
fi

# https://bugs.gentoo.org/918897#c32
append-ldflags $(test-flags-CCLD -Wl,--undefined-version)

# Force lld for lto and pgo builds, otherwise disable, bug 641556
if needs_lld || use lto || use pgo; then
# https://bugs.gentoo.org/918897#c32
append-ldflags -Wl,--undefined-version
myconf_gn+=" use_lld=true"
else
myconf_gn+=" use_lld=false"
Expand Down
7 changes: 4 additions & 3 deletions www-client/chromium/chromium-121.0.6167.85.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 2009-2023 Gentoo Authors
# Copyright 2009-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
Expand Down Expand Up @@ -760,10 +760,11 @@ chromium_configure() {
myconf_gn+=" is_clang=false"
fi

# https://bugs.gentoo.org/918897#c32
append-ldflags $(test-flags-CCLD -Wl,--undefined-version)

# 641556: Force lld for lto and pgo builds, otherwise disable
if needs_lld || use lto || use pgo; then
# https://bugs.gentoo.org/918897#c32
append-ldflags -Wl,--undefined-version
myconf_gn+=" use_lld=true"
else
# This doesn't prevent lld from being used, but rather prevents gn from forcing it
Expand Down
7 changes: 4 additions & 3 deletions www-client/chromium/chromium-122.0.6261.6.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 2009-2023 Gentoo Authors
# Copyright 2009-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
Expand Down Expand Up @@ -765,9 +765,10 @@ chromium_configure() {
fi
fi

# https://bugs.gentoo.org/918897#c32
append-ldflags $(test-flags-CCLD -Wl,--undefined-version)

if needs_lld ; then
# https://bugs.gentoo.org/918897#c32
append-ldflags -Wl,--undefined-version
myconf_gn+=" use_lld=true"
else
# This doesn't prevent lld from being used, but rather prevents gn from forcing it
Expand Down

0 comments on commit 09792f6

Please sign in to comment.