forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-tv/plex-media-server: version bump to 1.3.2
Package-Manager: portage-2.3.2
- Loading branch information
Jonathan Vasquez
committed
Dec 12, 2016
1 parent
8b80e33
commit 09814b1
Showing
2 changed files
with
115 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST plexmediaserver_1.2.7.2987-1bef33a_amd64.deb 101409368 SHA256 33b21ebb656e1f1011141aff5e6a47946c346392912b4c9ce3049df7e1d9ba08 SHA512 5c9af7d1752eaf1d8d2dd5750c81feea683efbb4703e852bbe980a114eed524d47862518e69881ea574cbcf5b7d8a8871c0a2804a2c10f87028deb05e05ac4cd WHIRLPOOL e8276726858b58526068d47046b974e99965a15b1c994400138ecbd3d40e4713c093d0b01941e6a5bd85f765f406c02d304468941ad259dd19fe6247f18d5d52 | ||
DIST plexmediaserver_1.3.2.3112-1751929_amd64.deb 101296066 SHA256 bf21c4fb7b5e541b51951c81bbd837ad0fc4b3e2b6ef01b0c3513b9b0f319d4d SHA512 216ea7cb942568932eb7bc99d5a745e56a061fdcb22661cb9b145bcbf93cd1e0f7c89cf1f6ae84f27cf9856d5d44a9d63d1d4e31bae75730b4df580faafbe6e3 WHIRLPOOL d17e4c9b8931255451162d94d47dda3252f7a1fa8d0c127d5960e108478cd0455f588c329d62bb94edf6b9b0b9ae619fd0f2ec991bb2f931507fcf96f9614db5 |
114 changes: 114 additions & 0 deletions
114
media-tv/plex-media-server/plex-media-server-1.3.2.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,114 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
inherit eutils user systemd unpacker | ||
|
||
MINOR1="3112" | ||
MINOR2="1751929" | ||
|
||
_APPNAME="plexmediaserver" | ||
_USERNAME="plex" | ||
_SHORTNAME="${_USERNAME}" | ||
_FULL_VERSION="${PV}.${MINOR1}-${MINOR2}" | ||
|
||
URI="https://downloads.plex.tv/plex-media-server" | ||
|
||
DESCRIPTION="A free media library that is intended for use with a plex client." | ||
HOMEPAGE="http://www.plex.tv/" | ||
SRC_URI=" | ||
amd64? ( ${URI}/${_FULL_VERSION}/plexmediaserver_${_FULL_VERSION}_amd64.deb )" | ||
SLOT="0" | ||
LICENSE="Plex" | ||
RESTRICT="mirror strip" | ||
KEYWORDS="-* ~amd64" | ||
|
||
DEPEND=" | ||
net-dns/avahi | ||
sys-apps/fix-gnustack" | ||
|
||
QA_DESKTOP_FILE="usr/share/applications/plexmediamanager.desktop" | ||
QA_PREBUILT="*" | ||
QA_MULTILIB_PATHS=( | ||
"usr/lib/${_APPNAME}/.*" | ||
"usr/lib/${_APPNAME}/Resources/Python/lib/python2.7/.*" | ||
) | ||
|
||
EXECSTACKED_BINS=( "${ED%/}/usr/lib/plexmediaserver/libgnsdk_dsp.so*" ) | ||
|
||
S="${WORKDIR}" | ||
|
||
pkg_setup() { | ||
enewgroup ${_USERNAME} | ||
enewuser ${_USERNAME} -1 /bin/bash /var/lib/${_APPNAME} ${_USERNAME} | ||
} | ||
|
||
src_unpack() { | ||
unpack_deb ${A} | ||
} | ||
|
||
src_install() { | ||
# Copy main files over to image and preserve permissions so it is portable | ||
cp -rp usr/ "${ED}" || die | ||
|
||
# Move the config to the correct place | ||
local CONFIG_VANILLA="${S}/etc/default/plexmediaserver" | ||
local CONFIG_PATH="/etc/${_SHORTNAME}" | ||
dodir "${CONFIG_PATH}" | ||
insinto "${CONFIG_PATH}" | ||
doins "${CONFIG_VANILLA}" | ||
|
||
# Remove Debian specific files | ||
rm -rf "${ED%/}/usr/share/doc" || die | ||
|
||
# Make sure the logging directory is created | ||
local LOGGING_DIR="/var/log/pms" | ||
dodir "${LOGGING_DIR}" | ||
chown "${_USERNAME}":"${_USERNAME}" "${ED%/}/${LOGGING_DIR}" || die | ||
|
||
# Create default library folder with correct permissions | ||
local DEFAULT_LIBRARY_DIR="/var/lib/${_APPNAME}" | ||
dodir "${DEFAULT_LIBRARY_DIR}" | ||
chown "${_USERNAME}":"${_USERNAME}" "${ED%/}/${DEFAULT_LIBRARY_DIR}" || die | ||
|
||
# Install the OpenRC init/conf files | ||
doinitd "${FILESDIR}/init.d/${PN}" | ||
doconfd "${FILESDIR}/conf.d/${PN}" | ||
|
||
_handle_multilib | ||
|
||
# Install systemd service file | ||
local INIT_NAME="${PN}.service" | ||
local INIT="${FILESDIR}/systemd/${INIT_NAME}" | ||
systemd_newunit "${INIT}" "${INIT_NAME}" | ||
|
||
_remove_execstack_markings | ||
} | ||
|
||
pkg_postinst() { | ||
einfo "" | ||
elog "Plex Media Server is now installed. Please check the configuration file in /etc/plex/${_SHORTNAME} to verify the default settings." | ||
elog "To start the Plex Server, run 'rc-config start plex-media-server', you will then be able to access your library at http://<ip>:32400/web/" | ||
} | ||
|
||
# Finds out where the library directory is for this system | ||
# and handles ldflags as to not break library dependencies | ||
# during rebuilds. | ||
_handle_multilib() { | ||
# Prevent revdep-rebuild, @preserved-rebuild breakage | ||
cat > "${T}"/66plex <<-EOF || die | ||
LDPATH="${EPREFIX}/usr/$(get_libdir)/plexmediaserver" | ||
EOF | ||
|
||
doenvd "${T}"/66plex | ||
} | ||
|
||
# Remove execstack flag from library so that it works in hardened setups. | ||
_remove_execstack_markings() { | ||
for f in "${EXECSTACKED_BINS[@]}"; do | ||
# Unquoting 'f' so that expansion works. | ||
fix-gnustack -f ${f} > /dev/null | ||
done | ||
} |