forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Closes: https://bugs.gentoo.org/770523 Package-Manager: Portage-3.0.21, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <[email protected]>
- Loading branch information
Showing
2 changed files
with
132 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST mysql-connector-odbc-8.0.22-src.tar.gz 3726015 BLAKE2B 055920446767b0c9a30a0ca4773e71d662b398a9849df1a0b7975d71a21cfb23f540d8dda5430c717569f173e63673d3e51b025bb098e51202093d33e19bc142 SHA512 c613ae60346cea2e57bade89d813fd5ac21d0712d3d751e3acbc275421da6ac7593afc3da9fb6d161ee413f60e76e670f0c84876591f331925c980d969db4e8c | ||
DIST mysql-connector-odbc-8.0.23-src.tar.gz 3726277 BLAKE2B 21b5e6f3f7e77d6107268800441675a230c79071e52db39093fade6e02031c12c96371d165af9459e9739e069e5b4196f0169dff54c0fa300e7a3023e8a82722 SHA512 2f66b5e1796176d638b1209b7d3381c2600a11cc88fa0dfb1f29b16a6c59386926674d5581d4843036d061af09312d58620484730bd7cdad36c0a0dcd45d49a9 | ||
DIST mysql-connector-odbc-8.0.25-src.tar.gz 3736461 BLAKE2B 888219340ed2ea86194b2aeab04719c58f2bdfaedb4364492eab2d8cce4b7617a259ae075fada3f55f2bd475d310b5a98642a791ac1efff22a8ceda31bbdf89c SHA512 b2df4134d89600708f30866ded6d915246d36eea087a5c86c0030ba55a1a96c7ee37f023183a28e2f731851969ee802846012e4435fb86a38f7a0f09571d32ac | ||
DIST mysql-connector-odbc-8.0.26-src.tar.gz 3760542 BLAKE2B e0da539743335bc70a7b809759121d5186782df27c301dc9bb34a73d5584540906df72f0e2b2bfa8af47587693063286cd3eadd3b69f77398264463e69a20e35 SHA512 caed3db20fb42df5123356a973e4f8cc1b162be0ada1de881981237e9a7b39d95f3f0aa48fceeff23139c3d05fc24115bf900206db7a497f4ed734a2234eb528 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,131 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
CMAKE_ECLASS=cmake | ||
|
||
inherit cmake-multilib | ||
|
||
MAJOR="$(ver_cut 1-2)" | ||
MY_PN="mysql-connector-odbc" | ||
MY_P="${MY_PN}-${PV/_p/r}-src" | ||
|
||
DESCRIPTION="ODBC driver for MySQL" | ||
HOMEPAGE="https://dev.mysql.com/downloads/connector/odbc/" | ||
SRC_URI="https://dev.mysql.com/get/Downloads/Connector-ODBC/${MAJOR}/${MY_P}.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="${MAJOR}" | ||
KEYWORDS="~amd64 ~ppc ~x86" | ||
IUSE="" | ||
|
||
RDEPEND=" | ||
dev-db/unixODBC[${MULTILIB_USEDEP}] | ||
>=dev-db/mysql-connector-c-8.0:0=[${MULTILIB_USEDEP}] | ||
" | ||
DEPEND="${RDEPEND}" | ||
S=${WORKDIR}/${MY_P} | ||
|
||
# Careful! | ||
DRIVER_NAME="${PN}-${SLOT}" | ||
|
||
# Patch document path so it doesn't install files to /usr | ||
PATCHES=( | ||
"${FILESDIR}/${MAJOR}-cmake-doc-path.patch" | ||
"${FILESDIR}/${PN}-8.0.19-cxxlinkage.patch" | ||
) | ||
|
||
src_prepare() { | ||
# Remove Tests | ||
sed -i -e "s/ADD_SUBDIRECTORY(test)//" \ | ||
"${S}/CMakeLists.txt" | ||
|
||
cmake_src_prepare | ||
} | ||
|
||
multilib_src_configure() { | ||
CMAKE_BUILD_TYPE="RelWithDebInfo" | ||
|
||
mycmakeargs+=( | ||
-DCMAKE_C_FLAGS_RELWITHDEBINFO=-DNDEBUG | ||
-DCMAKE_CXX_FLAGS_RELWITHDEBINFO=-DNDEBUG | ||
-DMYSQLCLIENT_STATIC_LINKING=OFF | ||
-DMYSQL_CXX_LINKAGE=YES | ||
-DWITH_UNIXODBC=YES | ||
-DWITH_DOCUMENTATION_INSTALL_PATH=${EPREFIX}/usr/share/doc/${PF} | ||
-DLIB_SUBDIR="$(get_libdir)/${PN}-${MAJOR}" | ||
-DMYSQLCLIENT_NO_THREADS=ON | ||
-DDISABLE_GUI=ON | ||
# Don't build "libmysql_strings.so" and "libmysql_sys.so" which are only | ||
# used internally | ||
-DBUILD_SHARED_LIBS=OFF | ||
# The NUMA and LIBWRAP options are not really used. | ||
# They are just copied from the server code | ||
-DWITH_NUMA=OFF | ||
-DWITH_LIBWRAP=OFF | ||
) | ||
|
||
cmake_src_configure | ||
} | ||
|
||
multilib_src_install_all() { | ||
debug-print-function ${FUNCNAME} "$@" | ||
|
||
dodir /usr/share/${PN}-${SLOT} | ||
for i in odbc.ini odbcinst.ini; do | ||
einfo "Building $i" | ||
sed \ | ||
-e "s,__PN__,${DRIVER_NAME},g" \ | ||
-e "s,__PF__,${MAJOR},g" \ | ||
-e "s,lib/libmyodbc3.so,$(get_libdir)/${PN}-${MAJOR}/libmyodbc${SLOT:0:1}a.so,g" \ | ||
>"${D}"/usr/share/${PN}-${SLOT}/${i} \ | ||
<"${FILESDIR}"/${i}.m4 \ | ||
|| die "Failed to build $i" | ||
done | ||
|
||
rm -rf "${ED}/usr/$(get_libdir)/${PN}-${MAJOR}/private" \ | ||
|| die "failed to remove bundled libs" | ||
|
||
mv "${D}/usr/bin/myodbc-installer" \ | ||
"${D}/usr/bin/myodbc-installer-${MAJOR}" || die "failed to move slotted binary" | ||
} | ||
|
||
pkg_config() { | ||
|
||
[ "${ROOT}" != "/" ] && \ | ||
die 'Sorry, non-standard ROOT setting is not supported :-(' | ||
|
||
local msg='MySQL ODBC driver' | ||
local drivers=$(/usr/bin/odbcinst -q -d) | ||
|
||
if echo $drivers | grep -vq "^\[${DRIVER_NAME}\]$" ; then | ||
ebegin "Installing ${msg}" | ||
/usr/bin/odbcinst -i -d -f /usr/share/${PN}-${SLOT}/odbcinst.ini | ||
rc=$? | ||
eend $rc | ||
[ $rc -ne 0 ] && die | ||
else | ||
einfo "Skipping already installed ${msg}" | ||
fi | ||
|
||
local sources=$(/usr/bin/odbcinst -q -s) | ||
msg='sample MySQL ODBC DSN' | ||
if echo $sources | grep -vq "^\[${DRIVER_NAME}-test\]$"; then | ||
ebegin "Installing ${msg}" | ||
/usr/bin/odbcinst -i -s -l -f /usr/share/${PN}-${SLOT}/odbc.ini | ||
rc=$? | ||
eend $rc | ||
[ $rc -ne 0 ] && die | ||
else | ||
einfo "Skipping already installed ${msg}" | ||
fi | ||
} | ||
|
||
pkg_postinst() { | ||
elog "If this is a new install, please run the following command" | ||
elog "to configure the MySQL ODBC drivers and sources:" | ||
elog "emerge --config =${CATEGORY}/${PF}" | ||
elog "Please note that the driver name used to form the DSN now includes the SLOT." | ||
elog "The myodbc-install utility is installed as myodbc-install-${MAJOR}" | ||
} |