Skip to content

Commit

Permalink
app-crypt/keybase: Version bump to keybase-2.5.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.40, Repoman-2.3.9
  • Loading branch information
nicolasbock committed Aug 8, 2018
1 parent 584e539 commit 09b370c
Show file tree
Hide file tree
Showing 2 changed files with 55 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-crypt/keybase/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,3 +4,4 @@ DIST keybase-1.0.48.tar.gz 34026876 BLAKE2B c620a664b47f66932d1b49c22509aac73a6c
DIST keybase-2.0.0.tar.gz 34340958 BLAKE2B fa9bcf2285a987131e00a5bc8b06ad09fa86f3bf3de87cc4e48669131fcf93e2c515435fc1e9d6663455d16744889131d09b5957fa5f78f9d3ecc91d10667bc1 SHA512 d7b91c9a0ef69442501956ba3a09f40490adf76ef38bf945617793a8238daee68f3fc2be7a5d2118531c2364f5604016ec241226a22bd217dbab3dafbf77fd25
DIST keybase-2.1.0.tar.gz 34444571 BLAKE2B 834f1001b136461c5665f12530d660e619d93c8b4e4b5f0c96da94af23f0667c778d7ddabc65d0585ac472cd91f89240bc4260b2034bf20c26b4047839570299 SHA512 0d71a22b5f56442fdc03848f831487da097dc817bfcacfb5a8eea1a9a13e87d231619216b6bab61862de71289373977c4c8d345518152137c8804005bf20e3e4
DIST keybase-2.3.0.tar.gz 34524576 BLAKE2B 5793892b6bcfeafbaebb4a38d35e77d9267a74243da61ecbb7472026b3c500cc6f6cc49dbbec2add65cecae2ce209bb24bc03f2eb393307b82958afeb8824537 SHA512 f2b92ec21fd8cfa182aac7655b836415b902c599f9e3a08a3f84d35c3f3728027a8eef8a06fb8ed4ba77b9a66888f49fd89013304f948c0f0276705f16ca4396
DIST keybase-2.5.0.tar.gz 35012800 BLAKE2B 46cba22bafbfcf519e658a05db349f047a622f30d6ec03d5e8b3c637e7d3351188c65b0725853c4c62da30ea1d4388d19c9a430a9c4d06b14712daca05c468d2 SHA512 05313c4373ffc8fc41097fabfd13fdbf4d0af789257bbbc4a9ff0500ab3ca9c9d5d50ab62bc38b7328aad3cbf631aa55fcd1a74b5dc73f3d31e76851733d7d5f
54 changes: 54 additions & 0 deletions app-crypt/keybase/keybase-2.5.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit golang-build systemd

DESCRIPTION="Client for keybase.io"
HOMEPAGE="https://keybase.io/"
SRC_URI="https://github.com/keybase/client/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

DEPEND="
~app-crypt/kbfs-${PV}"
RDEPEND="
app-crypt/gnupg"

src_unpack() {
unpack "${P}.tar.gz"
ln -vs "client-${PV}" "${P}" || die
mkdir -vp "${S}/src/github.com/keybase" || die
ln -vs "${S}" "${S}/src/github.com/keybase/client" || die
}

src_compile() {
EGO_PN="github.com/keybase/client/go/keybase" \
EGO_BUILD_FLAGS="-tags production -o ${T}/keybase" \
golang-build_src_compile
}

src_test() {
EGO_PN="github.com/keybase/client/go/keybase" \
golang-build_src_test
}

src_install() {
dobin "${T}/keybase"
dobin "${S}/packaging/linux/run_keybase"
systemd_douserunit "${S}/packaging/linux/systemd/keybase.service"
dodir "/opt/keybase"
insinto "/opt/keybase"
doins "${S}/packaging/linux/crypto_squirrel.txt"
}

pkg_postinst() {
elog "Start/Restart keybase: run_keybase"
elog "Run the service: keybase service"
elog "Run the client: keybase login"
ewarn "Note that the user keybasehelper is obsolete and can be removed"
}

0 comments on commit 09b370c

Please sign in to comment.