Skip to content

Commit

Permalink
app-emulation/s6-overlay: new package -- an s6 init system for contai…
Browse files Browse the repository at this point in the history
…ners

Package-Manager: portage-2.2.28
  • Loading branch information
williamh committed Jul 1, 2016
1 parent 13162a4 commit 09e0d4f
Show file tree
Hide file tree
Showing 3 changed files with 71 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/s6-overlay/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST s6-overlay-1.18.1.3.tar.gz 20067 SHA256 15d16c0882a3bc014e6dd7de0f13dbdb2a4acdee4b48365db3d3b18d9c2bed5d SHA512 2b17b86a93e1efc27181a100bb86aacbce2e2c58cfd0d0855a293b99ba5c871a2f17bd10fa14b173b297816ae2d1658aaee2e6a6e25b957ad60f93d535955775 WHIRLPOOL ea53eb5595fbaa7340ae3223a0a885b57c94fa478b9cbe13cfab58c7fc61deb4714ccce624066be363530aa6f664365f36db9d9d84e8142ebc93c158d9de4829
11 changes: 11 additions & 0 deletions app-emulation/s6-overlay/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer>
<email>[email protected]</email>
<name>William Hubbs</name>
</maintainer>
<longdescription lang="en">
This is an s6-based custom init to be used in containers.
</longdescription>
</pkgmetadata>
59 changes: 59 additions & 0 deletions app-emulation/s6-overlay/s6-overlay-1.18.1.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

if [[ ${PV} = 9999 ]]; then
EGIT_REPO_URI="git://github.com/just-containers/${PN}"
inherit git-r3
else
SRC_URI="https://github.com/just-containers/${PN}/archive/v${PV}.tar.gz ->
${P}.tar.gz"
KEYWORDS="~amd64"
inherit vcs-snapshot
fi

DESCRIPTION="an s6-based init system for containers"
HOMEPAGE="https://github.com/just-containers/s6-overlay"

LICENSE="ISC"
SLOT="0"
IUSE=""

DEPEND=""
RDEPEND="sys-apps/s6
sys-apps/s6-portable-utils"

src_install() {
dodoc *.md
cd builder/overlay-rootfs
dobin usr/bin/{fix-attrs,logutil*,print*,with*}

insinto /
doins -r etc init

# create must exist directories
dodir /etc/{cont-init.d,cont-finish.d,fix-attrs.d,services.d}
dodir /etc/s6/init/env-stage2

# create "supervise" directory in fdholder, its needed for no-catchall
# stage2 wake up
dodir /etc/s6/services/s6-fdholderd/supervise
fperms 0700 /etc/s6/services/s6-fdholderd/supervise

# fix misc permissions
fperms 0755 /init
fperms 0755 /etc/s6/init/init-stage1 \
/etc/s6/init/init-stage2 \
/etc/s6/init/init-stage2-redirfd \
/etc/s6/init/init-stage3
fperms 0755 /etc/s6/init-catchall/init-stage1 \
/etc/s6/init-catchall/init-stage2
fperms 0755 /etc/s6/init-no-catchall/init-stage1 \
/etc/s6/init-no-catchall/init-stage2
fperms 0755 /etc/s6/services/.s6-svscan/crash
fperms 0755 /etc/s6/services/.s6-svscan/finish
fperms 0755 /etc/s6/services/s6-fdholderd/run
fperms 0755 /etc/s6/services/s6-svscan-log/run
}

0 comments on commit 09e0d4f

Please sign in to comment.