Skip to content

Commit

Permalink
dev-python/cliff-tablib: Support python3.6
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.41, Repoman-2.3.9
  • Loading branch information
pacho2 committed Jun 27, 2018
1 parent 30cebd5 commit 09f3692
Showing 1 changed file with 27 additions and 0 deletions.
27 changes: 27 additions & 0 deletions dev-python/cliff-tablib/cliff-tablib-1.1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,27 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=7
PYTHON_COMPAT=( python2_7 python3_{4,5,6} )

inherit distutils-r1

DESCRIPTION="Formatter extensions of JSON, YAML, and HTML output for the cliff framework"
HOMEPAGE="https://github.com/dreamhost/cliff-tablib"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

KEYWORDS="~amd64 ~x86"
IUSE="doc examples"
LICENSE="Apache-2.0"
SLOT="0"

RDEPEND="dev-python/tablib[${PYTHON_USEDEP}]
dev-python/cliff[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"

python_install_all() {
# Use IUSE examples for installing the demoapp
use examples && local EXAMPLES=( demoapp/. )
use doc && local HTML_DOCS=( docs/build/html/. )
distutils-r1_python_install_all
}

0 comments on commit 09f3692

Please sign in to comment.