Skip to content

Commit

Permalink
dev-python/Nuitka: Bump to 1.9
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Nov 23, 2023
1 parent 654cfd1 commit 09fce98
Show file tree
Hide file tree
Showing 2 changed files with 53 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/Nuitka/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST Nuitka-1.8.4.tar.gz 3604833 BLAKE2B 32a5169e981e1323e0cc30147bbd6327521f496d3a4bcd0e6d3e811b291c596c50a3cf7602221f24b7a6d82936286bab1a045e65abfa4ddb9f366e23edaad9a2 SHA512 632453e937ca6c895646910ca650d83f9610e0aa4a28d2b2fe608c1bf4138ea06496c2bd2fee24fb4e6224a844437242ff9d21af2221ad2eed2edc77262050c2
DIST Nuitka-1.8.5.tar.gz 3604649 BLAKE2B 146e4f5fafb37fee7c7824fe448db85d3d77d57cadad63c10f237cba969ad81cc7c73eecbf68fcbfb8a1b2e0d8a9439c2435c5c7db16dde04324c3dd0ddb1770 SHA512 660f1480835491473cb4c512ce14109a9d27887e64fdfdfe6c92a59cf59445e7d6068c7859af9942330345b918fe81593c52f8f3b6166d55bad8bbbf362cc05c
DIST Nuitka-1.8.6.tar.gz 3605120 BLAKE2B 5bf40eb8e62f0bd656f94f1c251b8de222d07808c6cbd0be3913b4f10f514c106b0db171a8122d6aaa163376eab9cc835d42a693519e06bb607f06b257a3fe5a SHA512 4cb1737bf95286b69f032ac49b4b2f0b15f068ea7cc22f737388257fe5c400bb3c47561144152a7c8e48426d10579912e5350f7ca7079d73a5a04bfe379ca9d3
DIST Nuitka-1.9.tar.gz 3907890 BLAKE2B e055d94d01ac203d73915e3f331538fbee04aff346faa15571c7ab5c24ac07616ff50bedab9c0832821a16d16cc30b5478d3f7d8ca3338f651f3cca27364f9fa SHA512 b48454a2959ce1479ce9135342dd89e83f33ae184ea38e3f050fff80bbb3320a3864aad1520310677abbfcd89d19da8be895ceed889b846d25fc51459ce78e5a
52 changes: 52 additions & 0 deletions dev-python/Nuitka/Nuitka-1.9.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
PYTHON_COMPAT=( python3_{10..11} )

inherit distutils-r1 flag-o-matic optfeature pypi

DESCRIPTION="Python to native compiler"
HOMEPAGE="
https://www.nuitka.net/
https://github.com/Nuitka/Nuitka/
https://pypi.org/project/Nuitka/
"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~loong ~x86"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND="
dev-util/scons[${PYTHON_USEDEP}]
"
BDEPEND="
${RDEPEND}
test? ( dev-util/ccache )
"

distutils-r1_src_prepare() {
# remove vendored version of SCons that is Python2 only
# this should be removed when upstream removes support for Python2
rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
eapply_user
}

python_install() {
distutils-r1_python_install
doman doc/nuitka3.1 doc/nuitka3-run.1
}

python_test() {
append-ldflags -Wl,--no-warn-search-mismatch
./tests/basics/run_all.py search || die
}

pkg_postinst() {
optfeature "support for stand-alone executables" app-admin/chrpath
}

0 comments on commit 09fce98

Please sign in to comment.