Skip to content

Commit

Permalink
net-fs/netatalk: Version Bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
Signed-off-by: Justin Lecher <[email protected]>
  • Loading branch information
jlec committed Jan 7, 2016
1 parent 8f86e8c commit 0a38d2a
Show file tree
Hide file tree
Showing 2 changed files with 182 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-fs/netatalk/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST netatalk-3.1.6.tar.bz2 1817059 SHA256 2df2b3b12be3f11eddb0fc2f88cb39d09a8c95792a4d97d9dd22127c5a5efb21 SHA512 36bfd3df30f1a3228a6f8f05e7744f9551d01d5a59d9c05e581f731e4fe9417bc1a7178e2e6af1128ea9a5c848bfa9a447ecf22691daa201f1fa37adcbe19be8 WHIRLPOOL 9f52d774487781aa43444bfe920fc07d9b7fe6bece45bca7cb44a9b7bc498ed17662c42d64db0628f668098c0bf7b6cb3f9c813d39e0fdac9f59b7eeae359d5d
DIST netatalk-3.1.7.tar.bz2 1780078 SHA256 e4049399e4e7d477f843a9ec4bd64f70eb7c7af946e890311140fd8fbd4bc071 SHA512 e8b22a156235cb93830ed5045e28346613e354fd830e742b2f7c1fc9302f9bdfce7fb2cc329ce8dfd1442857f96e9e54119a4ac177b6855af9143e64fb2208e7 WHIRLPOOL 3dfbc5c3091388fc2b1e811faf60c274549f5d6e9d7ae2c5dc0552a72ae01b2a075c8f7df634ad99188adc83c19c70ba7060aec80fe5f8783a206e4d5db16ecb
DIST netatalk-3.1.8.tar.bz2 1802404 SHA256 34668d5f53b780e9f143c2d7ee06ebc1c2bd7758c60ca483c8b08da27dcc4d4c SHA512 734745743b2d5fe39f3d6716f377e6255d6a061e3c615a4fe30db388ec6d848f6db063d733dfa24ccf967f1e9042841bce4824f4bed391952c4304ee11e11b0d WHIRLPOOL dff6050c746b301864d34b9577f9cea7195878434306e4ad83032a51ba6841b4b8537db6cedef27642d751beeefacba62026addd4b8f5056a9fe9b0b07bf98d8
181 changes: 181 additions & 0 deletions net-fs/netatalk/netatalk-3.1.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,181 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 )

AUTOTOOLS_AUTORECONF=yes

inherit autotools-utils flag-o-matic multilib pam python-r1 systemd versionator

DESCRIPTION="Open Source AFP server"
HOMEPAGE="http://netatalk.sourceforge.net/"
SRC_URI="mirror://sourceforge/project/${PN}/${PN}/$(get_version_component_range 1-3)/${P}.tar.bz2"

LICENSE="GPL-2 BSD"
SLOT="0/17.0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
IUSE="acl avahi cracklib dbus debug pgp kerberos ldap pam quota samba +shadow ssl static-libs tracker tcpd +utils"

CDEPEND="
!app-editors/yudit
dev-libs/libevent
>=dev-libs/libgcrypt-1.2.3:0
sys-apps/coreutils
>=sys-libs/db-4.2.52:=
sys-libs/tdb
acl? (
sys-apps/attr
sys-apps/acl
)
avahi? ( net-dns/avahi[dbus] )
cracklib? ( sys-libs/cracklib )
dbus? ( sys-apps/dbus dev-libs/dbus-glib )
kerberos? ( virtual/krb5 )
ldap? ( net-nds/openldap )
pam? ( virtual/pam )
ssl? ( dev-libs/openssl:0 )
tcpd? ( sys-apps/tcp-wrappers )
tracker? ( app-misc/tracker )
utils? ( ${PYTHON_DEPS} )
"
RDEPEND="${CDEPEND}
utils? (
dev-lang/perl
dev-python/dbus-python[${PYTHON_USEDEP}]
)"
DEPEND="${CDEPEND}
virtual/yacc
sys-devel/flex"

RESTRICT="test"

REQUIRED_USE="
ldap? ( acl )
utils? ( ${PYTHON_REQUIRED_USE} )"

PATCHES=(
"${FILESDIR}"/${PN}-3.1.7-gentoo.patch
)

src_prepare() {
if ! use utils; then
sed \
-e "s:shell_utils::g" \
-i contrib/Makefile.am || die
fi
autotools-utils_src_prepare
}

src_configure() {
local myeconfargs=()

append-flags -fno-strict-aliasing

if use acl; then
myeconfargs+=( --with-acls $(use_with ldap) )
else
myeconfargs+=( --without-acls --without-ldap )
fi

# Ignore --with-init-style=gentoo, we install the init.d by hand and we avoid having
# to sed the Makefiles to not do rc-update.
# TODO:
# systemd : --with-init-style=systemd
myeconfargs+=(
--disable-silent-rules
$(use_enable avahi zeroconf)
$(use_enable debug)
$(use_enable debug debugging)
$(use_enable pgp pgp-uam)
$(use_enable kerberos)
$(use_enable kerberos krbV-uam)
$(use_enable quota)
$(use_enable tcpd tcp-wrappers)
$(use_with cracklib)
$(use_with dbus afpstats)
$(use_with pam)
$(use_with samba smbsharemodes)
$(use_with shadow)
$(use_with ssl ssl-dir)
$(use_with tracker)
$(use_with tracker tracker-pkgconfig-version $(get_version_component_range 1-2 $(best_version app-misc/tracker | sed 's:app-misc/tracker-::g')))
--enable-overwrite
--disable-krb4-uam
--disable-afs
--with-libevent-header=/usr/include
--with-libevent-lib=/usr/$(get_libdir)
--with-bdb=/usr
--with-uams-path=/usr/$(get_libdir)/${PN}
--disable-silent-rules
--with-init-style=gentoo
--without-libevent
--without-tdb
--with-lockfile=/run/lock/${PN}
)
autotools-utils_src_configure
}

src_install() {
autotools-utils_src_install

if use avahi; then
sed -i -e '/avahi-daemon/s:use:need:g' "${D}"/etc/init.d/${PN} || die
else
sed -i -e '/avahi-daemon/d' "${D}"/etc/init.d/${PN} || die
fi

# The pamd file isn't what we need, use pamd_mimic_system
rm -rf "${ED}/etc/pam.d" || die
pamd_mimic_system netatalk auth account password session

sed \
-e "s|:SBINDIR:|${EPREFIX}/usr/sbin|g" \
-e "s|:PATH_NETATALK_LOCK:|/run/lock/netatalk|g" \
distrib/initscripts/service.systemd.tmpl \
> "${T}"/service.systemd || die
systemd_newunit "${T}"/service.systemd ${PN}.service

use utils && python_foreach_impl python_doscript contrib/shell_utils/afpstats
}

pkg_postinst() {
local fle
if [[ ${REPLACING_VERSIONS} < 3 ]]; then
for fle in afp_signature.conf afp_voluuid.conf; do
if [[ -f "${ROOT}"etc/netatalk/${fle} ]]; then
if [[ ! -f "${ROOT}"var/lib/netatalk/${fle} ]]; then
mv \
"${ROOT}"etc/netatalk/${fle} \
"${ROOT}"var/lib/netatalk/
fi
fi
done

echo ""
elog "Starting from version 3.0 only uses a single init script again"
elog "Please update your runlevels accordingly"
echo ""
elog "Dependencies should be resolved automatically depending on settings"
elog "but please report issues with this on https://bugs.gentoo.org/ if"
elog "you find any."
echo ""
elog "Following config files are obsolete now:"
elog "afpd.conf, netatalk.conf, AppleVolumes.default and afp_ldap.conf"
elog "in favour of"
elog "/etc/afp.conf"
echo ""
elog "Please convert your existing configs before you restart your daemon"
echo ""
elog "The new AppleDouble default backend is appledouble = ea"
elog "Existing entries will be updated on access, but can do an offline"
elog "conversion with"
elog "dbd -ruve /path/to/Volume"
echo ""
elog "For general notes on the upgrade, please visit"
elog "http://netatalk.sourceforge.net/3.0/htmldocs/upgrade.html"
echo ""
fi
}

0 comments on commit 0a38d2a

Please sign in to comment.